Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scsi_asc_key_strings(9s) [opensolaris man page]

scsi_asc_key_strings(9S)				    Data Structures for Drivers 				  scsi_asc_key_strings(9S)

NAME
scsi_asc_key_strings - SCSI ASC ASCQ to message structure SYNOPSIS
#include <sys/scsi/scsi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
The scsi_asc_key_strings structure stores the ASC and ASCQ codes and a pointer to the related ASCII string. STRUCTURE MEMBERS
ushort_t asc; /* ASC code */ ushort_t ascq; /* ASCQ code */ char *message; /* ASCII message string */ asc Contains the ASC key code. ascq Contains the ASCQ code. message Points to the NULL terminated ASCII string describing the asc and ascq condition SEE ALSO
scsi_vu_errmsg(9F) ANSI Small Computer System Interface-2 (SCSI-2) Writing Device Drivers SunOS 5.11 24 Feb 1998 scsi_asc_key_strings(9S)

Check Out this Related Man Page

scsi_validate_sense(9F) 				   Kernel Functions for Drivers 				   scsi_validate_sense(9F)

NAME
scsi_validate_sense - find descriptor in SCSI sense data SYNOPSIS
#include <sys/scsi/scsi.h> int scsi_validate_sense(uint8_t *sense_buffer, int sense_buf_len, int *flags); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
sense_buffer Pointer to a buffer containing SCSI sense data. The sense data is expected in wire format starting at the response code. sense_buf_len Length of sense buffer in bytes. flags Returns additional properties of the sense data. DESCRIPTION
The scsi_validate_sense() function returns the format of the sense data contained in the provided sense buffer. If the response code field in the sense data is not recognized or if there is not enough sense data to include sense key, asc, and ascq then scsi_validate_sense() returns SENSE_UNUSABLE. If the buffer contains usable sense data in fixed format, the function returns SENSE_FIXED_FORMAT. If the buffer contains usable sense data in descriptor format, the function returns SENSE_DESCR_FORMAT. The following flags may be set as appropriate depending on the sense data: SNS_BUF_OVERFLOW The sense data buffer provided for the request is too small to hold all the sense data. SNS_BUF_DEFERRED The sense data contained in the buffer relates to an error that has occurred during the processing of a successfully completed command, such as a cached write that could not be commited to the media. RETURN VALUES
SENSE_UNUSABLE The response code from the sense data is unrecognized or not enough sense data present to provide the sense key, asc, and ascq. SENSE_FIXED_FORMAT The sense data in the buffer is in "fixed format". SENSE_DESCR_FORMAT The sense data in the buffer is in "descriptor format". CONTEXT
The scsi_validate_sense() function can be called from user or interrupt context. SEE ALSO
scsi_ext_sense_fields(9F), scsi_find_sense_descr(9F), scsi_sense_asc(9F), scsi_sense_ascq(9F), scsi_sense_cmdspecific_uint64(9F), scsi_sense_info_uint64(9F), scsi_sense_key(9F) SunOS 5.11 29 Jun 2006 scsi_validate_sense(9F)
Man Page

14 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Trying to block signal

I have this code that doesnt do what it is suppose to do. It should block signal that I send while process is running. I press control+z while this process is running and it should be blocked but it isnt. When i press control+z it gives me this.... + Stopped When I change SIGTSP into SIGINT then... (5 Replies)
Discussion started by: joker40
5 Replies

2. Fedora

How to learn UNIX

First question is how do you learn UNIX on a home lab. I understand that HP-UX isn't free and neither is SCO Unix and they don't run on x86 based systems anyways. The choices I believe are going to be OpenSolaris and FreeBSD. My question is UNIX commands the same across the board so if I learn... (11 Replies)
Discussion started by: michael78
11 Replies

3. Solaris

solaris zones vs container..

kindly share what are difference b/w solaris zones and containers.... (8 Replies)
Discussion started by: Rajesh_Apple
8 Replies

4. Shell Programming and Scripting

What does this mean?

Hello all, I am a newbie in shell scripting. I want to know what does the below text means? 6.355u 1.679s 0:12.68 63.2% 0+0k 0+0io 0pf+0w I am getting this line (on terminal) after every successful execution of my script. Thanks in advance . . :) -MD (15 Replies)
Discussion started by: manands07
15 Replies

5. SCO

Study UNIX Kernel

Hi all, I hope you are fine, I'd like study Os I tried a book like Silberschatz it's a good book but like other books it talks about the concepts abstractly and that's due to it try to encompass many concepts from many operating systems in GENERAL. i am not too much comfortable from these... (20 Replies)
Discussion started by: Abdo_8008
20 Replies

6. UNIX for Dummies Questions & Answers

Change directory for core file

Hi, Some of the process in th environment are producing a core file. These core files are produced by default in the directory from which they were launched. I want to change the default directory to say /tmp of that environment. I am using both Linux and Solaris, so will need the solution... (2 Replies)
Discussion started by: Raj999
2 Replies

7. UNIX for Beginners Questions & Answers

Grep the 'not running' jobs and will send the update in mail with its name(job)

my request is: i have to create a script , which will grep the 'not running' jobs and will send the update in mail with its name(job) Scenario: logged in to machine abc went to particular path: cd /a/b/c then ./script1.sh status (script.sh is a script,whose status gives info about 10 jobs... (1 Reply)
Discussion started by: learner987
1 Replies

8. Solaris

Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD

Hi all, My home server was Solaris for quite a while- I started with an Ultra 2 about 20 years ago, ended with a Blade 2000- but I've transitioned to Linux and am not going back. I miss the Solaris experience a bit (but not the Oracle experience), besides running with modern and small and quiet... (0 Replies)
Discussion started by: gpounce32768
0 Replies

9. Shell Programming and Scripting

Identify problem with while getopts

can anyone spot a problem with the below: $ $ cat getopts.sh #!/bin/sh usage() { echo "myscript.sh local /tmp data.txt 600s -query" 1>&2; exit 1; } while... (4 Replies)
Discussion started by: SkySmart
4 Replies

10. Red Hat

%memused is high

All I see cpu and memory usage are under control, only cache gets high upto 99% using sar -r command I did echo3 and cleaned the drop caches do we need to monitor this , why my application going high upto 99.8% memused in sar command , this is cache memory which is going high will this... (12 Replies)
Discussion started by: anil529
12 Replies

11. Solaris

Solaris 10 - password complexity not working

I have been trying to enable password complexity variables on Solaris 10 by editing the /etc/default/passwd file but none of my changes are taking effect (I'm still able to set passwords that violate the rules I am trying to implement). I've tried an O/S reboot after the changes but that had no... (6 Replies)
Discussion started by: triggerhippie
6 Replies

12. What is on Your Mind?

What is good?

Hello everyone, I am using centos, 1) solaris is free right? 2) I want to learn solaris and install it in a computer that I am mounting, I would like know what is strong in solaris and if do it is wise. I am programmer python, learning machine and programming in general,..any help thanks,.. (6 Replies)
Discussion started by: gitac
6 Replies

13. What is on Your Mind?

PHP Man Pages Now Available (Over 10,000)

Hello! Yesterday we added over 10,000 PHP man pages to our man page section. I've not yet got our unique and special recursive search feature working; but you can still access the PHP man pages directly by selecting PHP in the man sets drop down menu (left side) and then section 3 (right... (3 Replies)
Discussion started by: Neo
3 Replies

14. UNIX for Advanced & Expert Users

Shopt -s histappend

What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file. # When the shell exits, append to the history file instead of overwriting it shopt -s histappend (3 Replies)
Discussion started by: cokedude
3 Replies