Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat_named(9s) [opensolaris man page]

kstat_named(9S) 					    Data Structures for Drivers 					   kstat_named(9S)

NAME
kstat_named - structure for named kstats SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
Named kstats are an array of name-value pairs. These pairs are kept in the kstat_named structure. When a kstat is created by kstat_cre- ate(9F), the driver specifies how many of these structures will be allocated. The structures are returned as an array pointed to by the ks_data field. STRUCTURE MEMBERS
union { char c[16]; long l; ulong_t ul; longlong_t ll; u_longlong_t ull; } value; /* value of counter */ The only member exposed to drivers is the value member. This field is a union of several data types. The driver must specify which type it will use in the call to kstat_named_init(). SEE ALSO
kstat_create(9F), kstat_named_init(9F) Writing Device Drivers SunOS 5.11 4 Apr 1994 kstat_named(9S)

Check Out this Related Man Page

kstat_named_init(9F)					   Kernel Functions for Drivers 				      kstat_named_init(9F)

NAME
kstat_named_init, kstat_named_setstr - initialize a named kstat SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> void kstat_named_init(kstat_named_t *knp, const char *name, uchar_t data_type); void kstat_named_setstr(kstat_named_t *knp, const char *str); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
knp Pointer to a kstat_named(9S) structure. name The name of the statistic. data_type The type of value. This indicates which field of the kstat_named(9S) structure should be used. Valid values are: KSTAT_DATA_CHAR The "char" field. KSTAT_DATA_LONG The "long" field. KSTAT_DATA_ULONG The "unsigned long" field. KSTAT_DATA_LONGLONG Obsolete. Use KSTAT_DATA_INT64. KSTAT_DATA_ULONGLONG Obsolete. Use KSTAT_DATA_UINT64. KSTAT_DATA_STRING Arbitrary length "long string" field. str Pointer to a NULL-terminated string. DESCRIPTION
kstat_named_init() associates a name and a type with a kstat_named(9S) structure. kstat_named_setstr() associates str with the named kstat knp. It is an error for knp to be of type other than KSTAT_DATA_STRING. The string argument must remain valid even after the function that is calling kstat_named_setstr() is returned. This is the only supported method of changing the value of long strings. RETURN VALUES
None. CONTEXT
kstat_named_init() and kstat_named_setstr() can be called from user or kernel context. SEE ALSO
kstat_create(9F), kstat_install(9F), kstat(9S), kstat_named(9S) Writing Device Drivers SunOS 5.11 29 Feb 2008 kstat_named_init(9F)
Man Page