Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_idevice_cookie(9s) [opensolaris man page]

ddi_idevice_cookie(9S)					    Data Structures for Drivers 				    ddi_idevice_cookie(9S)

NAME
ddi_idevice_cookie - device interrupt cookie SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information. DESCRIPTION
The ddi_idevice_cookie_t structure contains interrupt priority and interrupt vector information for a device. This structure is useful for devices having programmable bus-interrupt levels. ddi_add_intr(9F) assigns values to the ddi_idevice_cookie_t structure members. STRUCTURE MEMBERS
u_short idev_vector; /* interrupt vector */ ushort_t idev_priority; /* interrupt priority */ The idev_vector field contains the interrupt vector number for vectored bus architectures such as VMEbus. The idev_priority field contains the bus interrupt priority level. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
ddi_add_intr(9F), Intro(9F) Writing Device Drivers SunOS 5.11 19 Oct 2005 ddi_idevice_cookie(9S)

Check Out this Related Man Page

ddi_intr_hilevel(9F)					   Kernel Functions for Drivers 				      ddi_intr_hilevel(9F)

NAME
ddi_intr_hilevel - indicate interrupt handler type SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_hilevel(dev_info_t *dip, uint_t inumber); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information. PARAMETERS
dip Pointer to dev_info structure. inumber Interrupt number. DESCRIPTION
The ddi_intr_hilevel() function returns non-zero if the specified interrupt is a "high level" interrupt. High level interrupts must be handled without using system services that manipulate thread or process states, because these interrupts are not blocked by the scheduler. In addition, high level interrupt handlers must take care to do a minimum of work because they are not preemptable. A typical high level interrupt handler would put data into a circular buffer and schedule a soft interrupt by calling ddi_trigger_soft- intr(). The circular buffer could be protected by using a mutex that was properly initialized for the interrupt handler. The ddi_intr_hilevel() function can be used before calling ddi_add_intr() to decide which type of interrupt handler should be used. Most device drivers are designed with the knowledge that the devices they support will always generate low level interrupts, however some devices, for example those using SBus or VME bus level 6 or 7 interrupts must use this test because on some machines those interrupts are high level (above the scheduler level) and on other machines they are not. RETURN VALUES
non-zero indicates a high-level interrupt. CONTEXT
These functions can be called from useruser, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
ddi_add_intr(9F), Intro(9F), mutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_intr_hilevel(9F)
Man Page