Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

device-blksize(9p) [opensolaris man page]

size(9P)						   Kernel Properties for Drivers						  size(9P)

NAME
size, Nblock, blksize, device-nblocks, device-blksize - device size properties DESCRIPTION
A driver can communicate size information to the system by the values associated with following properties. Size information falls into two categories: device size associated with a dev_info_t node, and minor node size associated with a ddi_create_minor_node(9F) dev_t (parti- tion). device size property names: device-nblocks An int64_t property representing device size in device-blksizeblocks. device-blksize An integer property representing the size in bytes of a block. If defined, the value must be a power of two. If not defined, DEV_BSIZE is implied. minor size property names: Size An int64_t property representing the size in bytes of a character minor device (S_IFCHR spec_type in ddi_create_minor_node). Nblocks An int64_t property representing the number blocks, in device-blksize units, of a block minor device (S_IFBLK spec_type in ddi_create_minor_node). blksize An integer property representing the size in bytes of a block. If defined, the value must be a power of two. If not defined, DEV_BSIZE is implied. A driver that implements both block and character minor device nodes should support both "Size" and "Nblocks". Typically, the following is true: Size = Nblocks * blksize. A driver where all ddi_create_minor_node(9F) calls for a given instance are associated with the same physical block device should implement "device-nblocks". If the device has a fixed block size with a value other than DEV_BSIZE then "device-blksize" should be implemented. The driver is responsible for ensuring that property values are updated when device, media, or partition sizes change. For each represented item, if its size is know to be zero, the property value should be zero. If its size is unknown, the property should not be defined. A driver may choose to implement size properties within its prop_op(9E) implementation. This reduces system memory since no space is used to store the properties. The DDI property interfaces deal in signed numbers. All Size(9P) values should be considered unsigned. It is the responsibility of the code dealing with the property value to ensure that an unsigned interpretation occurs. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attach(9E), detach(9E), prop_op(9E), ddi_create_minor_node(9F), inquiry-vendor-id(9P) Writing Device Drivers SunOS 5.11 23 Janl2008 size(9P)

Check Out this Related Man Page

no-involuntary-power-cycles(9P) 			   Kernel Properties for Drivers			   no-involuntary-power-cycles(9P)

NAME
no-involuntary-power-cycles - device property to prevent involuntary power cycles DESCRIPTION
A device that might be damaged by power cycles should export the boolean (zero length) property no-involuntary-power-cycles to notify the system that all power cycles for the device must be under the control of the device driver. The presence of this property prevents power from being removed from a device or any ancestor of the device while the device driver is detached, unless the device was voluntarily powered off as a result of the device driver calling pm_lower_power(9F). The presence of no-involuntary-power-cycles also forces attachment of the device driver during a CPR suspend operation and prevents the suspend from taking place, unless the device driver returns DDI_SUCCESS when its detach(9E) entry point is called with DDI_SUSPEND. The presence of no-involuntary-power-cycles does not prevent the system from being powered off due to a halt(1M) or uadmin(1M) invocation, except for CPR suspend. This property can be exported by a device that is not power manageable, in which case power is not removed from the device or from any of its ancestors, even when the driver for the device and the drivers for its ancestors are detached. EXAMPLES
Example 1: Use of Property in Driver's Configuration File The following is an example of a no-involuntary-power-cycles entry in a driver's .conf file: no-involuntary-power-cycles=1; ... Example 2: Use of Property in attach() Function The following is an example of how the preceding .conf file entry would be implemented in the attach(9E) function of a driver: xxattach(dev_info_t *dip, ddi_attach_cmd_t cmd) { ... if (ddi_prop_create(DDI_DEV_T_NONE, dip, DDI_PROP_CANSLEEP, "no-involuntary-power-cycles", NULL, 0) != DDI_PROP_SUCCESS) goto failed; ... } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), pm(7D), attach(9E), detach(9E), ddi_prop_create(9F) Writing Device Drivers SunOS 5.10 22 Mar 2001 no-involuntary-power-cycles(9P)
Man Page