Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

device-blksize(9p) [opensolaris man page]

size(9P)						   Kernel Properties for Drivers						  size(9P)

NAME
size, Nblock, blksize, device-nblocks, device-blksize - device size properties DESCRIPTION
A driver can communicate size information to the system by the values associated with following properties. Size information falls into two categories: device size associated with a dev_info_t node, and minor node size associated with a ddi_create_minor_node(9F) dev_t (parti- tion). device size property names: device-nblocks An int64_t property representing device size in device-blksizeblocks. device-blksize An integer property representing the size in bytes of a block. If defined, the value must be a power of two. If not defined, DEV_BSIZE is implied. minor size property names: Size An int64_t property representing the size in bytes of a character minor device (S_IFCHR spec_type in ddi_create_minor_node). Nblocks An int64_t property representing the number blocks, in device-blksize units, of a block minor device (S_IFBLK spec_type in ddi_create_minor_node). blksize An integer property representing the size in bytes of a block. If defined, the value must be a power of two. If not defined, DEV_BSIZE is implied. A driver that implements both block and character minor device nodes should support both "Size" and "Nblocks". Typically, the following is true: Size = Nblocks * blksize. A driver where all ddi_create_minor_node(9F) calls for a given instance are associated with the same physical block device should implement "device-nblocks". If the device has a fixed block size with a value other than DEV_BSIZE then "device-blksize" should be implemented. The driver is responsible for ensuring that property values are updated when device, media, or partition sizes change. For each represented item, if its size is know to be zero, the property value should be zero. If its size is unknown, the property should not be defined. A driver may choose to implement size properties within its prop_op(9E) implementation. This reduces system memory since no space is used to store the properties. The DDI property interfaces deal in signed numbers. All Size(9P) values should be considered unsigned. It is the responsibility of the code dealing with the property value to ensure that an unsigned interpretation occurs. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attach(9E), detach(9E), prop_op(9E), ddi_create_minor_node(9F), inquiry-vendor-id(9P) Writing Device Drivers SunOS 5.11 23 Janl2008 size(9P)

Check Out this Related Man Page

removable-media(9P)                                        Kernel Properties for Drivers                                       removable-media(9P)

NAME
removable-media - removable media device property DESCRIPTION
A device that supports removable media--such as CDROM, JAZZ, and ZIP drives--and that supports power management and expects automatic mounting of the device via the volume manager should export the boolean (zero length) property removable-media. This property enables the system to make the power state of the device dependent on the power state of the frame buffer and monitor. See the power.conf(4) discussion of the device-dependency-property entry for more information. Devices that behave like removable devices (such as PC ATA cards, where the controller and media both are removed at the same time) should also export this property. EXAMPLES
Example 1: removable-media Entry An example of a removable-media entry from the .conf file of a driver is shown below. # This entry keeps removable media from being powered down unless # the console framebuffer and monitor are powered down # removable-media=1; Example 2: Implementation in attach() Below is an example of how the entry above would be implemented in the attach(9E) function of the driver. xxattach(dev_info_t *dip, ddi_attach_cmd_t cmd) { ... if (ddi_prop_create(DDI_DEV_T_NONE, dip, DDI_PROP_CANSLEEP, "removable-media", NULL, 0)) != DDI_PROP_SUCCESS) goto failed; ... } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
power.conf(4), pm(7D), attach(9E), detach(9E), ddi_prop_create(9F) Writing Device Drivers SunOS 5.10 15 Jun 2001 removable-media(9P)
Man Page