Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

usb_get_string_descr(9f) [opensolaris man page]

usb_get_string_descr(9F)				   Kernel Functions for Drivers 				  usb_get_string_descr(9F)

NAME
usb_get_string_descr - Get string descriptor from device SYNOPSIS
#include <sys/usb/usba.h> int usb_get_string_descr(dev_info_t *dip, uint16_t langid, uint8_t index, char *buf, size_t buflen); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. langid Language ID. Currently only USB_LANG_ID (English ascii) is valid. index String index indicating descriptor to retrieve. buf Address into which the string descriptor is placed. buflen Size of buf in bytes. DESCRIPTION
The usb_get_string_descr() function retrieves a parsed string descriptor from a device. dip specifies the device, while index indicates which descriptor to return. String descriptors provide information about other descriptors, or information that is encoded in other descriptors, in readable form. Many descriptor types have one or more index fields which identify string descriptors. (See Sections 9.5 and 9.6 of the USB 2.0 specifica- tion.) For example, a configuration descriptor's seventh byte contains the string descriptor index describing a specific configuration. Retrieved descriptors that do not fit into buflen bytes are truncated. All returned descriptors are null-terminated. RETURN VALUES
USB_SUCCESS String descriptor is returned in buf. USB_INVALID_ARGS dip or buf are NULL, or index or buflen is 0. USB_FAILURE Descriptor cannot be retrieved. CONTEXT
May be called from user or kernel context. EXAMPLES
/* Get the first string descriptor. */ char buf[SIZE]; if (usb_get_string_descr( dip, USB_LANG_ID, 0, buf, SIZE) == USB_SUCCESS) { cmn_err (CE_NOTE, "%s%d: %s", ddi_driver_name(dip), ddi_get_instance(dip), buf); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_get_dev_data(9F), usb_string_descr(9S) SunOS 5.11 5 Jan 2004 usb_get_string_descr(9F)

Check Out this Related Man Page

usb_cfg_descr(9S)					    Data Structures for Drivers 					 usb_cfg_descr(9S)

NAME
usb_cfg_descr - USB configuration descriptor SYNOPSIS
#include <sys/usb/usba.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
The usb_cfg_descr_t configuration descriptor defines attributes of a configuration. A configuration contains one or more interfaces. A con- figuration descriptor acts as a header for the group of other descriptors describing the subcomponents (for example, interfaces and end- points) of a configuration. Please refer to Section 9.6.3 of the USB 2.0 specification. The USB 2.0 specification is available at www.usb.org. One or more configuration descriptors are retrieved from a USB device during device enumeration. They can be accessed via usb_get_dev_data(9F). A configuration descriptor has the following fields: uint8_t bLength Size of this descriptor in bytes. uint8_t bDescriptorType Set to USB_DESCR_TYPE_CFG. uint16_t wTotalLength Total length of data returned including this and all other descriptors in this configuration. uint8_t bNumInterfaces Number of interfaces in this configuration. uint8_t bConfigurationValue ID of this configuration (1-based). uint8_t iConfiguration Index of optional configuration string. Valid if > 0. uint8_t bmAttributes Configuration characteristics (See below). uint8_t bMaxPower Maximum power consumption, in 2mA units. Configuration descriptors define the following bmAttributes: USB_CFG_ATTR_SELFPWR - Set if config not using bus power. USB_CFG_ATTR_REMOTE_WAKEUP - Set if config supports rem wakeup. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusbu | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_get_string_descr(9F), usb_parse_data(9F), usb_ctrl_request(9S), usb_dev_descr(9S), usb_dev_qlf_descr(9S), usb_ep_descr(9S), usb_if_descr(9S), usb_other_speed_cfg_descr(9S), usb_string_descr(9S) SunOS 5.11 5 Jan 2004 usb_cfg_descr(9S)
Man Page