Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

samestr(9f) [opensolaris man page]

SAMESTR(9F)						   Kernel Functions for Drivers 					       SAMESTR(9F)

NAME
SAMESTR, samestr - test if next queue is in the same stream SYNOPSIS
#include <sys/stream.h> int SAMESTR(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue. DESCRIPTION
The SAMESTR() function is used to see if the next queue in a stream (if it exists) is the same type as the current queue (that is, both are read queues or both are write queues). This function accounts for the twisted queue connections that occur in a STREAMS pipe and should be used in preference to direct examination of the q_next field of queue(9S) to see if the stream continues beyond q. RETURN VALUES
The SAMESTR() function returns 1 if the next queue is the same type as the current queue. It returns 0 if the next queue does not exist or if it is not the same type. CONTEXT
The SAMESTR() function can be called from user, interrupt, context. SEE ALSO
OTHERQ(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 SAMESTR(9F)

Check Out this Related Man Page

RD(9F)							   Kernel Functions for Drivers 						    RD(9F)

NAME
RD, rd - get pointer to the read queue SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> queue_t *RD(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the write queue whose read queue is to be returned. DESCRIPTION
The RD() function accepts a write queue pointer as an argument and returns a pointer to the read queue of the same module. CAUTION: Make sure the argument to this function is a pointer to a write queue. RD() will not check for queue type, and a system panic could result if it is not the right type. RETURN VALUES
The pointer to the read queue. CONTEXT
The RD() function can be called from user, interrupt, or kernel context. EXAMPLES
Example 1 Function page reference See the qreply(9F) function page for an example of RD(). SEE ALSO
qreply(9F), WR(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 RD(9F)
Man Page

2 More Discussions You Might Find Interesting

1. Filesystems, Disks and Memory

Unix hash queue

How is the hash queue categorized? I am trying to understand the free list vs the hash queue and i'm just not getting it. The book im using is written like you already have a degree in Unix architecture. Maybe someone knows a web site that explains this in laymans terms. A Unix architecture for... (1 Reply)
Discussion started by: HPCnewbie
1 Replies

2. AIX

Performance monitoring

Hi All I am looking for a script that would collect statistics in a summarised format. CPU, Memory,Swap, Wait queue, Run queue and disk activity. Something that would allow me to profile the environment based on a 1 line output that I could run every 15 min. Thx Junaid (1 Reply)
Discussion started by: jhansrod
1 Replies