Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_kstat_create(9f) [opensolaris man page]

net_kstat_create(9F)					   Kernel Functions for Drivers 				      net_kstat_create(9F)

NAME
net_kstat_create - create and initialize a new kstat for a specific instance of IP SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/neti.h> kstat_t *net_kstat_create(netid_t netid, char *module, int instance, char *name, char *class, uchar_type type, ulong_t ndata, uchar_t ks_flag); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
netid IP instance identifier. module The name of the provider's module (such as "sd", "esp", ...). The "core" kernel uses the name "unix". instance The provider's instance number, as from ddi_get_instance(9F). Modules which do not have a meaningful instance number should use 0. name A pointer to a string that uniquely identifies this structure. Only KSTAT_STRLEN - 1 characters are significant. class The general class that this kstat belongs to. The following classes are currently in use: disk, tape, net, controller, vm, kvm, hat, streams, kstat, and misc. type The type of kstat to allocate. Valid types are: KSTAT_TYPE_NAMED Allows more than one data record per kstat. KSTAT_TYPE_INTR Interrupt; only one data record per kstat. KSTAT_TYPE_IO I/O; only one data record per kstat ndata The number of type-specific data records to allocate. ks_flag A bit-field of various flags for this kstat. ks_flag is some combination of: KSTAT_FLAG_VIRTUAL Tells kstat_create() not to allocate memory for the kstat data section; instead, the driver will set the ks_data field to point to the data it wishes to export. This provides a convenient way to export existing data structures. KSTAT_FLAG_WRITABLE Makes the kstat data section writable by root. KSTAT_FLAG_PERSISTENT Indicates that this kstat is to be persistent over time. For persistent kstats, kstat_delete(9F) simply marks the kstat as dormant; a subsequent kstat_create() reactivates the kstat. This feature is provided so that statistics are not lost across driver close/open (such as raw disk I/O on a disk with no mounted partitions.) Note: Persistent kstats cannot be virtual, since ks_data points to garbage as soon as the driver goes away. DESCRIPTION
The net_kstat_create() function allocates and initializes a kstat(9S) structure. See kstat_create(9F) for a complete discussion of this function. RETURN VALUES
If successful, net_kstat_create() returns a pointer to the allocated kstat. NULL is returned upon failure. CONTEXT
The net_kstat_create() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
ddi_get_instance(9F), kstat_create(9F), kstat_delete(9F), net_kstat_delete(9F), hook_t(9S), kstat_named(9S) SunOS 5.11 1 May 2008 net_kstat_create(9F)

Check Out this Related Man Page

kstat_lookup(3KSTAT)					Kernel Statistics Library Functions				      kstat_lookup(3KSTAT)

NAME
kstat_lookup, kstat_data_lookup - find a kstat by name SYNOPSIS
cc [ flag... ] file... -lkstat [ library...] #include <kstat.h> kstat_t *kstat_lookup(kstat_ctl_t *kc, char *ks_module, int ks_instance, char *ks_name); void *kstat_data_lookup(kstat_t *ksp, char *name); DESCRIPTION
The kstat_lookup() function traverses the kstat chain, kc->kc_chain, searching for a kstat with the same ks_module, ks_instance, and ks_name fields; this triplet uniquely identifies a kstat. If ks_module is NULL, ks_instance is -1, or ks_name is NULL, those fields will be ignored in the search. For example, kstat_lookup(kc, NULL, -1, "foo") will find the first kstat with name "foo". The kstat_data_lookup() function searches the kstat's data section for the record with the specified name. This operation is valid only for those kstat types that have named data records: KSTAT_TYPE_NAMED and KSTAT_TYPE_TIMER. RETURN VALUES
The kstat_lookup() function returns a pointer to the requested kstat if it is found. Otherwise it returns NULL and sets errno to indicate the error. The kstat_data_lookup() function returns a pointer to the requested data record if it is found. Otherwise it returns NULL and sets errno to indicate the error . ERRORS
The kstat_lookup() and kstat_data_lookup() functions will fail if: EINVAL An attempt was made to look up data for a kstat that was not of type KSTAT_TYPE_NAMED or KSTAT_TYPE_TIMER. ENOENT The requested kstat could not be found. FILES
/dev/kstat kernel statistics driver ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Stable | +-----------------------------+-----------------------------+ |MT-Level |Unsafe | +-----------------------------+-----------------------------+ SEE ALSO
kstat(3KSTAT), kstat_chain_update(3KSTAT), kstat_open(3KSTAT), kstat_read(3KSTAT), attributes(5) SunOS 5.11 3 Aug 2004 kstat_lookup(3KSTAT)
Man Page