Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_isvalidchecksum(9f) [opensolaris man page]

net_isvalidchecksum(9F) 				   Kernel Functions for Drivers 				   net_isvalidchecksum(9F)

NAME
net_isvalidchecksum - verify layer 3 and layer 4 checksums SYNOPSIS
#include <sys/neti.h> int net_isvalidchecksum(const net_data_t net, mblk_t *mb); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). mb the mblk structure holding a packet that is the subject of this query. DESCRIPTION
The net_isvalidchecksum() function verifies the layer 3 checksum (and, in some case, the layer 4 checksum) in the packet. If possible, fields that are used by hardware checksum'ing are examined rather than manually verifying that the checksums are present for packets received from a network interface. For both IPv4 and IPv6, TCP, UDP and ICMP (including ICMPV6 for IPv6) layer 4 checksums are currently validated. RETURN VALUES
The net_isvalidchecksum() function returns: -1 The network protocol does not support this function. 0 The packet does not contain partial checksums. 1 The packet does contain partial checksums. CONTEXT
The net_isvalidchecksum() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_ispartialchecksum(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_isvalidchecksum(9F)

Check Out this Related Man Page

net_getifname(9F)					   Kernel Functions for Drivers 					 net_getifname(9F)

NAME
net_getifname - determine the name given to a network interface SYNOPSIS
#include <sys/neti.h> int net_getifname(const net_data_t net, const phy_if_t ifp, char *buffer, size_t buflen); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F). buffer pointer to the buffer in which to write the interface name. buflen size of the buffer in which to store the interface name. DESCRIPTION
The net_getifname() function copies the name of the network interface into the buffer provided. The name will always be null-terminated. If the buffer is too small to fit both the interface name and the null-terminated name, the name in the buffer is truncated to fit. See net_phygetnext(9F) for an example on how to use this function. RETURN VALUES
The net_getifname() function returns: -1 The network protocol does not support this function. 0 Successful completion. 1 Unsuccessful. CONTEXT
The net_getifname() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F) SunOS 5.11 1 May 2008 net_getifname(9F)
Man Page