Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_getlifaddr(9f) [opensolaris man page]

net_getlifaddr(9F)					   Kernel Functions for Drivers 					net_getlifaddr(9F)

NAME
net_getlifaddr - determine a network address for a given interface SYNOPSIS
#include <sys/neti.h> int net_getlifaddr(const net_data_t net, const phy_if_t ifp, const net_if_t lif, int const type, struct sockaddr* storage); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F), indicating which network interface the infor- mation should be returned from. lif indicates the logical interface from which to fetch the address. type indicates what type of address should be returned. See below for more details on this field. storage pointer to an area of memory to store the address data. DESCRIPTION
The net_getlifaddr() function retrieves the address information for each logical interface. Each call to net_getlifaddr() requires that the caller pass a pointer to an array of address information types to retrieve, and an accompanying pointer to an array of pointers to struct sockaddr structures to which to copy the address information. See net_lifgetnext(9F) for an example on how to use this function. Each member of the address type array should be one of the values listed here. NA_ADDRESS Return the network address associated with the logical interface (lif) that belongs to the network interface (ifp). NA_PEER Return the address assigned to the remote host for point to point network interfaces for the given network/logical inter- face. NA_BROADCAST Return the broadcast address assigned to the given network/logical interface for network interfaces that support broadcast packets. NA_NETMASK Return the netmask associated with the given network/logical interface for network interfaces that support broadcast pack- ets. RETURN VALUES
The net_getlifaddr() function returns: -1 The network protocol does not support this function. 0 Successful completion. 1 Unsuccessful. CONTEXT
The net_getifaddr() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_lifgetnext(9F), net_phylookup(9F), net_phygetnext(9F)net_protocol_lookup(9F) SunOS 5.11 13 Oct 2008 net_getlifaddr(9F)

Check Out this Related Man Page

net_protocol_lookup(9F) 				   Kernel Functions for Drivers 				   net_protocol_lookup(9F)

NAME
net_protocol_lookup - locate an implementation of a network layer protocol SYNOPSIS
#include <sys/neti.h> net_data_t net_protocol_lookup(netid_t id, const char *protocol); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
id network instance identifier. family name of the network protocol to find. DESCRIPTION
The net_protocol_lookup() function attempts to locate a data structure that defines what capabilities it is exporting through this inter- face. The value returned by this call is guaranteed to be valid until it is passed into a call to net_protocol_release(9F), after which it should no longer be treated as valid. The protocol must be a registered name of a network protocol that has been registered. The symbols NHF_INET and NHF_INET6 should be passed to net_protocol_lookup() as the protocol name to gain access to either IPv4 or IPv6 respectively. RETURN VALUES
The net_protocol_lookup() function returns NULL if it does not find any knowledge about the network protocol referenced. Otherwise, it returns a value that can be used with other calls in this framework. CONTEXT
The net_protocol_lookup() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_protocol_release(9F), attributes(5) SunOS 5.11 1 May 2008 net_protocol_lookup(9F)
Man Page