Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

mioc2ack(9f) [opensolaris man page]

mioc2ack(9F)						   Kernel Functions for Drivers 					      mioc2ack(9F)

NAME
mioc2ack - Convert an M_IOCTL message to an M_IOCACK message SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
mp M_IOCTL message. dp Payload to associate with M_IOCACK message. count Value to set the ioc_count of the iocblk(9S) to. rval Value to set the ioc_rval of the iocblk(9S) to. DESCRIPTION
The mioc2ack() function converts an M_IOCTL message into an M_IOCACK message using the supplied arguments. To convert the message, mioc2ack() changes the message type to M_IOCACK, sets the ioc_count and ioc_rval members of the iocblk(9S) associ- ated with mp to the passed-in values, and clears the ioc_error field. Further, it frees any message blocks chained off of mp->b_cont and resets mp->b_cont to dp. Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr to be dp->b_rptr + count (that is, it sets dp to be exactly count bytes in length). RETURN VALUES
None. CONTEXT
This function can be called from user, kernel or interrupt context. SEE ALSO
miocack(9F), miocnak(9F), iocblk(9S) STREAMS Programming Guide SunOS 5.11 9 June 2004 mioc2ack(9F)

Check Out this Related Man Page

mcopyout(9F)						   Kernel Functions for Drivers 					      mcopyout(9F)

NAME
mcopyout - Convert an M_IOCTL or M_IOCDATA message to an M_COPYOUT SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> void mcopyout(mblk_t *mp, void *private, size_t size, void *useraddr, mblk_t *dp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
mp M_IOCTL or M_IOCDATA message. private Value to set the cq_private field of the copyreq(9S) to. size Value to set the cq_size field of the copyreq(9S) to. useraddr Optionally, the value to set the cq_addr field of the copyreq(9S) to. dp Optionally, the payload to copy out. DESCRIPTION
The mcopyout() function converts an M_IOCTL or M_IOCDATA message into an M_COPYOUT message using the supplied arguments. To convert the message, mcopyout() changes the message type to M_COPYOUT, and its payload from a iocblk(9S) to a copyreq(9S). Since the iocblk(9S) and copyreq(9S) are designed to overlay one another, the only fields which must be updated are cq_private, cq_size, and cq_addr, which are set to the supplied values. If useraddr is passed as NULL, the M_IOCTL must be transparent and cq_addr is assigned the pointer- sized quantity found at mp->b_cont->b_rptr. If dp is not NULL, any trailing message blocks associated with mp are freed, mp->b_cont is reset to dp and dp->b_wptr is set to dp->b_rptr + size. Otherwise, any trailing message blocks are unaffected. RETURN VALUES
None. CONTEXT
This function can be called from user, kernel or interrupt context. SEE ALSO
mcopyin(9F), copyreq(9S), iocblk(9S) STREAMS Programming Guide SunOS 5.10 9 June 2004 mcopyout(9F)
Man Page