Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_enter_critical(9f) [opensolaris man page]

ddi_enter_critical(9F)					   Kernel Functions for Drivers 				    ddi_enter_critical(9F)

NAME
ddi_enter_critical, ddi_exit_critical - enter and exit a critical region of control SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> unsigned int ddi_enter_critical(void); void ddi_exit_critical(unsignedint ddic); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddic The returned value from the call to ddi_enter_critical() must be passed to ddi_exit_critical(). DESCRIPTION
Nearly all driver operations can be done without any special synchronization and protection mechanisms beyond those provided by, for exam- ple, mutexes (see mutex(9F)). However, for certain devices there can exist a very short critical region of code which must be allowed to run uninterrupted. The function ddi_enter_critical() provides a mechanism by which a driver can ask the system to guarantee to the best of its ability that the current thread of execution will neither be preempted nor interrupted. This stays in effect until a bracketing call to ddi_exit_critical() is made (with an argument which was the returned value from ddi_enter_critical()). The driver may not call any functions external to itself in between the time it calls ddi_enter_critical() and the time it calls ddi_exit_critical(). RETURN VALUES
The ddi_enter_critical() function returns an opaque unsigned integer which must be used in the subsequent call to ddi_exit_critical(). CONTEXT
This function can be called from user, interrupt, or kernel context. WARNINGS
Driver writers should note that in a multiple processor system this function does not temporarily suspend other processors from executing. This function also cannot guarantee to actually block the hardware from doing such things as interrupt acknowledge cycles. What it can do is guarantee that the currently executing thread will not be preempted. Do not write code bracketed by ddi_enter_critical() and ddi_exit_critical() that can get caught in an infinite loop, as the machine may crash if you do. SEE ALSO
mutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_enter_critical(9F)

Check Out this Related Man Page

CRITICAL_ENTER(9)                                          BSD Kernel Developer's Manual                                         CRITICAL_ENTER(9)

NAME
critical_enter, critical_exit -- enter and exit a critical region SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> void critical_enter(void); void critical_exit(void); DESCRIPTION
These functions are used to prevent preemption in a critical region of code. All that is guaranteed is that the thread currently executing on a CPU will not be preempted. Specifically, a thread in a critical region will not migrate to another CPU while it is in a critical region. The current CPU may still trigger faults and exceptions during a critical section; however, these faults are usually fatal. The critical_enter() and critical_exit() functions manage a per-thread counter to handle nested critical sections. If a thread is made runnable that would normally preempt the current thread while the current thread is in a critical section, then the preemption will be deferred until the current thread exits the outermost critical section. Note that these functions are not required to provide any inter-CPU synchronization, data protection, or memory ordering guarantees and thus should not be used to protect shared data structures. These functions should be used with care as an infinite loop within a critical region will deadlock the CPU. Also, they should not be inter- locked with operations on mutexes, sx locks, semaphores, or other synchronization primitives. One exception to this is that spin mutexes include a critical section, so in certain cases critical sections may be interlocked with spin mutexes. HISTORY
These functions were introduced in FreeBSD 5.0. BSD October 5, 2005 BSD
Man Page