Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_parse_cistpl_spcl(9f) [opensolaris man page]

csx_Parse_CISTPL_SPCL(9F)				   Kernel Functions for Drivers 				 csx_Parse_CISTPL_SPCL(9F)

NAME
csx_Parse_CISTPL_SPCL - parse the Special Purpose tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_SPCL(client_handle_t ch, tuple_t *tu, cistpl_spcl_t *csp); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). csp Pointer to a cistpl_spcl_t structure which contains the parsed CISTPL_SPCL tuple information upon return from this function. DESCRIPTION
This function parses the Special Purpose tuple, CISTPL_SPCL, into a form usable by PC Card drivers. The CISTPL_SPCL tuple is identified by an identification field that is assigned by PCMCIA or JEIDA. A sequence field allows a series of CISTPL_SPCL tuples to be used when the data exceeds the size that can be stored in a single tuple; the maximum data area of a series of CISTPL_SPCL tuples is unlimited. Another field gives the number of bytes in the data field in this tuple. STRUCTURE MEMBERS
The structure members of cistpl_date_t are: uint32_t id; /* tuple contents identification */ uint32_t seq; /* data sequence number */ uint32_t bytes; /* number of bytes following */ uchar_t data[CIS_MAX_TUPLE_DATA_LEN]; The fields are defined as follows: id This field contains a PCMCIA or JEIDA assigned value that identifies this series of one or more CISTPL_SPCL tuples. These field values are assigned by contacting either PCMCIA or JEIDA. seq This field contains a data sequence number. CISTPL_SPCL_SEQ_END is the last tuple in sequence. bytes This field contains the number of data bytes in the data[CIS_MAX_TUPLE_DATA_LEN]. data The data component of this tuple. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 20 Dec 1996 csx_Parse_CISTPL_SPCL(9F)

Check Out this Related Man Page

csx_GetTupleData(9F)					   Kernel Functions for Drivers 				      csx_GetTupleData(9F)

NAME
csx_GetTupleData - return the data portion of a tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetTupleData(client_handle_t ch, tuple_t *tu); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure. DESCRIPTION
This function returns the data portion of a tuple, as returned by the csx_GetFirstTuple(9F) and csx_GetNextTuple(9F) functions. STRUCTURE MEMBERS
The structure members of tuple_t are: The fields are defined as follows: uint32_t Socket; /* socket number */ uint32_t Attributes; /* tuple attributes*/ cisdata_t DesiredTuple; /* tuple to search for*/ cisdata_t TupleOffset; /* tuple data offset*/ cisdata_t TupleDataMax; /* max tuple data size*/ cisdata_t TupleDataLen; /* actual tuple data length*/ cisdata_t TupleData[CIS_MAX_TUPLE_DATA_LEN]; /* tuple body data buffer*/ cisdata_t TupleCode; /* tuple type code*/ cisdata_t TupleLink; /* tuple link */ Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Attributes Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. DesiredTuple Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. TupleOffset This field allows partial tuple information to be retrieved, starting anywhere within the tuple. TupleDataMax This field is the size of the tuple data buffer that Card Services uses to return raw tuple data from csx_GetTuple- Data(9F). It can be larger than the number of bytes in the tuple data body. Card Services ignores any value placed here by the client. TupleDataLen This field is the actual size of the tuple data body. It represents the number of tuple data body bytes returned. TupleData This field is an array of bytes containing the raw tuple data body contents. TupleCode Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. TupleLink Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_ARGS Data from prior csx_GetFirstTuple(9F) or csx_GetNextTuple(9F) is corrupt. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_NO_MORE_ITEMS Card Services was not able to read the tuple from the PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_ParseTuple(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 20 Dec 1996 csx_GetTupleData(9F)
Man Page