Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_maplogsocket(9f) [opensolaris man page]

csx_MapLogSocket(9F)					   Kernel Functions for Drivers 				      csx_MapLogSocket(9F)

NAME
csx_MapLogSocket - return the physical socket number associated with the client handle SYNOPSIS
#include <sys/pccard.h> int32_t csx_MapLogSocket(client_handle_t ch, map_log_socket_t *ls); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). ls Pointer to a map_log_socket_t structure. DESCRIPTION
This function returns the physical socket number associated with the client handle. STRUCTURE MEMBERS
The structure members of map_log_socket_t are: uint32_t LogSocket; /* logical socket number */ uint32_t PhyAdapter; /* physical adapter number */ uint32_t PhySocket; /* physical socket number */ The fields are defined as follows: LogSocket Not used by this implementation of Card Services and can be set to any arbitrary value. PhyAdapter Returns the physical adapter number, which is always 0 in the Solaris implementation of Card Services. PhySocket Returns the physical socket number associated with the client handle. The physical socket number is typically used as part of an error or message string or if the client creates minor nodes based on the physical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_MapLogSocket(9F)

Check Out this Related Man Page

csx_ValidateCIS(9F)					   Kernel Functions for Drivers 				       csx_ValidateCIS(9F)

NAME
csx_ValidateCIS - validate the Card Information Structure (CIS) SYNOPSIS
#include <sys/pccard.h> int32_t csx_ValidateCIS(client_handle_t ch, cisinfo_t *ci); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). ci Pointer to a cisinfo_t structure. DESCRIPTION
This function validates the Card Information Structure (CIS) on the PC Card in the specified socket. STRUCTURE MEMBERS
The structure members of cisinfo_t are: uint32_t Socket; /* socket number to validate CIS on */ uint32_t Chains; /* number of tuple chains in CIS */ uint32_t Tuples; /* total number of tuples in CIS */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Chains This field returns the number of valid tuple chains located in the CIS. If 0 is returned, the CIS is not valid. Tuples This field is a Solaris-specific extension and it returns the total number of tuples on all the chains in the PC Card's CIS. RETURN VALUES
CS_SUCCESS Successful operation. CS_NO_CIS No CIS on PC Card or CIS is invalid. CS_NO_CARD No PC Card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_ParseTuple(9F), csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_ValidateCIS(9F)
Man Page

8 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

client app not letting go of socket

Ok here's the situation We have an application that our users log into over the network to one of our unix boxes (Solaris 8). I had this situation occur the other day where an user claimed that he totally shutdown the app because it froze up and wasn't able to log back in. I performed a... (1 Reply)
Discussion started by: fusion99
1 Replies

2. HP-UX

Socket implementation differences

Hi Can anybody tell what are the socket implementation differences between hp 10.x and Solaris 9? Does this affect the application (any) when I migrate from Hp to Solaris? Charles C. (3 Replies)
Discussion started by: charlcy
3 Replies

3. Shell Programming and Scripting

Unix Services (Solaris 9)

(2 Replies)
Discussion started by: BCarlson
2 Replies

4. IP Networking

Bad Address

I am trying to write a C server code that will handle WWW request from client. i am very new to socket programming. i can very well setup the socket...but when an incomin request comes from a browser, the progrom exits with an error message "Bad address". the following is the code. please do help... (1 Reply)
Discussion started by: shankarramv
1 Replies

5. UNIX for Dummies Questions & Answers

hi i need help with socket programming

in socket programming how can i : Create for example 3 blank files, namely: server, client, network •Server: act as servers/provider, will receive all requests from different client •Client: requesters •Network: middle-layer of communication between server & client any tips or... (6 Replies)
Discussion started by: kedah160
6 Replies

6. Solaris

vendor of physical host with Solaris OS

(0 Replies)
Discussion started by: epriya2003
0 Replies

7. Shell Programming and Scripting

Solaris sun4v - how do you determine physical RAM?

(9 Replies)
Discussion started by: thomn8r
9 Replies

8. Hardware

seeking QUIET hardware Sparc Solaris 8/Openwin

I have several applications locked to Solaris 8 (and older) and have been very happy with my Sparcs and Ultras but am getting tinnitus problems from fans and disks. Any tips on a quiet thin client (with decent graphics, not video or gaming level but 24bit and multi monitor would be useful) that... (0 Replies)
Discussion started by: batchman
0 Replies