Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

backq(9f) [opensolaris man page]

backq(9F)						   Kernel Functions for Drivers 						 backq(9F)

NAME
backq - get pointer to the queue behind the current queue SYNOPSIS
#include <sys/stream.h> queue_t *backq(queue_t *cq); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
cq The pointer to the current queue. queue_t is an alias for the queue(9S) structure. DESCRIPTION
The backq() function returns a pointer to the queue preceding cq (the current queue). If cq is a read queue, backq() returns a pointer to the queue downstream from cq, unless it is the stream end. If cq is a write queue, backq() returns a pointer to the next queue upstream from cq, unless it is the stream head. RETURN VALUES
If successful, backq() returns a pointer to the queue preceding the current queue. Otherwise, it returns NULL. CONTEXT
The backq() function can be called from user, interrupt, or kernel context. SEE ALSO
queue(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 backq(9F)

Check Out this Related Man Page

RD(9F)							   Kernel Functions for Drivers 						    RD(9F)

NAME
RD, rd - get pointer to the read queue SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> queue_t *RD(queue_t *q); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the write queue whose read queue is to be returned. DESCRIPTION
The RD() function accepts a write queue pointer as an argument and returns a pointer to the read queue of the same module. CAUTION: Make sure the argument to this function is a pointer to a write queue. RD() will not check for queue type, and a system panic could result if it is not the right type. RETURN VALUES
The pointer to the read queue. CONTEXT
RD() can be called from user or interrupt context. EXAMPLES
Example 1: Function page reference See the qreply(9F) function page for an example of RD(). SEE ALSO
qreply(9F), WR(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 15 Nov 1991 RD(9F)
Man Page

6 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

date program in ksh

#Author : kkodava #!/usr/bin/ksh #Use of this program is You can findout the no of days & day of starting and ending dates #usage no_of_days startdate<yyyymmdd> enddate<yyyymmdd> syy=`echo $1|cut -c1-4` smm=`echo $1|cut -c5-6` sdd=`echo $1|cut -c7-8` eyy=`echo $2|cut -c1-4` emm=`echo... (1 Reply)
Discussion started by: krishna
1 Replies

2. UNIX for Dummies Questions & Answers

awk field not recognized in backquotes

Hi, I am writing a script to use awk to generate a set of cp commands from an input file abc. file abc: /data/a.dbf /data/june/b.dbf desired output: cp -pr a.dbf /data/a.dbf cp -pr b.dbf /data/june/b.dbf script: $ cat abc | awk '{ print "cp -pr '`basename $1`' " $1 }' I tried to... (4 Replies)
Discussion started by: voa2mp3
4 Replies

3. Shell Programming and Scripting

perl scalar variable in backquoted string

hi I've been searching all over the internet to simply do the following: $tempfile = "/usr/school/tempfile.dat"; $myvar = param('add'); ###add is the variable assigned to a popup menu `ls -l $myvar * >> $tempfile` ###I also tried `ls -l ${myvar}* >>$tempfile` open(ADDLIST,... (6 Replies)
Discussion started by: mehdi9
6 Replies

4. Shell Programming and Scripting

variable redirect messing up a sed command.

Not sure if that title is decent, but here we go. I'm running this string of commands: qstat -f $1 | sed 's/^*//' | sed -n -e ":a" -e "$ s/\n//gp;N;b a" | sed 's/\\,/,/' | awk -F"PBS_O_WORKDIR=" '{print $2}' | awk -F",PBS_O_SYSTEM" '{print $1}'In case you're curious is takes the output of a PBS... (3 Replies)
Discussion started by: dhibbit
3 Replies

5. Shell Programming and Scripting

how to print a backquote in csh

A quick question. Can anyone tell me how to print a backquote character to a file in csh. e.g. I need to print the below line to a file in csh. How to do it. Thanks. `uuencode something something` (1 Reply)
Discussion started by: pok.fung
1 Replies

6. Shell Programming and Scripting

Remove backquotes from file

Hello, I have a few thousand files that contain backquotes (`) which were a typo in the program. Now I only want to delete these backquotes from these files. In these cases I normally use the sed command in a script, but I can't seem to get sed to remove the backquotes. I tried several... (6 Replies)
Discussion started by: bckoop
6 Replies