Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

networks(4) [opensolaris man page]

networks(4)							   File Formats 						       networks(4)

NAME
networks - network name database SYNOPSIS
/etc/inet/networks /etc/networks DESCRIPTION
The networks file is a local source of information regarding the networks which comprise the Internet. The networks file can be used in conjunction with, or instead of, other networks sources, including the NIS maps networks.byname and networks.byaddr and the NIS+ table networks. Programs use the getnetbyname(3SOCKET) routines to access this information. The network file has a single line for each network, with the following information: official-network-name network-number aliases Items are separated by any number of SPACE or TAB characters. A `#' indicates the beginning of a comment. Characters up to the end of the line are not interpreted by routines which search the file. This file is normally created from the official network database maintained at the Network Information Control Center (NIC), though local changes may be required to bring it up to date regarding unofficial aliases and/or unknown networks. Network numbers may be specified in the conventional dot (`.') notation using the inet_network routine from the Internet address manipula- tion library, inet(7P). Network names may contain any printable character other than a field delimiter, NEWLINE, or comment character. SEE ALSO
getnetbyaddr(3SOCKET), getnetbyname(3SOCKET), inet(3SOCKET), nsswitch.conf(4), inet(7P) NOTES
The official SVR4 name of the networks file is /etc/inet/networks. The symbolic link /etc/networks exists for BSD compatibility. The network number in networks database is the host address shifted to the right by the number of 0 bits in the address mask. For example, for the address 24.132.47.86 that has a mask of fffffe00, its network number is 803351. This is obtained when the address is shifted right by 9 bits. The address maps to 12.66.23. The trailing 0 bits should not be specified. The network number here is different from that described in netmasks(4). For this example, the entry in netmasks would be 24.132.46.0 fffffe00. SunOS 5.11 17 Jan 2002 networks(4)

Check Out this Related Man Page

GETNETENT(3)						     Linux Programmer's Manual						      GETNETENT(3)

NAME
getnetent, getnetbyname, getnetbyaddr, setnetent, endnetent - get network entry SYNOPSIS
#include <netdb.h> struct netent *getnetent(void); struct netent *getnetbyname(const char *name); struct netent *getnetbyaddr(long net, int type); void setnetent(int stayopen); void endnetent(void); DESCRIPTION
The getnetent() function reads the next line from the file /etc/networks and returns a structure netent containing the broken out fields from the line. The /etc/networks file is opened if necessary. The getnetbyname() function returns a netent structure for the line from /etc/networks that matches the network name. The getnetbyaddr() function returns a netent structure for the line that matches the network number net of type type. The setnetent() function opens and rewinds the /etc/networks file. If stayopen is true (1), then the file will not be closed between calls to getnetbyname() and getnetbyaddr(). The endservent() function closes /etc/networks. The netent structure is defined in <netdb.h> as follows: struct netent { char *n_name; /* official network name */ char **n_aliases; /* alias list */ int n_addrtype; /* net address type */ unsigned long int n_net; /* network number */ } The members of the netent structure are: n_name The official name of the network. n_aliases A zero terminated list of alternative names for the network. n_addrtype The type of the network number; always AF_INET. n_net The network number in host byte order. RETURN VALUE
The getnetent(), getnetbyname() and getnetbyaddr() functions return the netent structure, or a NULL pointer if an error occurs or the end of the file is reached. FILES
/etc/networks networks database file CONFORMING TO
BSD 4.3 SEE ALSO
getprotoent(3), getservent(3), networks(5) RFC 1101 BSD
1993-05-15 GETNETENT(3)
Man Page