Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

alias(4) [opensolaris man page]

alias(4)							   File Formats 							  alias(4)

NAME
alias - alias table file of encoding names SYNOPSIS
/usr/lib/iconv/alias DESCRIPTION
This file contains the alias table of encoding names for iconv_open(3C). The format of the alias table is as follows: "%s %s ", <variant encoding name>, <canonical encoding name> The string specified for the variant encoding name is case-insensitive. A line beginning with '#' is treated as a comment. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
iconv(3C), iconv_close(3C), iconv_open(3C), attributes(5) SunOS 5.11 2 Oct 2001 alias(4)

Check Out this Related Man Page

iconv_open(3C)						   Standard C Library Functions 					    iconv_open(3C)

NAME
iconv_open - code conversion allocation function SYNOPSIS
#include <iconv.h> iconv_t iconv_open(const char *tocode, const char *fromcode); DESCRIPTION
The iconv_open() function returns a conversion descriptor that describes a conversion from the codeset specified by the string pointed to by the fromcode argument to the codeset specified by the string pointed to by the tocode argument. For state-dependent encodings, the con- version descriptor will be in a codeset-dependent initial shift state, ready for immediate use with the iconv(3C) function. Settings of fromcode and tocode and their permitted combinations are implementation-dependent. The iconv_open() function supports the alias of the encoding name specified in tocode and fromcode. The alias table of the encoding name is described in the file /usr/lib/iconv/alias. See alias(4). A conversion descriptor remains valid in a process until that process closes it. For examples using the iconv_open() function, see iconv(3C). RETURN VALUES
Upon successful completion iconv_open() returns a conversion descriptor for use on subsequent calls to iconv(). Otherwise, iconv_open() returns (iconv_t) -1 and sets errno to indicate the error. ERRORS
The iconv_open function may fail if: EMFILE {OPEN_MAX} files descriptors are currently open in the calling process. ENFILE Too many files are currently open in the system. ENOMEM Insufficient storage space is available. EINVAL The conversion specified by fromcode and tocode is not supported by the implementation. FILES
/usr/lib/iconv/alias alias table file of the encoding name ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Standard | +-----------------------------+-----------------------------+ |MT-Level |MT-Safe | +-----------------------------+-----------------------------+ SEE ALSO
exec(2), iconv(3C), iconv_close(3C), malloc(3C), alias(4), attributes(5) NOTES
The iconv_open() function uses malloc(3C) to allocate space for internal buffer areas. iconv_open() may fail if there is insufficient stor- age space to accommodate these buffers. Portable applications must assume that conversion descriptors are not valid after a call to one of the exec functions (see exec(2)). SunOS 5.10 2 Oct 2001 iconv_open(3C)
Man Page

14 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

adding a new alias to Aliases

when we invoke a line we write alias aliasname " " but i have on the original line "specific string" so it must be alias aliasname " "specific string" " and it cause me trouble what can i do ? (5 Replies)
Discussion started by: eynkesef
5 Replies

2. UNIX for Dummies Questions & Answers

Some basic questions

Hi- Newbie here with some basic questions: 1) I can't get alias to work. I tried alias ll='ls -al', but it doesn't work. When just typing 'alias', the new definition doesn't appear. I'm in a bash shell -- is that the problem. I tried switching to csh, but that didn't seem to help. This... (5 Replies)
Discussion started by: Aworstell
5 Replies

3. Shell Programming and Scripting

please help me regarding alias

Dear All, I have given alias to run a script which will calculate memory and cpu utilization as "utils" in my bash shell. Even i have given this entry in .profile and .bashrc in my home directory. It is working fine. Now my question is that I want to use this alias in... (17 Replies)
Discussion started by: naree
17 Replies

4. UNIX for Dummies Questions & Answers

alias in bash shell for CTRL + l

Is it possible to create an alias wherein it will use a keystroke. Like to clear the screen in bash i have to use CTRL + l. I want to make an alias 'c' out of this. Thanks. (6 Replies)
Discussion started by: or_knob
6 Replies

5. UNIX for Dummies Questions & Answers

Printing a part of a string

hi I have the input as follows ABC =893 JKL = "jee" alias PQR = 9833 alias STUVE = "kuiue" I should be able to print as follows ABC JKL alias PQR alias STUVE Thanks Suresh (7 Replies)
Discussion started by: ssuresh1999
7 Replies

6. Shell Programming and Scripting

alias help needed

Dear All, I need help in seeting alias i use follwing command to set an alias alias hitme='cd /tmp; ls-ltr' alias is set, but when I disconnect from the session and relogin, and try to use the same alias it doesnt work. I think i have to save my alias into enviornmental variables,... (7 Replies)
Discussion started by: jojo123
7 Replies

7. UNIX for Dummies Questions & Answers

alias

Hi, I have created alias in UNIX environment (ie in .cshrc file). But when i use the alias in the UNIX script, getting an error message as that is not found. But when i use that alias, outside the script it is working fine. Let me know if you need more details For example: alias cderror... (6 Replies)
Discussion started by: Naveen_5960
6 Replies

8. UNIX for Dummies Questions & Answers

Setting alias with echoing embedded $ sign

I tried to set up some alias in my .profile to save typing. One of the alais i tried to set up is alais test='echo 123$acct54679abc' But when I typed in test in the command line. The echo only dispaly 123 and truncated all the string starting from the $ sign. Is there any way to display the... (6 Replies)
Discussion started by: oht
6 Replies

9. UNIX for Dummies Questions & Answers

Export script to current session

Hi, I have a script called bash$> cat -ev setprofile.sh alias rm='rm -i'$ $ The alias does not take effect unless i run the script as bash$> . ./setprofile.sh What do I have to do in-order to simply run (9 Replies)
Discussion started by: shifahim
9 Replies

10. Shell Programming and Scripting

Why does my test fail ??

Hello, I am stuck... i dunno why does my test fail... any idea ? #!/bin/bash dos2unix info.txt Distor=Distributeur LINE=$(cat info.txt | sed -n 1p) echo $LINE echo $Distor echo "" echo "123-$LINE-123" echo "123-$Distor-123" if ; then LINE2=$(cat info.txt | sed -n 2p) echo $Distor... (14 Replies)
Discussion started by: patx
14 Replies

11. Shell Programming and Scripting

More a logic than a programming question

hello, I'm a littlebit lost... i have a table of single names and combination of two names and i want a table of ALL single names with ALL combinations (also the indirect ones). - - - in reality the names are longer, not only a,b,.. and the table is tab-delimited, and the result table... (6 Replies)
Discussion started by: dietmar13
6 Replies

12. UNIX for Dummies Questions & Answers

Return alias with pattern

hello all, i have ids repeated with alias names starting with different patterns like 'ab' , 'fg' etc...sometimes the same pattern names are repeated with the same ids like id=1 has names ab1 as well as ab3. Lookup.txt name id ab1 1 fg22 1 ab3 1 er2 1 fgh1 1 fg21 2 ab2 2 ab31 2... (8 Replies)
Discussion started by: jalaj841
8 Replies

13. Shell Programming and Scripting

Finding 'ls' to bypass system alias

Heyas Just asking, is there a better to make sure the script will use the binary and not some alias? LS=$(locate "ls"|grep /bin/ls$ | head -n 1) Thank you. (7 Replies)
Discussion started by: sea
7 Replies

14. Shell Programming and Scripting

Vlookup using Ask from specific column from two files

File1 alias:server1_00,20:f1:0a:25:b5:03:02:90 alias:server2_00,20:f1:0a:25:b5:03:02:91 alias:server3_00,50:00:09:75:50:0d:bd:da alias:server4_00,20:f1:0a:25:b5:03:02:93 alias:server5_00,21:00:00:24:ff:8b:e1:fe alias:server6_00,50:00:09:75:50:08:54:44... (17 Replies)
Discussion started by: ranjancom2000
17 Replies