Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ieee80211_output(9) [netbsd man page]

IEEE80211_OUTPUT(9)					   BSD Kernel Developer's Manual				       IEEE80211_OUTPUT(9)

NAME
ieee80211_encap, ieee80211_add_rates, ieee80211_add_xrates, ieee80211_send_mgmt -- software 802.11 stack output functions SYNOPSIS
#include <net80211/ieee80211_var.h> #include <net80211/ieee80211_proto.h> struct mbuf * ieee80211_encap(struct ieee80211com *ic, struct mbuf *m, struct ieee80211_node *ni); u_int8_t * ieee80211_add_rates(u_int8_t *frm, const struct ieee80211_rateset *rs); u_int8_t * ieee80211_add_xrates(u_int8_t *frm, const struct ieee80211_rateset *rs); int ieee80211_send_mgmt(struct ieee80211com *ic, struct ieee80211_node *ni, int type, int arg); DESCRIPTION
These functions handle the encapsulation and transmission of 802.11 frames within the software 802.11 stack. The ieee80211_encap() function encapsulates an outbound data frame contained within the mbuf chain m from the interface ic. The argument ni is a reference to the destination node. If the function is successful, the mbuf chain is updated with the 802.11 frame header prepended, and a pointer to the head of the chain is returned. If an error occurs, NULL is returned. The ieee80211_add_rates() utility function is used to add the rate set element *rs to the frame frm. A pointer to the location in the buffer after the addition of the rate set is returned. It is typically used when constructing management frames from within the software 802.11 stack. The ieee80211_add_xrates() utility function is used to add the extended rate set element *rs to the frame frm. A pointer to the location in the buffer after the addition of the rate set is returned. It is typically used when constructing management frames from within the software 802.11 stack in 802.11g mode. The ieee80211_send_mgmt() function transmits a management frame on the interface ic to the destination node ni of type type. The argument arg specifies either a sequence number for authentication operations, a status code for [re]association operations, or a reason for deauthentication and deassociation operations. Nodes other than ic_bss have their reference count incremented to reflect their use for an indeterminate amount of time. This reference is freed when the function returns. The function returns 0 if successful; if temporary buffer space is not available, the function returns ENOMEM. SEE ALSO
ieee80211(9) HISTORY
The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6. AUTHORS
This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>. BSD
September 12, 2006 BSD

Check Out this Related Man Page

IEEE80211_INPUT(9)					   BSD Kernel Developer's Manual					IEEE80211_INPUT(9)

NAME
ieee80211_input -- software 802.11 stack input functions SYNOPSIS
#include <net80211/ieee80211_var.h> void ieee80211_input(struct ieee80211_node *, struct mbuf *, int rssi, int noise); void ieee80211_input_all(struct ieee80211com *, struct mbuf *, int rssi, int noise); DESCRIPTION
The net80211 layer that supports 802.11 device drivers requires that receive processing be single-threaded. Typically this is done using a dedicated driver taskqueue(9) thread. ieee80211_input() and ieee80211_input_all() process received 802.11 frames and are designed for use in that context; e.g. no driver locks may be held. The frame passed up in the mbuf must have the 802.11 protocol header at the front; all device-specific information and/or PLCP must be removed. Any CRC must be stripped from the end of the frame. The 802.11 protocol header should be 32-bit aligned for optimal performance but receive processing does not require it. If the frame holds a payload and that is not aligned to a 32-bit boundary then the payload will be re-aligned so that it is suitable for processing by protocols such as ip(4). If a device (such as ath(4)) inserts padding after the 802.11 header to align the payload to a 32-bit boundary the IEEE80211_C_DATAPAD capa- bility must be set. Otherwise header and payload are assumed contiguous in the mbuf chain. If a received frame must pass through the A-MPDU receive reorder buffer then the mbuf must be marked with the M_AMPDU flag. Note that for the moment this is required of all frames received from a station and TID where a Block ACK stream is active, not just A-MPDU aggregates. It is sufficient to check for IEEE80211_NODE_HT in the ni_flags of the station's node table entry, any frames that do not require reorder pro- cessing will be dispatched with only minimal overhead. The rssi parameter is the Receive Signal Strength Indication of the frame measured in 0.5dBm units relative to the noise floor. The noise parameter is the best approximation of the noise floor in dBm units at the time the frame was received. RSSI and noise are used by the net80211 layer to make scanning and roaming decisions in station mode and to do auto channel selection for hostap and similar modes. Other- wise the values are made available to user applications (with the rssi presented as a filtered average over the last ten values and the noise floor the last reported value). SEE ALSO
ieee80211(9) BSD
August 4, 2009 BSD
Man Page