Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

fsetown(9) [netbsd man page]

FSETOWN(9)						   BSD Kernel Developer's Manual						FSETOWN(9)

NAME
fsetown, fgetown, fownsignal -- file descriptor owner handling functions SYNOPSIS
#include <sys/file.h> int fsetown(struct lwp *l, pid_t *pgid, int cmd, const void *data); int fgetown(struct lwp *l, pid_t pgid, int cmd, void *data); void fownsignal(pid_t pgid, int signo, int code, int band, void *fdescdata); DESCRIPTION
These functions handle file descriptor owner related ioctls and related signal delivery. Device drivers and other parts of the kernel call these functions from ioctl entry functions or I/O notification functions. fsetown() sets the owner of file. cmd is an ioctl command, one of SIOCSPGRP, FIOSETOWN, and TIOCSPGRP. data is interpreted as a pointer to a signed integer, the integer being the ID of the owner. The cmd determines how exactly data should be interpreted. If cmd is TIOCSPGRP, the ID needs to be positive and is interpreted as process group ID. For SIOCSPGRP and FIOSETOWN, the passed ID is the process ID if posi- tive, or the process group ID if negative. fgetown() returns the current owner of the file. cmd is an ioctl command, one of SIOCGPGRP, FIOGETOWN, and TIOCGPGRP. data is interpreted as a pointer to a signed integer, and the value is set according to the passed cmd. For TIOCGPGRP, the returned data value is positive process group ID if the owner is the process group, or negative process ID if the owner is a process. For other ioctls, the returned value is the positive process ID if the owner is a process, or the negative process group ID if the owner is a process group. fownsignal() schedules the signo signal to be sent to the current file descriptor owner. The signals typically used with this function are SIGIO and SIGURG. The code and band arguments are sent along with the signal as additional signal specific information if SA_SIGINFO is activated. If the information is not available from the context of the fownsignal() call, these should be passed as zero. fdescdata is used to lookup the file descriptor for SA_SIGINFO signals. If it is specified, the file descriptor number is sent along with the signal as addi- tional signal specific information. If file descriptor data pointer is not available in the context of the fownsignal() call, NULL should be used instead. Note that a fcntl(2) F_SETOWN request is translated by the kernel to a FIOSETOWN ioctl, and F_GETOWN is translated to FIOGETOWN. This is done transparently by generic code, before the device- or subsystem-specific ioctl entry function is called. SEE ALSO
fcntl(2), siginfo(2), signal(7), ioctl(9), signal(9) HISTORY
These kernel functions appeared in NetBSD 2.0. BSD
December 20, 2005 BSD

Check Out this Related Man Page

FCNTL(2)							System Calls Manual							  FCNTL(2)

NAME
fcntl - file control SYNOPSIS
#include <fcntl.h> res = fcntl(fd, cmd, arg) int res; int fd, cmd, arg; DESCRIPTION
Fcntl provides for control over descriptors. The argument fd is a descriptor to be operated on by cmd as follows: F_DUPFD Return a new descriptor as follows: Lowest numbered available descriptor greater than or equal to arg. Same object references as the original descriptor. New descriptor shares the same file pointer if the object was a file. Same access mode (read, write or read/write). Same file status flags (i.e., both file descriptors share the same file status flags). The close-on-exec flag associated with the new file descriptor is set to remain open across execv(2) system calls. F_GETFD Get the close-on-exec flag associated with the file descriptor fd. If the low-order bit is 0, the file will remain open across exec, otherwise the file will be closed upon execution of exec. F_SETFD Set the close-on-exec flag associated with fd to the low order bit of arg (0 or 1 as above). F_GETFL Get descriptor status flags, as described below. F_SETFL Set descriptor status flags. F_GETOWN Get the process ID or process group currently receiving SIGIO and SIGURG signals; process groups are returned as negative values. F_SETOWN Set the process or process group to receive SIGIO and SIGURG signals; process groups are specified by supplying arg as nega- tive, otherwise arg is interpreted as a process ID. The flags for the F_GETFL and F_SETFL flags are as follows: O_NONBLOCK Non-blocking I/O; if no data is available to a read call, or if a write operation would block, the call returns -1 with the error EWOULDBLOCK. O_APPEND Force each write to append at the end of file; corresponds to the O_APPEND flag of open(2). O_ASYNC Enable the SIGIO signal to be sent to the process group when I/O is possible, e.g., upon availability of data to be read. RETURN VALUE
Upon successful completion, the value returned depends on cmd as follows: F_DUPFD A new file descriptor. F_GETFD Value of flag (only the low-order bit is defined). F_GETFL Value of flags. F_GETOWN Value of file descriptor owner. other Value other than -1. Otherwise, a value of -1 is returned and errno is set to indicate the error. ERRORS
Fcntl will fail if one or more of the following are true: [EBADF] Fildes is not a valid open file descriptor. [EMFILE] Cmd is F_DUPFD and the maximum allowed number of file descriptors are currently open. [EINVAL] Cmd is F_DUPFD and arg is negative or greater than the maximum allowable number (see getdtablesize(2)). [ESRCH] Cmd is F_SETOWN and the process ID given as argument is not in use. SEE ALSO
close(2), execve(2), getdtablesize(2), open(2), sigvec(2) BUGS
The asynchronous I/O facilities of O_NONBLOCK and O_ASYNC are currently available only for tty and socket operations. 4.2 Berkeley Distribution Nov 30, 1994 FCNTL(2)
Man Page