Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

cpu_reboot(9) [netbsd man page]

CPU_REBOOT(9)						   BSD Kernel Developer's Manual					     CPU_REBOOT(9)

NAME
cpu_reboot -- halt or reboot the system SYNOPSIS
#include <sys/reboot.h> void cpu_reboot(int howto, char *bootstr); DESCRIPTION
The cpu_reboot() function handles final system shutdown, and either halts or reboots the system. The exact action to be taken is determined by the flags passed in howto and by whether or not the system has finished autoconfiguration. If the system has finished autoconfiguration, cpu_reboot() does the following: 1. Sets the boothowto system variable (see boothowto(9)) from the howto argument. 2. If this is the first invocation of cpu_reboot() and the RB_NOSYNC flag is not set in howto, syncs and unmounts the system disks by calling vfs_shutdown(9) and sets the time of day clock by calling resettodr(9). 3. Disables interrupts. 4. If rebooting after a crash (i.e., if RB_DUMP is set in howto, but RB_HALT is not), saves a system crash dump. 5. Runs any shutdown hooks by calling pmf_system_shutdown(9). 6. Prints a message indicating that the system is about to be halted or rebooted. 7. If RB_HALT is set in howto, halts the system. Otherwise, reboots the system. If the system has not finished autoconfiguration, cpu_reboot() runs any shutdown hooks by calling pmf_system_shutdown(9), prints a message, and halts the system. If RB_STRING is set in howto, then the parameter bootstr is passed to the system boot loader on some ports. SEE ALSO
boothowto(9), dumpsys(9), pmf_system_shutdown(9), resettodr(9), vfs_shutdown(9) BSD
February 11, 2010 BSD

Check Out this Related Man Page

REBOOT(2)						      BSD System Calls Manual							 REBOOT(2)

NAME
reboot -- reboot system or halt processor LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <unistd.h> #include <sys/reboot.h> int reboot(int howto); DESCRIPTION
The reboot() system call reboots the system. Only the super-user may reboot a machine on demand. However, a reboot is invoked automatically in the event of unrecoverable system failures. The howto argument is a mask of options; the system call interface allows the following options, defined in the include file <sys/reboot.h>, to be passed to the new kernel or the new bootstrap and init programs. RB_AUTOBOOT The default, causing the system to reboot in its usual fashion. RB_ASKNAME Interpreted by the bootstrap program itself, causing it to prompt on the console as to what file should be booted. Normally, the system is booted from the file ``xx(0,0)kernel'', where xx is the default disk name, without prompting for the file name. RB_DFLTROOT Use the compiled in root device. Normally, the system uses the device from which it was booted as the root device if possible. (The default behavior is dependent on the ability of the bootstrap program to determine the drive from which it was loaded, which is not possible on all systems.) RB_DUMP Dump kernel memory before rebooting; see savecore(8) for more information. RB_HALT the processor is simply halted; no reboot takes place. This option should be used with caution. RB_POWEROFF After halting, the shutdown code will do what it can to turn off the power. This requires hardware support. RB_INITNAME An option allowing the specification of an init program (see init(8)) other than /sbin/init to be run when the system reboots. This switch is not currently available. RB_KDB Load the symbol table and enable a built-in debugger in the system. This option will have no useful function if the kernel is not configured for debugging. Several other options have different meaning if combined with this option, although their use may not be possible via the reboot() system call. See ddb(4) for more information. RB_NOSYNC Normally, the disks are sync'd (see sync(8)) before the processor is halted or rebooted. This option may be useful if file system changes have been made manually or if the processor is on fire. RB_RDONLY Initially mount the root file system read-only. This is currently the default, and this option has been deprecated. RB_SINGLE Normally, the reboot procedure involves an automatic disk consistency check and then multi-user operations. RB_SINGLE prevents this, booting the system with a single-user shell on the console. RB_SINGLE is actually interpreted by the init(8) program in the newly booted system. When no options are given (i.e., RB_AUTOBOOT is used), the system is rebooted from file ``kernel'' in the root file system of unit 0 of a disk chosen in a processor specific way. An automatic consistency check of the disks is normally performed (see fsck(8)). RETURN VALUES
If successful, this call never returns. Otherwise, a -1 is returned and an error is returned in the global variable errno. ERRORS
[EPERM] The caller is not the super-user. SEE ALSO
crash(8), halt(8), init(8), reboot(8), savecore(8) HISTORY
The reboot() system call appeared in 4.0BSD. BUGS
The HP300 implementation supports neither RB_DFLTROOT nor RB_KDB. BSD
June 4, 1993 BSD
Man Page