Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

tcpdrop(8) [netbsd man page]

TCPDROP(8)						    BSD System Manager's Manual 						TCPDROP(8)

NAME
tcpdrop -- drop a TCP connection SYNOPSIS
tcpdrop laddr lport faddr fport DESCRIPTION
The tcpdrop command drops the TCP connection specified by the local address laddr, port lport and the foreign address faddr, port fport. Addresses and ports can be specified by name or numeric value. EXAMPLES
If a connection to httpd(8) is causing congestion on a network link, one can drop the TCP session in charge: $ fstat | grep 'httpd.*internet.*<--' www httpd 21307 3* internet stream tcp 0xd1007ca8 192.168.5.41:80 <-- 192.168.5.1:26747 The following command will drop the connection: # tcpdrop 192.168.5.41 80 192.168.5.1 26747 SEE ALSO
fstat(1), netstat(1) BSD
June 23, 2007 BSD

Check Out this Related Man Page

SOCKET-CONTEXT-OPTIONS(3)						 1						 SOCKET-CONTEXT-OPTIONS(3)

Socket context options - Socket context option listing

	Socket context options are available for all wrappers that work over sockets, like tcp, http and ftp.

	      o $bindto
		-  Used to specify the IP address (either IPv4 or IPv6) and/or the port number that PHP will use to access the network. The syntax
		is ip:port for IPv4 addresses, and [ip]:port for IPv6 addresses. Setting the IP or the port to 0 will let the system choose the IP
		and/or port.

	      Note

		      As FTP creates two socket connections during normal operation, the port number cannot be specified using this option.

	      o $backlog
		- Used to limit the number of outstanding connections in the socket's listen queue.

	      Note

		      This is only applicable to stream_socket_server(3).

       +--------+-----------------+
       |Version |		  |
       |	|		  |
       |	|   Description   |
       |	|		  |
       +--------+-----------------+
       | 5.3.3	|		  |
       |	|		  |
       |	|  Added backlog. |
       |	|		  |
       | 5.1.0	|		  |
       |	|		  |
       |	|  Added bindto.  |
       |	|		  |
       +--------+-----------------+
       Example #1

	      Basic $bindto usage example

	      <?php
	      // connect to the internet using the '192.168.0.100' IP
	      $opts = array(
		  'socket' => array(
		      'bindto' => '192.168.0.100:0',
		  ),
	      );

	      // connect to the internet using the '192.168.0.100' IP and port '7000'
	      $opts = array(
		  'socket' => array(
		      'bindto' => '192.168.0.100:7000',
		  ),
	      );

	      // connect to the internet using the '2001:db8::1' IPv6 address
	      // and port '7000'
	      $opts = array(
		  'socket' => array(
		      'bindto' => '[2001:db8::1]:7000',
		  ),
	      );

	      // connect to the internet using port '7000'
	      $opts = array(
		  'socket' => array(
		      'bindto' => '0:7000',
		  ),
	      );

	      // create the context...
	      $context = stream_context_create($opts);

	      // ...and use it to fetch the data
	      echo file_get_contents('http://www.example.com', false, $context);

	      ?>

PHP Documentation Group 												 SOCKET-CONTEXT-OPTIONS(3)
Man Page