Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

genassym.cf(5) [netbsd man page]

GENASSYM.CF(5)						      BSD File Formats Manual						    GENASSYM.CF(5)

NAME
genassym.cf -- assym.h definition file DESCRIPTION
The genassym.cf file is used by genassym(1) to make constant C expressions known to assembler source files. Lines starting with '#' are dis- carded by genassym(1). Lines starting with include, ifdef, if, else or endif are preceded with '#' and passed otherwise unmodified to the C compiler. Lines starting with quote get passed on with the quote command removed. The first word after a define command is taken as a CPP identifier and the rest of the line has to be a constant C expression. The output of genassym(1) will assign the numerical value of this expression to the CPP identifier. export X is a shorthand for define X X. struct X remembers X for the member command and does a define X_SIZEOF sizeof(X). member X does a define X offsetof(<last struct>, X). config <ctype> <gcc constraint> <asm print modifier> can be used to customize the output of genassym(1). When producing C output, values are casted to <ctype> (default: long) before they get handed to printf. <gcc constraint> (default: n) is the constraint used in the __asm__ statements. <asm print modifier> (default: empty) can be used to force gcc to output operands in different ways then normal. The "a" modifier e.g. stops gcc from emitting immediate prefixes in front of con- stants for the i386 and m68k port. FILES
/usr/src/sys/arch/${MACHINE}/${MACHINE}/genassym.cf SEE ALSO
genassym(1) HISTORY
The genassym.cf file appeared in NetBSD 1.3. BSD
August 18, 2005 BSD

Check Out this Related Man Page

OFFSETOF(3)						     Linux Programmer's Manual						       OFFSETOF(3)

NAME
offsetof - offset of a structure member SYNOPSIS
#include <stddef.h> size_t offsetof(type, member); DESCRIPTION
The macro offsetof() returns the offset of the field member from the start of the structure type. This macro is useful because the sizes of the fields that compose a structure can vary across implementations, and compilers may insert different numbers of padding bytes between fields. Consequently, an element's offset is not necessarily given by the sum of the sizes of the previous elements. A compiler error will result if member is not aligned to a byte boundary (i.e., it is a bit field). RETURN VALUE
offsetof() returns the offset of the given member within the given type, in units of bytes. CONFORMING TO
C89, C99, POSIX.1-2001. EXAMPLE
On a Linux/i386 system, when compiled using the default gcc(1) options, the program below produces the following output: $ ./a.out offsets: i=0; c=4; d=8 a=16 sizeof(struct s)=16 Program source #include <stddef.h> #include <stdio.h> #include <stdlib.h> int main(void) { struct s { int i; char c; double d; char a[]; }; /* Output is compiler dependent */ printf("offsets: i=%ld; c=%ld; d=%ld a=%ld ", (long) offsetof(struct s, i), (long) offsetof(struct s, c), (long) offsetof(struct s, d), (long) offsetof(struct s, a)); printf("sizeof(struct s)=%ld ", (long) sizeof(struct s)); exit(EXIT_SUCCESS); } COLOPHON
This page is part of release 3.27 of the Linux man-pages project. A description of the project, and information about reporting bugs, can be found at http://www.kernel.org/doc/man-pages/. GNU
2008-07-12 OFFSETOF(3)
Man Page

15 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

man gcc

Hi all, How can I get man page to recognize gcc when i need to look up gcc options? I tried "man gcc" but got a response "no manual entry for gcc". Thanks a bunch, Rachael (10 Replies)
Discussion started by: rachael
10 Replies

2. Solaris

gcc problems

I downloaded and installed the gcc binaries recently. I am now trying to compile openssh, but I get bad compiler issues when I try this. in the openssh directory, I run: ./configure (mind you, I have usr/local/bin/gcc in my PATH) but the output says checking for gcc... no Why... (7 Replies)
Discussion started by: AJA
7 Replies

3. UNIX for Advanced & Expert Users

gcc & make error- Help please

Folks; I'm trying to install gcc-3.4.6 & install SWIG tool on Solaris 10 (Sparc), but when i try to run make for gcc i got this error below: make: Fatal error: Command failed for target `all-gcc' and when i try to run "make install" to install swig, i got this error: *** Error code 2... (10 Replies)
Discussion started by: moe2266
10 Replies

4. Programming

Porting From Linux To Hpux

Gents, i'm a senior applications developer and need to port a Linux server application ( no additional / special libraries or unique header files ) to a HPUX enviroment. Any chance to compile it on the Linux using flags to create an HPUX binary with gcc? (8 Replies)
Discussion started by: anak0nda
8 Replies

5. Solaris

Installing gcc - recieve error message gcc : cannot execute

AIM- Install Oracle 11g on Solaris using VMWare Steps 1.Logged on as root 2.Created subfolders à /usr/local/bin & /usr/local/bin/gcc 3.Downloaded gcc & libiconv & unzipped them on my harddrive & burnt them on CD 4.Copied files from CD to /usr/local/bin/gcc 5.Terminal (root) à pkgadd -d... (8 Replies)
Discussion started by: Ackers
8 Replies

6. Programming

enable 64bit long type for gcc

hey, I believe I once saw a post in this forum, about enable an GCC option to enable long types. I simply cannot find it any more. Can anybody give me a hint? I am on 32bit Ubuntu, and I would like my int be really long. Also I need malloc() take long int argument too. I found it is necessary to... (6 Replies)
Discussion started by: patiobarbecue
6 Replies

7. Solaris

command 'cc' failed even though gcc is installed

I'm trying to build some python modules on a Solaris 10 machine. It has gcc as /usr/sfw/bin/gcc. # CC=gcc python setup.py build running build running build_py running build_ext cc -c actread.c -o actread.o unable to execute cc: No such file or directory error: command 'cc' failed with exit... (8 Replies)
Discussion started by: aussieos
8 Replies

8. Programming

Is gcc compliant with the C++ standards

Hello Friends, I am a newbie and have started using different compilers and tools to make myself familiar with their workings. I wanted to know that how compliant is gcc with the C++ standards. It is pretty obvious that no compiler is close to being completely compliant, but if there are some... (7 Replies)
Discussion started by: hthapar
7 Replies

9. Solaris

Help on gcc command

Hi All, I have added a gcc 3.4.6 package into Solaris 10 recently and I didnot receive any error on that. I have set the path of this gcc to /usr/local/bin I tried executing a simple Hello World 'C' program but I get the following error "bash: /usr/local/bin/gcc: invalid argument". ... (7 Replies)
Discussion started by: EmbedUX
7 Replies

10. Programming

gcc: warning: will never be executed

I get this gcc warning, but the function works correctly. Any ideas? #include <stdio.h> #include <string.h> #include <ctype.h> int main(void) { char A = ""; strcat(A, "Hello World!"); int COUNT = 0; while(A) { A = (char)(tolower(A)); ... (7 Replies)
Discussion started by: limmer
7 Replies

11. Solaris

There is gcc but doesn't work !!

gcc packages are installed as is seen. # pkginfo | grep -i gcc system SUNWgcc gcc - The GNU C compiler system SUNWgccruntime GCC Runtime libraries # There is gcc in /usr/sfw/bin but It doesn't work. # gcc bash: gcc: command not found... (7 Replies)
Discussion started by: getrue
7 Replies

12. Solaris

Need gcc binary for a SPARC machine

The machine I am trying to compile on does have /usr/sfw/bin and all the files in it, EXCEPT gcc !! This is a SUN Sparc-1 machine, so the binary does matter to match this. Can someone send me a gcc so I can put it locally for compilation purposes? Or point me a a site that has a compiled-ready... (17 Replies)
Discussion started by: steve701
17 Replies

13. Solaris

Why is gcc missing from </usr/sfw/bin>

Hi All: Does anyone know why gcc would be missing from /usr/sfw/bin? Has it been replaced by another file in below directory? .... Do you think admins may have deleted it from here? More importantly, is there anything else I can use in here as an alternative for a C program compilation? ... (8 Replies)
Discussion started by: steve701
8 Replies

14. UNIX for Advanced & Expert Users

AIX 7.1 gcc 4.8.5 issue

hey guys , after migrate our AIX server from 6.1 to 7.1 , we insalled c compilator with rpm files Server:root:/ > rpm -qa | grep gcc libgcc-4.8.5-1 gcc-cpp-4.8.5-1 gcc-4.8.5-1 gcc-c++-4.8.5-1 but whene we proceed to compile a c programm we have this error exec(): 0509-036... (17 Replies)
Discussion started by: yahia
17 Replies

15. UNIX for Beginners Questions & Answers

Downloading and installing a very old version of gcc

I would like to acquire a very old version of gcc: 4.4.3 and set it up in such a way that I can use the update-alternatives command to switch between my current version and the older version. I believe I may have found a website where I can download 4.4.3 from. However, I am not sure what all I... (6 Replies)
Discussion started by: Circuits
6 Replies