Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vref(9) [freebsd man page]

VREF(9) 						   BSD Kernel Developer's Manual						   VREF(9)

NAME
vref -- increment the use count for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vref(struct vnode *vp); DESCRIPTION
Increment the v_usecount field of a vnode. vp the vnode to increment Each vnode maintains a reference count of how many parts of the system are using the vnode. This allows the system to detect when a vnode is no longer being used and can be safely recycled for a different file. Any code in the system which is using a vnode (e.g. during the operation of some algorithm or to store in a data structure) should call vref(). SEE ALSO
vget(9), vnode(9), vput(9), vrefcnt(9), vrele(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD

Check Out this Related Man Page

VRELE(9)						   BSD Kernel Developer's Manual						  VRELE(9)

NAME
vput, vrele, vunref -- decrement the use count for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vput(struct vnode *vp); void vrele(struct vnode *vp); void vunref(struct vnode *vp); DESCRIPTION
Decrement the v_usecount field of a vnode. vp the vnode to decrement The vrele() function takes an unlocked vnode and returns with the vnode unlocked. The vput() function should be given a locked vnode as argument, the vnode is unlocked after the function returned. The vput() is opera- tionally equivalent to calling VOP_UNLOCK(9) followed by vrele(9), with less overhead. The vunref() function takes a locked vnode as argument, and returns with the vnode locked. Any code in the system which signified its use of a vnode by usecount should call one of the listed function to decrement use counter. If the v_usecount field of the non-doomed vnode reaches zero, then it will be inactivated and placed on the free list. Since the functions might need to call VOPs for the vnode, the Giant mutex should be conditionally locked around the call. The hold count for the vnode is always greater or equal to the usecount. Non-forced unmount fails when mount point owns a vnode that has non-zero usecount, see vflush(9). SEE ALSO
vget(9), vnode(9), vref(9), vrefcnt(9) AUTHORS
This manual page was written by Doug Rabson and Konstantin Belousov. BSD
November 20, 2010 BSD
Man Page

12 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Extracting from file

Hi I have the file in following format Begining of file --------------------------------------- my name some dfgfgfk jdksjdkls laladsl sdlsdls . . . kfdjkfdk some drt pro vhdl sdjls. ---------------------------------------------------------------- ddr.spw.df.df 0 0 0 0 0 ddr.ser.ddf.tp... (7 Replies)
Discussion started by: hack_tom
7 Replies

2. Shell Programming and Scripting

XML file: add 100 lines

Hi Gurus, I have XML file which i want to add 100 lines.I have no idea in xml how to add or modify data .Any help should be appreciated. Thanks, Akil (6 Replies)
Discussion started by: akil
6 Replies

3. Shell Programming and Scripting

process field 1 depending on field 6

Hi I am abigginer to unix .I have a file which contains data like this . fiusdcanlt_fmrbgmusd1_run 07/23/2012 20:11:18 07/23/2012 20:12:20 SU 10861341/1 fiusdcanlt_fmrbgmusd2_run 07/23/2012 20:12:22 07/23/2012 20:21:26 SU 10861341/1 fiusdcanlt_fmrbgmusd3_run 07/23/2012... (7 Replies)
Discussion started by: ptappeta
7 Replies

4. Shell Programming and Scripting

jump to a section in output

HI I have the following output from an autosys command . Now I would like to investigate further .i.e Start Dependent Job Name Status ... (3 Replies)
Discussion started by: ptappeta
3 Replies

5. Shell Programming and Scripting

Need help with sed and regexp

Hi everyone, I would really appreciate any help I could get on the following topic. I am not very familiar with reg expressions nor with sed, I just know the basic uses. What I am trying to do is the following: I have a huge text file where I would like to replace all occurnces of a certain... (13 Replies)
Discussion started by: Boxtuna
13 Replies

6. Programming

C++ for dummies: how to compile a code.

Hi. I wrote a small programm which shows me display's refresh rate #include "stdafx.h" #include "windows.h" #include "iostream" using namespace std; int _tmain(int cout) { HDC hDCScreen = GetDC(NULL); int RefreshFrequency = GetDeviceCaps(hDCScreen, VREFRESH); ReleaseDC(NULL, hDCScreen);... (1 Reply)
Discussion started by: urello
1 Replies

7. IP Networking

Help with iptables

photo... (1 Reply)
Discussion started by: beerpong1
1 Replies

8. Programming

Curious About Offbeat "#" Usage in C . . .

Greetings! Being incredibly rusty in the little C which I ever knew, and, not knowing where else to turn but the best programming community on the web ( :) ), I submit the following snippet for a quick question:#if PERL_VERSION > 7 if (DEBUG_D_TEST) { SV* sva; ... (3 Replies)
Discussion started by: LinQ
3 Replies

9. Post Here to Contact Site Administrators and Moderators

Priority one: Remove highly confidential data

Hi Kindly remove the following from the post . These are confidential info posted by mistake and there is escalation on our company side . Kindly help. Link : https://www.unix.com/shell-programming-and-scripting/194721-process-field-1-depending-field-6-a.html Terms to be removed : itf... (0 Replies)
Discussion started by: ptappeta
0 Replies

10. Solaris

Assigning proc_owner privilege to particular user in RBAC

Hi I need to assign proc_owner privilege to particular user through RBAC. How can I assign this privilege to user, I need help on this. Further I need to understand if I give this proc_owner privilege to particular user, what kind of control user will get on other user or system processes... (7 Replies)
Discussion started by: sb200
7 Replies

11. UNIX for Beginners Questions & Answers

Finding a word through substring in a file

I have a text file that has some data like: PADHOGOA1 IOP055_VINREG5_1 ( .IO(VINREG5_1), .MONI(), .MON_D(px_IOP055_VINREG5_1_MON_D), .R0T(px_IOP054_VINREG5_0_R0T), .IO1() ); PADV30MA0 IOP056_VOUT3_IN ( .IO(VOUT3_IN), .V30M(px_IOP056_VOUT3_IN_V30M)); PADV30MA0 IOP057_VOUT3_OUT (... (2 Replies)
Discussion started by: utkarshkhanna44
2 Replies

12. UNIX for Beginners Questions & Answers

Regex for this

I want to catch something like this : .V30M ( 1'b1 ) PADRV30MA0 IOP057_VOUT3_OUT ( .IO ( VOUT3_OUT ) , .V30M ( 1'b1 ) ) ; PADRV15MA0 IOP059_VOUT15_OUT ( .IO ( VOUT15_OUT ) , .V15M ( 1'b1 ) ) ; PADHOGOA1 IOP064_VREFLB ( .IO ( VREFLB ) , .MONI ( SYNOPSYS_UNCONNECTED_17 ) , .MON_D (... (5 Replies)
Discussion started by: utkarshkhanna44
5 Replies