Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vget(9) [freebsd man page]

VGET(9) 						   BSD Kernel Developer's Manual						   VGET(9)

NAME
vget -- get a vnode from the free list SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int vget(struct vnode *vp, int lockflag, struct thread *td); DESCRIPTION
Get a vnode from the free list and increment its reference count. vp The vnode to remove from the free list. lockflag If non-zero, the vnode will also be locked. When not in use, vnodes are kept on a free list. The vnodes still reference valid files but may be reused to refer to a new file at any time. Often, these vnodes are also held in caches in the system, such as the name cache. When a vnode which is on the free list is used again, for instance if the vnode was found in the name cache as a result of a call to VOP_LOOKUP(9) then the new user must call vget() to increment the reference count and remove it from the free list. SEE ALSO
vnode(9), vput(9), vref(9), vrele(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD

Check Out this Related Man Page

VRELE(9)						   BSD Kernel Developer's Manual						  VRELE(9)

NAME
vput, vrele, vunref -- decrement the use count for a vnode SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> void vput(struct vnode *vp); void vrele(struct vnode *vp); void vunref(struct vnode *vp); DESCRIPTION
Decrement the v_usecount field of a vnode. vp the vnode to decrement The vrele() function takes an unlocked vnode and returns with the vnode unlocked. The vput() function should be given a locked vnode as argument, the vnode is unlocked after the function returned. The vput() is opera- tionally equivalent to calling VOP_UNLOCK(9) followed by vrele(9), with less overhead. The vunref() function takes a locked vnode as argument, and returns with the vnode locked. Any code in the system which signified its use of a vnode by usecount should call one of the listed function to decrement use counter. If the v_usecount field of the non-doomed vnode reaches zero, then it will be inactivated and placed on the free list. Since the functions might need to call VOPs for the vnode, the Giant mutex should be conditionally locked around the call. The hold count for the vnode is always greater or equal to the usecount. Non-forced unmount fails when mount point owns a vnode that has non-zero usecount, see vflush(9). SEE ALSO
vget(9), vnode(9), vref(9), vrefcnt(9) AUTHORS
This manual page was written by Doug Rabson and Konstantin Belousov. BSD
November 20, 2010 BSD
Man Page

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Script to move files based on Pattern don't work

Hi people, i need you help on this if you can. I have a script that does the move command when it searches for a that doesn't match the pattern. This Pattern is on a list. When it run's and doesn´t found no files but it haves 2 more folders it moves the folders too. Ex:... (1 Reply)
Discussion started by: osramos
1 Replies

2. Solaris

proc precompilation - linking results in symbolic referncing errors

I can compile and link a piece of code on Solaris 2.6 .. I want the same thing to be done on Solaris8.. I am getting symbolic refernce errors while linking... Errors looks to be with proc symbols defination.. Any ideas ?? fgs_lib/finder_dbl.pkg_shr_def->lib/finder_dbl.so expand_file "cc -G... (0 Replies)
Discussion started by: shafi2all
0 Replies

3. AIX

niminv and rshd error

I am trying to run niminv on my nim master to collect info from my nim clients. : / -> niminv -o invcon -a targets=<nimclient> -a location=/tmp/inventory rshd: 0826-813 Permission is denied. geninv: 0645-007 ATTENTION: gi_nim_standalone() returned an unexpected result. Return Status: FAILURE... (4 Replies)
Discussion started by: nerradr
4 Replies

4. Shell Programming and Scripting

Conversion of spaces Text file into CSV format file

Input file (each line is separaed by spaces )given below: Name Domain Contact Phone Email Location ----------------------- ------------------------------------------------ ------- -----... (18 Replies)
Discussion started by: sreenath1037
18 Replies

5. IP Networking

Help with iptables

photo... (1 Reply)
Discussion started by: beerpong1
1 Replies

6. UNIX for Dummies Questions & Answers

How to Send AT Commands to mgetty?

Hello All, I've been working on something which requires a dialup USB Modem. I have been using minicom with success entering "AT Commands" directly into the terminal window that shows after running the minicom command. I had already configured the modem through minicom and was able to... (2 Replies)
Discussion started by: mrm5102
2 Replies

7. Programming

C: CSV implementation

I have this code from a programming book: #include <stdio.h> #include <string.h> char buf; /* input line buffer */ char* field; /* fields */ char* unquote( char* ); /* csvgetline: read and parse line, return field count */ /* sample input:... (3 Replies)
Discussion started by: totoro125
3 Replies

8. Shell Programming and Scripting

Finding the part of a filename

Hi, I am writing an ebuild for Gentoo Linux operating system. Writing an ebuild is about Bash scripting where I am a newbie. So, my ebuild must find a part of a specific filename. Such a filaname my look like this: libvclient_release_x64.so.740and I must to find the number at the and of... (18 Replies)
Discussion started by: csanyipal
18 Replies

9. Programming

Chinese Arduino UNO Clones - The Wavgat versus the generic UNO R3 Clone - The Winner Is?

Waiting for more fun Ardunio parts from AliExpress, I decided to test two cheap Chinese Arduino UNO clones. The Arduino UNO R3 (CH340G) MEGA328P The Wavgat UNO R3 (CH340G) MEGA328P Both of these Chinese Ardunio clones sell for about $3 USD, delivered to your door. The bottom line is... (0 Replies)
Discussion started by: Neo
0 Replies