Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pmap_extract_and_hold(9) [freebsd man page]

PMAP_EXTRACT(9) 					   BSD Kernel Developer's Manual					   PMAP_EXTRACT(9)

NAME
pmap_extract, pmap_extract_and_hold -- map a virtual address to a physical page SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> vm_paddr_t pmap_extract(pmap_t pmap, vm_offset_t va); vm_paddr_t pmap_extract_and_hold(pmap_t pmap, vm_offset_t va, vm_prot_t prot); DESCRIPTION
The pmap_extract() function maps a virtual address to a physical page. In certain situations, callers may use pmap_extract_and_hold() instead, to ensure that the returned page is held. The pmap_extract_and_hold() function maps a virtual address to a physical page, and atomically holds the returned page for use by the caller, only if the mapping permits the given page protection. IMPLEMENTATION NOTES
Currently, the page protection requested by the caller is not verified. RETURN VALUES
The pmap_extract() function will return the physical page address associated with the virtual address va inside the physical map pmap. If the mapping does not exist, or if the pmap parameter is NULL, then NULL will be returned. The pmap_extract_and_hold() function will return the physical page address associated with the virtual address va inside the physical map pmap. If the mapping does not exist, the result is a no-op, and NULL will be returned. SEE ALSO
mutex(9), pmap(9) AUTHORS
The pmap_extract_and_hold() function was implemented by Alan L. Cox <alc@imimic.com>. This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 21, 2003 BSD

Check Out this Related Man Page

PMAP_OBJECT_INIT_PT(9)					   BSD Kernel Developer's Manual				    PMAP_OBJECT_INIT_PT(9)

NAME
pmap_object_init_pt -- initialize page tables for a VM object SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h> void pmap_object_init_pt(pmap_t pmap, vm_offset_t addr, vm_object_t object, vm_pindex_t pindex, vm_size_t size, int limit); DESCRIPTION
The pmap_object_init_pt() function preloads the page table entries into the specified physical map pmap, for the given object at the virtual address addr, for size bytes, beginning at the page index pindex within the object. The map bits limit are heeded when creating the mapping. IMPLEMENTATION NOTES
This function is not strictly required by an architecture's pmap(9) implementation, but it does provide performance benefits if implemented. It is intended to eliminate the blast of soft faults on process startup, and immediately following a call to mmap(2). SEE ALSO
pmap(9), vm_map(9) AUTHORS
This manual page was written by Bruce M Simpson <bms@spc.org>. BSD
July 21, 2003 BSD
Man Page

4 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

help with C++ code that relate the object with physical address

(1 Reply)
Discussion started by: silviafisica
1 Replies

2. Shell Programming and Scripting

script to loop all process ids and take pmap

Hi all, I need a script that will loop around all the current processes and take a pmap -x <process id> and output each pmap to a separate file. Would anyone have a quick command to do this? (2 Replies)
Discussion started by: borderblaster
2 Replies

3. UNIX for Dummies Questions & Answers

What would the physical address be for virtual address?

Hi guys, I got one problem which I definetily no idea. What would the physical address be for virtual address? 1) 2ABC 2) 3F4B Here is the page table:see attached Thank you sos sososososso much!! (0 Replies)
Discussion started by: lemon_06
0 Replies

4. UNIX for Advanced & Expert Users

Server is virtual or physical?

Hi All, How can I know whether the server I am connecting to is a virtual or physical one? The server might be having any Unix OS (Linux/Solaris/HP-UX etc.). Is there any system files / commands which can show these concrete information? Thanks in advance for the replies. sanzee (1 Reply)
Discussion started by: sanzee007
1 Replies