Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

vop_ioctl(9) [freebsd man page]

VOP_IOCTL(9)						   BSD Kernel Developer's Manual					      VOP_IOCTL(9)

NAME
VOP_IOCTL -- device specific control SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_IOCTL(struct vnode *vp, u_long command, caddr_t data, int fflag, struct ucred *cred, struct thread *td); DESCRIPTION
Manipulate a file in device dependent ways. Its arguments are: vp The vnode of the file (normally representing a device). command The device specific operation to perform. data Extra data for the specified operation. fflag Some flags ??? cred The caller's credentials. td The calling thread. Most file systems do not implement this entry point. LOCKS
The file should not be locked on entry. RETURN VALUES
If successful, zero is returned, otherwise an appropriate error code. If the ioctl is not recognized or not handled, ENOTTY should be returned. SEE ALSO
vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD

Check Out this Related Man Page

VOP_OPEN(9)						   BSD Kernel Developer's Manual					       VOP_OPEN(9)

NAME
VOP_OPEN, VOP_CLOSE -- open or close a file SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_OPEN(struct vnode *vp, int mode, struct ucred *cred, struct thread *td, struct file *fp); int VOP_CLOSE(struct vnode *vp, int mode, struct ucred *cred, struct thread *td); DESCRIPTION
The VOP_OPEN() entry point is called before a file is accessed by a process and the VOP_CLOSE() entry point is called after a file is fin- ished with by the process. The arguments are: vp The vnode of the file. mode The access mode required by the calling process. cred The caller's credentials. td The thread which is accessing the file. fp The file being opened. Pointer to the file fp is useful for file systems which require such information, e.g., fdescfs(5). Use 'NULL' as fp argument to VOP_OPEN() for in-kernel opens. The access mode is a set of flags, including FREAD, FWRITE, O_NONBLOCK, O_APPEND. LOCKS
VOP_OPEN() expects vp to be locked on entry and will leave it locked on return. VOP_CLOSE() expects at least a reference to be associated with the vnode and does not care whether the vnode is locked or not. The lock and reference state is left unchanged on return. Note that vn_close expects an unlocked, referenced vnode and will dereference the vnode prior to returning. RETURN VALUES
Zero is returned on success, otherwise an error code is returned. SEE ALSO
vnode(9), VOP_LOOKUP(9) AUTHORS
This manual page was written by Doug Rabson. BSD
December 2, 2009 BSD
Man Page

13 More Discussions You Might Find Interesting

1. OS X (Apple)

Mac OS X: Based on UNIX - Solid As a Rock

See this threads: Page Not Found - Apple Open Source - Apple (0 Replies)
Discussion started by: Neo
0 Replies

2. Tips and Tutorials

The Whole Story on #! /usr/bin/ksh

Introduction Originally, we only had one shell on unix. When ran a command, the shell would attempt to invoke one of the exec() system calls on it. It the command was an executable, the exec would succeed and the command would run. If the exec() failed, the shell would not give up, instead it... (3 Replies)
Discussion started by: Perderabo
3 Replies

3. BSD

FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick

FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick nwbqBdghh6E The first hour of Marshall Kirk McKusick's course on FreeBSD kernel internals based on his book, The Design and Implementation of the FreeBSD Operating System. (0 Replies)
Discussion started by: Neo
0 Replies

4. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

5. Programming

Memory Leaks

Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram. main() { malloc(1gb) return(0) } The program above exits without freeing the memory. In this case will the 1 gb of heap memory be returned... (9 Replies)
Discussion started by: rupeshkp728
9 Replies

6. Shell Programming and Scripting

Scripts without shebang

I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning . Does this mean that it will run on any shell ? Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Discussion started by: kraljic
16 Replies

7. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

8. Web Development

A simple UNIXtime component in Vue.js

A shout out to Scott who gave me a helping hand to turn a simple sample Vue.js app I wrote yesterday into a Vue.js component: Vue.component("unix-time", { template: `<div class="time">{{unixtime}}</div>`, data() { return { unixtime: "" }; }, methods: { ... (1 Reply)
Discussion started by: Neo
1 Replies

9. Shell Programming and Scripting

Reason for no directory creation date

i read here that linux provides no way to determine when a directory was created. https://www.unix.com/shell-programming-and-scripting/157874-creation-date-directory.htmlI have a directory /home/andy/scripts that had a README file in it. That file says I put the script in that directory and... (3 Replies)
Discussion started by: drew77
3 Replies

10. Shell Programming and Scripting

Valid separator in time and date format

Hello. I can use any particular (stupid or not) format when using bash date command. Example : ~> date --date "now" '+%Y-%m-%d %H!%M!%S' 2019-06-03 12!55!33or ~> date --date "now" '+%Y£%m£%d %H¤%M¤%S' 2019£06£03 12¤57¤36 or ~> date --date "now" '+%Y-%m-%d %H-%M-%S' 2019-06-03 12-58-51 ... (4 Replies)
Discussion started by: jcdole
4 Replies

11. UNIX for Beginners Questions & Answers

UNIX Environment Setup - (Just starting!)

Morning All So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question: Currently I use Oracle VirtualBox, can... (8 Replies)
Discussion started by: GophusMeau
8 Replies

12. Solaris

Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?

I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager. FreeBSD slices are as follows; / on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f. I hesitate to install Solaris 10... (2 Replies)
Discussion started by: vectrum
2 Replies

13. Shell Programming and Scripting

Controlling user input

I'm trying to use a bash script for a psych experiment that involves listening to sound files and responding. If I have something like the code below, how can I make sure that a key press is assigned to RESPONSE only after the second echo statement? for i in 1 2 3; do echo "Ready?" sleep 2 ... (10 Replies)
Discussion started by: darwin_886
10 Replies