Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

flushband(9f) [bsd man page]

flushband(9F)						   Kernel Functions for Drivers 					     flushband(9F)

NAME
flushband - flush messages for a specified priority band SYNOPSIS
#include <sys/stream.h> void flushband(queue_t *q, unsigned char pri, int flag); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue. pri Priority of messages to be flushed. flag Valid flag values are: FLUSHDATA Flush only data messages (types M_DATA, M_DELAY, M_PROTO, and M_PCPROTO ). FLUSHALL Flush all messages. DESCRIPTION
flushband() flushes messages associated with the priority band specified by pri. If pri is 0, only normal and high priority messages are flushed. Otherwise, messages are flushed from the band pri according to the value of flag. CONTEXT
flushband() can be called from user or interrupt context. SEE ALSO
flushq(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 flushband(9F)

Check Out this Related Man Page

flushq(9F)						   Kernel Functions for Drivers 						flushq(9F)

NAME
flushq - remove messages from a queue SYNOPSIS
#include <sys/stream.h> void flushq(queue_t *q, int flag); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue to be flushed. flag Valid flag values are: FLUSHDATA Flush only data messages (types M_DATA M_DELAY M_PROTO and M_PCPROTO). FLUSHALL Flush all messages. DESCRIPTION
flushq() frees messages and their associated data structures by calling freemsg(9F). If the queue's count falls below the low water mark and the queue was blocking an upstream service procedure, the nearest upstream service procedure is enabled. CONTEXT
flushq() can be called from user or interrupt context. EXAMPLES
Example 1: Using flushq() This example depicts the canonical flushing code for STREAMS modules. The module has a write service procedure and potentially has messages on the queue. If it receives an M_FLUSH message, and if the FLUSHR bit is on in the first byte of the message (line 10), then the read queue is flushed (line 11). If the FLUSHW bit is on (line 12), then the write queue is flushed (line 13). Then the message is passed along to the next entity in the stream (line 14). See the example for qreply(9F) for the canonical flushing code for drivers. 1 /* 2 * Module write-side put procedure. 3 */ 4 xxxwput(q, mp) 5 queue_t *q; 6 mblk_t *mp; 7 { 8 switch(mp->b_datap->db_type) { 9 case M_FLUSH: 10 if (*mp->b_rptr & FLUSHR) 11 flushq(RD(q), FLUSHALL); 12 if (*mp->b_rptr & FLUSHW) 13 flushq(q, FLUSHALL); 14 putnext(q, mp); 15 break; . . . 16 } 17 } SEE ALSO
flushband(9F), freemsg(9F), putq(9F), qreply(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 flushq(9F)
Man Page

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Mac OS X: Based on UNIX - Solid As a Rock

See this threads: Page Not Found - Apple Open Source - Apple (0 Replies)
Discussion started by: Neo
0 Replies

2. UNIX for Beginners Questions & Answers

Simple rules of the UNIX.COM forums:

RULES OF THE UNIX AND LINUX FORUMS For the latest version of the community rules (the official community rules page), please visit here. No flames, shouting (all caps), sarcasm, bullying, profanity or arrogant posts. No negative comments about others or impolite remarks. Be patient. No... (1 Reply)
Discussion started by: Neo
1 Replies

3. Shell Programming and Scripting

Scripts without shebang

I see lot of ad-hoc shell scripts in our servers which don't have a shebang at the beginning . Does this mean that it will run on any shell ? Is it a good practice to create scripts (even ad-hoc ones) without shebang ? (16 Replies)
Discussion started by: kraljic
16 Replies

4. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

5. UNIX for Beginners Questions & Answers

Memory leak with awk on MacOs

Dear all, I use awk quite a bit for data wrangling ... today I find weird behavior that I cannot wrap my head around. if I execute the following command (simplified to illustrate the behavior ... nothing to do with the real command) bash-3.2$ awk... (3 Replies)
Discussion started by: comm|getline
3 Replies

6. Shell Programming and Scripting

Mail/mailx ignores newline formatting Problem.

I have a file hello.txt which i wish to send as a email body (not attachment). cat -ev hello.txt 1$ 2$ 3$ I use the following command to send the hello.txt as the email body. mailx -s "Alert" myteam@mycomp.com<hello.txt However, the email received has this in the email body 123... (2 Replies)
Discussion started by: mohtashims
2 Replies

7. Linux

LM 19.1 from pendrive

I've "installed" LM 19.1 to a PNY 16Gb(2.0) pendrive. I have a few issues that I'd like to resolve. First and foremost, the O.S. experiences "lagging" issues and to a lesser degree, freezing. Example: Complete "boot-up" (from start to complete "home" page) can take upwards of 7 mins. Then when... (10 Replies)
Discussion started by: 69Rixter
10 Replies

8. UNIX for Beginners Questions & Answers

UNIX Environment Setup - (Just starting!)

Morning All So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question: Currently I use Oracle VirtualBox, can... (8 Replies)
Discussion started by: GophusMeau
8 Replies

9. Solaris

Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?

I've installed Slack 14.2 on /dev/sda1 (/dev/sda2 is swap) and FreeBSD 12 on /dev/sda3 and lilo is the boot manager. FreeBSD slices are as follows; / on /dev/ada0S3a, swap on /dev/ada0s3e, /var on /dev/ada0s3b, /tmp on /dev/ada0s3d and /usr on /dev/ada0s3f. I hesitate to install Solaris 10... (2 Replies)
Discussion started by: vectrum
2 Replies

10. UNIX for Advanced & Expert Users

[Tip] How to display the number of logged-in users

In a professional environment with traditional application you often want (or are asked) to report the users. Traditionally there is the who command who | awk '{print $1}'telnetd or sshd register the users in the utmp file, to be shown with who, w, users, finger, pinky, ... In addition they... (1 Reply)
Discussion started by: MadeInGermany
1 Replies