Sponsored Content
Full Discussion: file system size
Operating Systems AIX file system size Post 302164553 by bakunin on Tuesday 5th of February 2008 07:08:31 AM
Old 02-05-2008
Quote:
Originally Posted by magasem
but I need now to reduce the percentage for /usr
I still do not understand why you do have to increase the available space (IMHO this is a waste of diskspace), but here is how you do it:

1. find out, how much space is left in the rootvg and decide, how much you want to assign to the /usr filesystem:

Code:
# lsvg rootvg
VOLUME GROUP:       rootvg                   VG IDENTIFIER:  0000fc010000d6000000011054db9d7c
VG STATE:           active                   PP SIZE:        128 megabyte(s)
VG PERMISSION:      read/write               TOTAL PPs:      1092 (139776 megabytes)
MAX LVs:            256                      FREE PPs:       910 (116480 megabytes)
LVs:                14                       USED PPs:       182 (23296 megabytes)
OPEN LVs:           13                       QUORUM:         1
TOTAL PVs:          2                        VG DESCRIPTORS: 3
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:         2                        AUTO ON:        yes
MAX PPs per VG:     32512                                     
MAX PPs per PV:     1016                     MAX PVs:        32
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                       BB POLICY:      relocatable 

# lsvg -l rootvg
rootvg:
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
hd5                 boot       1     2     2    closed/syncd  N/A
hd6                 paging     32    64    2    open/syncd    N/A
hd8                 jfs2log    1     2     2    open/syncd    N/A
hd4                 jfs2       1     2     2    open/syncd    /
hd2                 jfs2       20    40    2    open/syncd    /usr
hd9var              jfs2       8     16    2    open/syncd    /var
hd3                 jfs2       9     18    2    open/syncd    /tmp
hd1                 jfs2       7     14    2    open/syncd    /home
hd10opt             jfs2       1     2     2    open/syncd    /opt
lg_dumplv           sysdump    8     8     1    open/syncd    N/A
usr_local_lv        jfs2       2     4     2    open/syncd    /usr/local

I have marked bold the relevant parts: In this example your smallest assignment unit is 128MB (PP size) and you have 910 (free PPs) of these 128MB-chunks available. As your rootvg is mirrored (see the LP to PP ratio of 1:2) you will need 2 PPs for every new LP you assign. Right now you have 20 LPs (=> 20x128MB=2.5GB) assigned. For the sake of the example i assume you want to increase it by 1GB, which would be 8 LPs.

2.) Increase the size of the logical volume:

Code:
# extendlv hd2 8

3.) Increase the size of the filesystem:

Filesystems are measured in (512-bytes-)blocks. Calculate how many blocks you have to increase, then increase the filesystem (use ^D to leave bc):

Code:
# bc
2*1024*128*8 
2097152

# chfs -a size=+2097152 /usr

I hope this helps.

bakunin
 

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Free size for File System

How to find the free size currently FileSystem has, on the disk mounted? I know 'df' lists all the mounted disks, but I am interested to know details for the filesystem, in which currently I am working. (7 Replies)
Discussion started by: videsh77
7 Replies

2. UNIX for Advanced & Expert Users

File system size change

Good morning folks! I'm new here.. trying to find an answer on how to resize filesystem. Need to add some space to c0t0d0s5, /var... Is it possible at all? JV (9 Replies)
Discussion started by: jvinn
9 Replies

3. Programming

how to get the file system size

I have the next code, and the output is incosistent, what is the problem: free blocks: 1201595 block size: 4096 total size(free blocks * block size): 626765824 1201595 * 4096 not is 626765824, what's the problem??? #include <sys/statvfs.h> #include <stdio.h> int main(){ ... (1 Reply)
Discussion started by: lucaxvu
1 Replies

4. Solaris

increasing file system size

Hi Can anyone explain me how to increase the filesystem size. We can do it when the system is running? It needs an reboot? (8 Replies)
Discussion started by: rogerben
8 Replies

5. AIX

increase the size of file system

Hi all, we are usig aix 4.3 and i need to increase the size of "/u01" file sytem which is mounted on logical volume "lv00", but "/u01" file system size is 9 GB and logical volume "lvoo" size 9 GB.how do i increase the size of /u01.do i increase the size of logical volume "lv00" and then... (2 Replies)
Discussion started by: younusdba
2 Replies

6. Solaris

Directory size larger than file system size?

Hi, We currently have an Oracle database running and it is creating lots of processes in the /proc directory that are 1000M in size. The size of the /proc directory is now reading 26T. How can this be if the root file system is only 13GB? I have seen this before we an Oracle temp file... (6 Replies)
Discussion started by: sparcman
6 Replies

7. Shell Programming and Scripting

file size on the operating system

When I do df -h, I see that one of my partitions is out of space. Then when I do du -h, I get thousands of files. How do I only look at files over a specific size. I want directories over 500m to be returned only. (2 Replies)
Discussion started by: guessingo
2 Replies

8. Shell Programming and Scripting

Script to check file system size

Dears, the output of this command df -h | tr -s ' ' | cut -f5 -d' ' is capacity 24% 0% 0% 0% 0% 1% 0% 24% 24% 0% 93% 1% (4 Replies)
Discussion started by: xxmasrawy
4 Replies

9. AIX

File system percentage to the hole size ?

Hi, I'd like to know how can I figure out my disk space area on AIX machine, for example to the situation of ( df -g ) which I have in my system : the area used by (/opt/oracle) file system is (98%) now. the free area on (/opt/oracle) is (0.75) now. the total size in Gigabyte... (1 Reply)
Discussion started by: arm
1 Replies

10. HP-UX

[Solved] Increase the file system size

Dear Friends, I would like to increase the size of a file system from 10GB to 15GB. System is runing on HP-UX 11.31. Please help in the matter. Regards, Bhagawati Pandey (3 Replies)
Discussion started by: BPANDEY
3 Replies
All times are GMT -4. The time now is 12:37 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy