VFS_FHTOVP(9) BSD Kernel Developer's Manual VFS_FHTOVP(9)NAME
VFS_FHTOVP -- turn an NFS filehandle into a vnode
SYNOPSIS
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>
int
VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp);
DESCRIPTION
The VFS_FHTOVP() macro is used by the NFS server to turn an NFS filehandle into a vnode.
The arguments it expects are:
mp The file system.
fhp The filehandle to convert.
vpp Return parameter for the new locked vnode.
The contents of the filehandle are defined by the file system and are not examined by any other part of the system. It should contain enough
information to uniquely identify a file within the file system as well as noticing when a file has been removed and the file system resources
have been reused for a new file. For instance, UFS file system stores the inode number and inode generation counter in its filehandle.
A call to VFS_FHTOVP() should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client.
RETURN VALUES
The locked vnode for the file will be returned in *vpp.
SEE ALSO VFS(9), VFS_CHECKEXP(9), VOP_VPTOFH(9), vnode(9)AUTHORS
This manual page was written by Doug Rabson.
BSD January 4, 2010 BSD
hello :-)
I have one problem with my LiLO... I installed PLD Linux on my computer but when it boots, the last thing I can see is:
request_module Root fs not mounted
VFS: Cannot open root device 03:01
Kernel panic: VFS: unable to mount root fs on 03:01
and the system stops :-(
what... (1 Reply)
Hi,
I ported a file system from Kernel version 2.6.18.* to 2.6.32.46 as VFS implementation has changed and prepare_write/commit_write are replaced by write_begin/write_end pairs.
Implemented the feature by writing a wrapper for write_begin and write_end and calling original functions for... (0 Replies)
Hi.
I'm starting to use minix and the version I'm using is 3.2.1. I didn't understand why in this version there are MFS/VFS/PFS file systems and in the other versions there is only FS. I'm trying to modify the file system but I don't know where should I modify. Does anyone know why are there... (0 Replies)