Help...Bad NIS problems

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Help...Bad NIS problems
# 1  
Old 11-28-2002
Data Help...Bad NIS problems

I changed the root password on the NIS master, now I cant login to any of the NIS clients. Or even the NIS master using normal logons, any ideas what might be wrong or how I can solve this?

Im running solaris 2.6 btw.
# 2  
Old 11-29-2002
Changing root password on NIS master should not stop you or any other users from authenticating to
NIS but if yp deamon is not running or passwd map
is corrupt this will prevent users authenticating.

root password on your NIS master is stored locally in your /etc/shadow file not in NIS datebase so your could try logging on to your NIS master at the console using root password and check if yp daemon is running by issuing ps -ef | grep yp
if yp daemon is not running then you can restart it by issuing /etc/init.d/rpc start or /usr/lib/netsvc/yp/ypstart

if yp daemon is running and you still can't log on
then yp passwd map may be corrupt, you can rebuld the passwd map by cd/var/yp and issue ypmake passwd or make passwd.

if you can not log on at the console using root password, try rebooting NIS master hopefully this
restart yp daemon when NIS goes in to run level 3

if after reboot you could still not logon then boot NIS master from cdrom by issue boot cdrom -s
from OK prompt then mount /dev/dsk/c0t0d0s0 /mnt
then edit /etc/shadow remove the root entry.
then reset the passwd by issuing passwd root.

you can use the your newly reset root pasword to logon to console
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

A bad configured logrotate can cause a problems with memory leak ?

I am newbe to unix. I have a very serious problem on my server. I have a java application running, and all day on Monday morning, the process that is associated with this java is locked. Usually I doing a shutdown by the shutdown java command , you have to kill the process with the kill-kill... (1 Reply)
Discussion started by: jjoottaa
1 Replies

2. HP-UX

Solved -- Problems with NIS Password Expiration...

HI. I was wondering if anyone can assist me in this. I have an HP-UX 11.31 server at work which keeps expiring my NIS password. I cannot log in unless I use root access. It worked before and I think some of the settings changed since then. My boss has told me that since we're taking some... (1 Reply)
Discussion started by: zixzix01
1 Replies

3. Shell Programming and Scripting

Validating that the NIS and NIS+ services are disabled

I'm creating a scrip for auditing our AIX box's to ensure that they are built according to our system standards. I'm not sure on the logic for checking to see if the NIS and NIS+ services are disabled. any idea's? (2 Replies)
Discussion started by: sport
2 Replies

4. Solaris

NIS problems in Sun 5.10

Hi everyone! I have a problem with NIS and I'm hoping one of you experts can point me in the right direction :) I have setup 2 Solaris10 machines in VMWare and I was following this guide I found: Solaris: NIS installation and configuration - Basically Tech After following that guide, I was... (3 Replies)
Discussion started by: Keepcase
3 Replies

5. UNIX for Advanced & Expert Users

NIS+ problems

We are lumbered with using NIS+, and I have some questions regarding its use. 1 in a senario with 1 master 3 slaves, if the slaves all die the master will also fail ? There is some thing I read which states that NIS+ needs n/2 to function can anyone confirm / deny this ? Also in the event... (0 Replies)
Discussion started by: wjones
0 Replies

6. Solaris

How to configure a NIS client bound to the NIS server in another subnet?

Hi, all. I have a Solaris client here needs to bind to NIS server in another subnet. Following is the configuration i made on the client, 1) edit /etc/inet/hosts to add an entry of the NIS server -- nserver01 2) execute `domainname` to set local NIS domain to the domain of the NIS server.... (1 Reply)
Discussion started by: sn_wukong
1 Replies

7. UNIX for Advanced & Expert Users

NIS master / slave problems

Our NIS master server went down. We have since fixed it and brought it back up. However all of are machines still point to the slave server when looking at it with ypwhich. My question is how do i point the servers back to the master. Frank (2 Replies)
Discussion started by: frankkahle
2 Replies

8. UNIX for Advanced & Expert Users

SUSE 9 and 10 NIS clients with RedHat 8.0 NIS server not working

We have a RedHat 8.0 NIS master, with a RedHat 8.0 NIS Slave. We also have a small number of SUSE 9.1 and SUSE 10 machines here for evaluation. However, no matter what i do, the SUSE machines will not talk to the NIS Servers. If i broadcast for NIS Servers for the specified NIS domain, it... (1 Reply)
Discussion started by: fishsponge
1 Replies

9. UNIX for Dummies Questions & Answers

NIS map mail.aliases specified, but NIS not running

Hi all, I just took over the admin role from someone and I wanna setup sendmail (just to send mail from the host) however, after I config all the resolv.conf, nssitch.conf, hosts file and when I try to send a mail out, after I punched ctl-D, it returned he following, "NIS map mail.aliases... (2 Replies)
Discussion started by: stancwong
2 Replies

10. UNIX for Advanced & Expert Users

Solaris NIS+ and RedHat NIS+

Hello all, I'm not sure if this is the right forum, but I would like to know if Redhat running NIS ( not NIS +) would have conflict with Solaris running NIS+. Currently I am running NIS+ on Solaris but will be adding RedHat to the network. I seem to be unable to find and information regarding... (2 Replies)
Discussion started by: larry
2 Replies
Login or Register to Ask a Question