Visit Our UNIX and Linux User Community


stty


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers stty
# 1  
Old 11-08-2002
Question stty

I am trying to set my backspace key as the erase key
right now I have to type CONTROL-H to delete.
Can you please tell me the command to set my backspace
as the erase key......
# 2  
Old 11-08-2002
You use the stty erase command - the last part of it is hitting the backspace key. You can put the command into your .kshrc after checking that it is a tty you are coming from - read the man page on stty, ksh, ...

% stty erase ^H
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #512
Difficulty: Medium
PHP requires that all variables begin with a dollar sign, for example $flag.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

How to use stty?

Hi , I have shell scripting in linux box. This script is mentioned that should be run under the one particular user. If you run that mentioned user location then it is working fine.... Suppose if you are trying run from some other user like as mentioned below sudo su - gxadm -c script.sh ... (1 Reply)
Discussion started by: Mani_apr08
1 Replies

2. UNIX for Advanced & Expert Users

stty issues

Copy Paste Issue... Pasted some c**p of a excel...!! Sorry Guys. Please look Below for the issue. (4 Replies)
Discussion started by: grep_me
4 Replies

3. Shell Programming and Scripting

stty: : I/O Error

Hi all, I am stuck on a shell script issue and need your inputs: I have a parent script A.ksh which call in another script B.ksh. At the start of the B.ksh, we export the .profile of another user and then call Informatica jobs. Issue When I run my jobs from the command prompt, it works... (1 Reply)
Discussion started by: fromrishi
1 Replies

4. OS X (Apple)

Using stty

Hello, I am trying to configure a serial port, for mac os x 10.6. I believe I can use the stty command to look at serial port configuration and or change the serial port settings. I read the man page, but I don't really know what I am doing. Any help? (0 Replies)
Discussion started by: jamesapp
0 Replies

5. UNIX for Advanced & Expert Users

stty: : Not a typewriter -- Help please

Hi All, I have been runing the same set of program using the same auto profile for an year. Now when i run the same set of process , i getting the below error Not a terminal stty: : Not a typewriter stty: : Not a typewriter ksh: jil: not found ksh: sendevent: not found logout... (4 Replies)
Discussion started by: arunkumar_mca
4 Replies

6. UNIX for Advanced & Expert Users

stty erase r

after hitting this command...on pressing r acts as a backspace character.... how to disable this function (5 Replies)
Discussion started by: bishweshwar
5 Replies

7. UNIX for Dummies Questions & Answers

stty errors

Hi folks, I run a script in rsh on HP-UX v2 (B.11.23 U 9000/800) and each time I have "su - user" in my program I'm getting the following output on the screen: stty: : Unknown error process not attached to terminal Usage: who r run level b boot time t time changes... (2 Replies)
Discussion started by: nir_s
2 Replies

8. UNIX for Dummies Questions & Answers

stty: : Not a typewriter

stty: : Not a typewriter the above error comes after i execute the script below o hpux B.11.00 #!/usr/bin/ksh /bin/su - <oraid> -c "svrmgrl" << EOF connect internal startup exit EOF echo "# End "`date +%D" "%T` >> time.log (4 Replies)
Discussion started by: yls177
4 Replies

9. UNIX for Advanced & Expert Users

stty (urgent)

Hello all, In the .profile of my account on Tru64 UNIX,there is a command stty dec In the man pages,it is specified that dec sets all modes suitable for terminals supplied by Digital Equipment Corporation. I am porting a software from Compaq to HP platform.so i want to use the same... (1 Reply)
Discussion started by: informshilpa
1 Replies

Featured Tech Videos