Visit Our UNIX and Linux User Community


stty erase e command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers stty erase e command
# 1  
Old 10-27-2002
stty erase e command

I'm not familiar with the stty command.

What would "stty erase e" do to my system and what kind of problems would it create? Also, how would I undo this command?
# 2  
Old 10-27-2002
stty erase e will cause the letter e to erase characters written on the prompt .
Similarly if u want to use backspace to erase
then doing stty erase <back-space> will do it.

It wont affect the system in any way though i think u wont be able to use the letter e.

Undo i am not sure ...

man stty for details ...

DP
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #826
Difficulty: Medium
JSON is a language-independent data format.
True or False?

10 More Discussions You Might Find Interesting

1. OS X (Apple)

Can I erase and start my mac with unix command

I made a tragic error and erased the extensions manager from my IMac. Now, I can't get the computer to boot up. It just stays on the gray screen. I've tried using the open apple+s method, which brings up the command console (not sure if I've got the lingo down right), and I've tried everything, but... (12 Replies)
Discussion started by: ccff22290
12 Replies

2. Shell Programming and Scripting

stty erase ^h not working for backspace

Hi , I have to press shift + Backspace to do backspace on my unix termminal everytime. How can i configure it to a normal backspace only. Please help me here. PFB the contents of the stty -a : dbtgr@hpxi017:/pocuser/C5/aimsys/dbtgr> stty -a speed 38400 baud; line = 0; rows = 35; columns =... (4 Replies)
Discussion started by: kunwar
4 Replies

3. AIX

How to use dd command to erase the data in disk

how to use dd command to erase the data in disk, such as hdisk2? (9 Replies)
Discussion started by: rainbow_bean
9 Replies

4. Shell Programming and Scripting

Problem in /bin/bash with stty erase

hello everybody, as many, I have a problem with a script... I wrote a shell script in which I want to read a variable value. the problem is that I can't use the arrow keys. Here is the script I use : #!/bin/bash stty erase ^H read foune echo "$foune" exit 0; the problem is... (2 Replies)
Discussion started by: Moumou
2 Replies

5. Filesystems, Disks and Memory

"mt erase" command does not work

Hi I have some data in my tape which I want to erase with the command mt erase The process runs for a long time without cleaning data. What can be the problem?? krishan (2 Replies)
Discussion started by: krishan
2 Replies

6. Solaris

stty erase on solaris 8 sparc

Hi All, I put all these combination either: stty erase ^H or stty erase "^H" on /etc/profile or /home/user/.profile. But backspace erase won't work on my keyboard. I'm using putty on my remote connection with ultra 10. On the console or direct connection with sun keyboard, it does. ... (3 Replies)
Discussion started by: itik
3 Replies

7. UNIX for Advanced & Expert Users

stty erase r

after hitting this command...on pressing r acts as a backspace character.... how to disable this function (5 Replies)
Discussion started by: bishweshwar
5 Replies

8. UNIX for Advanced & Expert Users

stty erase in a script

does anyone know how to incorporate this in a script so users can actually make use of their backspace button that they've grown accustomed to? stty erase ^H --- this isn't working the script. works on command line but i wanna invoke it whenever this program of mine is run so users can use... (2 Replies)
Discussion started by: Terrible
2 Replies

9. UNIX for Dummies Questions & Answers

erase file

I have a file that always generated in the system eg. /tmp/log.txt , it is generated by the application program , but this file should not be present in the system otherwise there are some program problem , I want to erase this file once the program has generate it , as I know , it can link to... (2 Replies)
Discussion started by: ust
2 Replies

10. UNIX for Dummies Questions & Answers

Is there an unrecoverable erase command?

I am "retiring" an old unix box and need to erase all sensitive data so that it can not be recovered. Does anyone know a unix command for this? (5 Replies)
Discussion started by: snyderpa
5 Replies

Featured Tech Videos