$home full? or quota enabled?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers $home full? or quota enabled?
# 8  
Quote:
Originally Posted by Annihilannic
Okay, so it does sound like /users is on the root filesystem, which is probably a Bad Thing (TM). It's unusual that you don't have a separate /export/home filesystem, which is the normal location of users' home directories on Solaris.

For completeness can we also see the output of df -k /users
Code:
qmmm1#df -k /users
Filesystem           kbytes   used                 avail    capacity          Mounted on
/dev/dsk/c0t0d0s0    4032654  18446744073708757319 4786625  462054822993220%  /

What's with the 'used' and 'capacity' figures here? (I should mention that this is a business-critical box and may be somewhat customised for it's purpose... which is alarming & logging a lot of data for a telco)

Quote:
Originally Posted by Annihilannic
and df -i /users (or df -o i if the latter is invalid for Solaris 9, it certainly is on 10, to my surprise).
Code:
qmmm1#df -i /users
df: unknown option: i

qmmm1#df -o i /users
Filesystem             iused   ifree  %iused  Mounted on
/dev/dsk/c0t0d0s0       3169  496031     1%   /

Quote:
Originally Posted by Annihilannic
Also, is there definitely no reference to /users in /etc/auto_master?
Code:
Yep, by the looks of it:
qmmm1#cat /etc/auto_master
# Master map for automounter
#
+auto_master
/net            -hosts          -nosuid,nobrowse
/home           auto_home       -nobrowse
/xfn            -xfn

Thanks for your help Anni, I am learning things from you! Also, some more testing seems to indicate that the more files I create in $HOME (regardless of size) seems to increase the maximum size I can make the files - there is some kind of relationship at least. It's sounds a bit 'block allocation' type thing, but still doesn't make sense according to the way blocks & iNodes are normally allocated in this os.
# 9  
From your initial post I was beginning to suspect some kind of filesystem corruption, but after seeing those df output figures that feeling is getting stronger.

I really think you'd be best booting from CD-ROM or network and doing a full fsck of the root filesystem.

Do you run regular backups? Do check that you have a successful one before you do the filesystem check.
# 10  
Bug It IS broken!

Your right Anni - apparently this machine is dying and sysadmin is currently building a replacement! (Of course there is no need to inform the users of this, nor that their data is as good as kaput...)

I don't think I would have figured this out on my own so thanks for your help Smilie

I tried the fsck and it was progressing very slowly, I was told that this is basically a bad sign, and followed up with the sysadmin for this machine. That alone took 2 days to find out who; but now I'm back in business.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

9 More Discussions You Might Find Interesting

1. What is on Your Mind?

The C64 is back, this time full-sized with a working keyboard for the dedicated retro home-computer

Retro Games has announced that the C64 is back, this time full-sized with a working keyboard for the dedicated retro home-computer fan, available December 2019. See also: CNN: Iconic 80s computer The Commodore 64 to return with fully-functional keyboard YouTube: The C64 | Trailer ... (2 Replies)
Discussion started by: Neo
2 Replies

2. AIX

100% Inode full with only 67% FS full.

AIX Version 6.1 and 7.1. I understand that when the OS initially creates the FS and inodes, its pretty strict, but not always tuned to a 1:1 ratio. I see the same thing when adding a whole disk LV to a separate device. It seems that when we expand a filesystem the inodes don't get tuned... (5 Replies)
Discussion started by: mrmurdock
5 Replies

3. Shell Programming and Scripting

cp -p /home/* home/exp/*.date not working please help

:( ---------- Post updated at 01:51 AM ---------- Previous update was at 01:50 AM ---------- Not working ---------- Post updated at 02:04 AM ---------- Previous update was at 01:51 AM ---------- cp -p /home/* home/exp/*.`date` i am using this (4 Replies)
Discussion started by: rishiraaz
4 Replies

4. Linux

Error: Encryption support not enabled

Hi when I run the following GET commad: ./snmpget -m ALL -M /data/net/naamab/snmp/snmp_mib/ -v 3 -a MD5 -l authPriv -u test1 -A welcome1 -x DES -X privpass 127.0.0.1 NOVELSAT-MODULATOR-MIB::nsModLineCMMode.0 -d I get the error: Encryption support not enabled. snmpget: USM encryption... (1 Reply)
Discussion started by: naamabm
1 Replies

5. Solaris

see if async i/o is enabled in Solaris 9

Hi guys. This may be a stupid question but I am trying to see if my Solaris 9 server has async i/o enabled... Is there a quick way to determine this? Thanks in advance. (1 Reply)
Discussion started by: jamie_collins
1 Replies

6. UNIX for Dummies Questions & Answers

know a particular user is disabled or enabled

Hi all, i had 500 users how can i know whether user is disabled or enabled Thanks, kalyan (8 Replies)
Discussion started by: kalyan212
8 Replies

7. HP-UX

st_san_safe enabled

$ uname -a HP-UX vfauh203 B.11.11 U 9000/800 486452371 unlimited-user license SCSI TAPE: dev = 0xcd520000 Failed open - st_san_safe enabled () is there any tools i can run to further investigate this err0r i received from syslog.log ? im new to hp-ux thanks (1 Reply)
Discussion started by: libchk
1 Replies

8. IP Networking

how we can find whether net is enabled or not

how we can find whether net is enabled or not with out using ping is there anyway please guide me thanku ,in advance sree (1 Reply)
Discussion started by: phani_sree
1 Replies

9. UNIX for Dummies Questions & Answers

Account creation Sudo enabled

Hi, how to create account with the following be cron enabled only accessible via sudo (1 Reply)
Discussion started by: vilves
1 Replies

Featured Tech Videos