FTP debate...

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers FTP debate...
# 1  
Old 10-18-2002
FTP debate...

Hello, sorry in advance, I'm a first time poster and somewhat new to UNIX (Mac OS X) I've searched on your boards and have been unsuccessfull in finding information on this. I have found some info at Google but not enough to validate my stance in a debate.

I'm trying to FTP into a server and the responsed server gives me:

230-No directory! Logging in with home=/

I cannot perform a "ls" or "dir" without it hanging. Basically can't see anything.

The administrator also states that I don't have a "home" directory and once I log in I will be placed into a "shared" directory with other users. I've yet to successfully view anything.

The admininstrator has told me its my FTP clients or my firewall blocking FTP traffic. I've been unsuccessfully to log into his server with a number of FTP clients, command lines, 2 different locations, 3 different OS (Windows2000, Linux and MacOSX) and all have reported the above response.

I believe the error is Unix administrator issue and not my FTP clients (which all do work on different FTP sites) The administrator is stating that its not their site. I just don't know enough Unix to converse efficiently.

Who wins?
# 2  
Old 10-18-2002
My guess is that you're trying to use passive mode ftp and the server doesn't support passive mode. Open a connect to the server and type "rhelp". Does the list of commands include PASV? (The list of commands should be returned back down the control connection so this should work.)

If that's not it, you will need a network engineer with a sniffer to watch the packets and see who is fumbling. It may indeed be a firewall issue. You are ok when the server and client establish a control connection. But you are locking up when the client and server attempt to establish a data connection.
# 3  
Old 10-18-2002
Hello, Just checked again and I've tried passive and active mode, and yes the server does support passive.

I've also tried from 2 completely different locations with the same result:

230-No directory! Logging in with home=/

And all not displaying the directory contents. Its hard for me to imagine that's its my end when the result is the same from 2 locations.
# 4  
Old 10-18-2002
Don't let that message throw you. It's not related to your problem although it may indicate another problem once you can establish a data connection. And like I said, you now need to to capture and decode the packets to see what's going on. This may be a firewall issue on his end.
# 5  
Old 10-18-2002
Thanks Perderabo, I'll do. I'll see if I can find some sniffing software now.
# 6  
Old 10-19-2002
The 'no home' message you are seeing is because the admin on the other end doesn't know what he's doing. A home directory hasn't been setup for the account you are logging in under, so it defaults to /, which usually isn't a good idea.

If you are able to ftp to other sites successfully then the problem isn't on your end. Its on the server side and that admin needs to do the debugging of his setup.

And a bit of a rant -- ftp is insecure! If you are using an account and password you are at the least revealing this info to anyone sniffing in-between. If this login and password is the same as your login/email to the server then you have just given away the farm to anyone listening in.

Use ssh, scp, sftp instead. Lobby your sysadmins to do the same.

# 7  
Old 10-21-2002
bcl, do you use SMTP or IMAP for mail? If yes to either, then you're doing the same thing.

Unless of course you're one of the few clients using Secure [SMTP|IMAP]...

Also, ssh is insecure because it's got so many darn security holes...
ssh is higher up than FTP, even...
Login or Register to Ask a Question

Previous Thread | Next Thread

4 More Discussions You Might Find Interesting

1. Linux

Where are people landing on the sytemd debate?

My two primary distros are Gentoo and Debian and I'm a fan of the older more traditional init system but as we all know Debian is moving to systemd. Not sure how impartial the crowd is here but I'd like to hear people's opinions. (4 Replies)
Discussion started by: Swathe
4 Replies

2. HP-UX

[Solved] Unable to rename file in ftp server .Net:FTP perl

Hello All, I am trying to connect to ftp server and get the files. Also i need to rename the file in other ftp dir. rename method is not allowing me to rename the file in other dir. When i tried copy command by using net::FTP:FILE then perl says it is not installed. Can some body help me to... (2 Replies)
Discussion started by: krsnadasa
2 Replies

3. UNIX for Advanced & Expert Users

Using FTP to check whether file is completely FTP... plz find the description below

Hi, We have some clients who will place huge files in to one of the remote server. And the shell script written in our local server to retrieve client files (using FTP) placed on one of the remote server of ours by clients. My question Is there any FTP command/script to check from my local... (1 Reply)
Discussion started by: nmsrao
1 Replies

4. Linux

Linux-laptop compatibility debate

Hey guys, i use my mac laptop and i love it, but i have decided its time to break the mold and use linux, and since linux on macs suck, i need to know what kind of pc to build... I want to know what kind of motherboard, wireless cards, hard drives, laptops, video cards, and etc. people have had... (3 Replies)
Discussion started by: mesaynaysayer
3 Replies
Login or Register to Ask a Question