Having Problem with crontab command


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Having Problem with crontab command
# 1  
Having Problem with crontab command

Hi all ,
When i am tryting to execute crontab from home directory for a shell script which is located in some directory it is giving a error message

The crontab file is
0 9-17 * * 1-5 /mydir/myshell

The following output is given
Your "cron" job

/mydir/myshell

produced the following output:

sh: /mydir/shell: does not exist

URGENTLY REQUIRE HELP
THANKS IN ADVANCE

Regrads
Arunava
# 2  
Smilie Hi Arunava

I have my crontab like this

17 09 * * 1-5 /mydir/myshell.sh

First the minutes then the hours.This how it works on my true64unix.

But don't forget the full path..

Peterh
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #956
Difficulty: Medium
A polymorphic virus infects files with an encrypted copy of itself which is decoded by a decryption module which is modified on each infection.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Problem with running the "autorep" command via crontab

Hi, The user "MadeInGermany" tried to help on the below post by saying "This has been asked before; see the links below. Get your current LD_LIBRARY_PATH and redefine that in your ksh script! " Thanks for the help. but this did not help. And my post got locked. I can't reply on my previous... (5 Replies)
Discussion started by: girish1428
5 Replies

2. Shell Programming and Scripting

Crontab problem

Hi One shell script is running fine when I am running it through command line. However the same thing is not working when I am trying through cron. Basically when I debugged I found when I am running it throuh ssh terminal ( putty) it's getting loading the profile file properly but... (7 Replies)
Discussion started by: Anupam_Halder
7 Replies

3. Solaris

Crontab Problem

Dear All I have machine with SunOS APP5a 5.9 Generic_122300-19 sun4u sparc SUNW,Sun-Fire With crontab like this : 59 23 * * * /home/lng/script/move_and_compress_logs_update.sh But that crontab cannot running at that time. I run my script by manually, the result is fine. What must I check at... (5 Replies)
Discussion started by: mbah_jiman
5 Replies

4. Shell Programming and Scripting

Crontab command substitution problem

Hi all, I am using Ubuntu 8.04 Linux. I have a cron job entry to run a shell script at a scheduled time. This script has a X application to be launched. As cron does not pick already exported environment variables and it runs in a separate environment, I need to export the DISPLAY variable to... (9 Replies)
Discussion started by: royalibrahim
9 Replies

5. AIX

Problem with crontab

Hi, Can anyone let me know the functionality of the following command in Unix crontab ;l Thanks, Wajith.M (3 Replies)
Discussion started by: Wajith
3 Replies

6. UNIX for Advanced & Expert Users

crontab problem

hi.. i have a program (tf.sh), and i want what it runs automatically with a "lapsus" of 2 hours. (1,3,5,7,9,11,13,15,17,19,21,23 hrs.) i know what i have to do it using crontab, but i dont know how to do it. i have the next idea, but the problem is what it doesnt run on my server... (11 Replies)
Discussion started by: DebianJ
11 Replies

7. Linux

crontab problem

Hello, I have this in the crontab 30 2 * * * /bin/sh /home/abc but in the log it looks run below Jan 27 08:30:01 localhost crond: (root) CMD (/bin/sh /home/abc how could this happen? I logged in with root user,I use root user's crontab. Kind Regards (9 Replies)
Discussion started by: sunsail
9 Replies

8. UNIX for Dummies Questions & Answers

Crontab problem

I have script which uses "for loop" for doing some activity. Inside for loop i have extracted some data and redirecting it to HTML file using "echo" command. When i run this script manually it runs fine and appends the data in the HTML file. However, when I am croning this script for every 5 min... (2 Replies)
Discussion started by: manandixit
2 Replies

9. Shell Programming and Scripting

Crontab problem

Hi all, I made few changes to the script (under the directory mentioned in crontab) scheduled under crontab and the problem is that crontab doesnt pickup those changes and somehow runs the old copy of the script from somewhere. Any help would be appreciated. (8 Replies)
Discussion started by: vinoo128
8 Replies

10. UNIX for Dummies Questions & Answers

Problem with Crontab

I have a problem with crontab. I made a class file name Mailer.class. When I run it at command line like this: $ java Mailer It runs very well and I got the email. But If I put it in a crontab line like this: 30 11 * * * java Mailer It doesn't work. Every time the cron job... (5 Replies)
Discussion started by: qhuynh
5 Replies

Featured Tech Videos