I got a corrupt /etc/inittab file....what next?

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers I got a corrupt /etc/inittab file....what next?
# 1  
Old 09-27-2002
Power I got a corrupt /etc/inittab file....what next?

Hi guys,

For some reason a client has given us a Sun Netra T1 with Solaris 8 to administer for them. That's always good business. However, the other day we rebooted the machine and to our amazement, after doing the preliminary hardware tests, we got an error messgae saying that /etc/inittab was corrupt. It subsequently wanted to bring the machine up into single user mode which also failed. I guess because it also needs the /etc/inittab file. On top of this we don't have a cdrom or floppy drive in it, only a network card.

Has anyone got any suggestions as to how I can fix this problem.

Also, I am not new to Unix but I AM new to Sun/Solaris.

Thanks in advance.
# 2  
Old 09-27-2002
I'm not familiar with the Netra. But I found this on Sun's web site...
The Netra[TM] X1 server comes preinstalled with Solaris[TM] 8 Update 2 (10/00), including LOM (Lights out Management)software and all the patches it needs to function correctly. Because the Netra X1 server does not contain a CD-ROM drive and the Solaris installation media is not bootable on this system, if you need to reinstall the Solaris 8 operating environment, you must do so from a network install server. Additionally, the Netra X1 Drivers must be downloaded from Sun and added to the installation image.
This means that if you can't get that thing to boot, you are going to need a network install server. And really, you are going to need a Sun/Solaris guru to go with it. I guess that I might call my local Sun office and ask them to handle this.

Before that, I would be sure that I really can't get into single user mode. Can you get an "ok" prompt? What are you doing to get into single user mode? "boot -s"? If that doesn't work you may need to use the above procedure to reinstall.

I found one Sun Doc that says "boot -s" from a cdrom is way out of a corrupt /etc/default/init so it may be impossible to get to single user mode with a corrupt /etc/inittab as well.

If you do get yourself out of this fix, please post back and tell us what it took. Good luck.
# 3  
Old 09-30-2002
Hello again and thanks for the reply!

We have solved the problem I mentioned above, and indeed as you wrote we called the local Sun office who sent their guru to help us out. They also charged us an enormous amount but that's the way it works nowadays. The fix itself was rather basic but as in most cases you have to know it first.

Next to the Netra you need an installation server in the network and you also need to know the MAC-address of the network card in the Netra. This can be found in the documentation which comes with the machine.

The software for the installation-server can be downloaded from the Sun site or you can use CD-ROM's which, in our case, the Sun technician brought along.

Solaris had to be reinstalled on the Netra and to do this there is a wizard on the installation server which guides you through the whole procedure. Like I just mentioned, you need to provide the MAC-address of the Netra when it asks for it. The server boots the Netra and the installation can proceed much in the same manner as a normal installation.

As for why the inittab file was corrupt remains a mystery for us. We assume that someone had tried to install Solaris before but did not complete the installation.

# 4  
Old 10-01-2002
Those netra x1/t1 sucks big time...we fried 2-3 boards on them.
they're cheap but...
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Solaris

UNIX : how can I recover a corrupt tar file from a tape?

I've a tape contains a corrupt tar file. I'm using Unix SunOS 5.5.1. So when I run this command : dd if=/dev/rmt/0 of=/tmp/outputfile.tar I get this error message : warning /pci@1f, 0/pci@1/pci@1/sunw, isptwo@4/st@4,0 (sty): Error for command : read Error Level: Fatal Requested... (2 Replies)
Discussion started by: akaderb
2 Replies

2. UNIX for Dummies Questions & Answers

What breaks inittab

Today there was a situation where processes running from inittab was broken. Can someone help me understand, how to find out, who might have stopped those processes? Or how does it get broken? G (2 Replies)
Discussion started by: ggayathri
2 Replies

3. UNIX for Advanced & Expert Users

Linux on vmware won't boot due to corrupt library file!

We have an issue here: The libc.so.6 file (link) is corrupted and it causes the system unbootable. It even doesn't boot to single user mode. How can we boot the system to fix the library file? Or is there any other solutions for this issue? Here are some boot messages:... (6 Replies)
Discussion started by: aixlover
6 Replies

4. Solaris

Recovering from corrupt /etc/system file

Hi I would like to know one thing while recovering from corrupt /etc/system file. For that we have to do at ok> boot -a when system ask for system file we give /dev/null. Could any one tell me what /dev/null value will do in this case. Regards (1 Reply)
Discussion started by: sb200
1 Replies

5. UNIX for Dummies Questions & Answers

Zipped tar file is corrupt

Hello, I am currently dumping 30-40 reports on a Unix folder located here /home/apps/reports/prode/excel I use K-shell to do this task. In that, I use the gzip command to compress these files. I want to be able to use a tar command to first load the entire directory into one file then gzip that... (2 Replies)
Discussion started by: Pramodini Rode
2 Replies

6. AIX

GPFS file system corrupt issue

Hi Administrators, I have one issue related to GPFS filesystem. We have bad entries in this file system, which reflects error like ls: 0653-341 The file <filename> does not exist. when we give "ls -ltr" on this directory. So we taken the FS filesystem offline and followed the below steps. ... (6 Replies)
Discussion started by: gauravgarg
6 Replies

7. UNIX for Dummies Questions & Answers

find a corrupt tar file

Hey there I am just looking for a way to find a corrupt tar file. I want to write a script to help sift through the 1000's of tar files we go through daily and move any corrupt ones to a different directory structure. Is there an easy way to do this. (4 Replies)
Discussion started by: car2nst2006
4 Replies

8. HP-UX

Corrupt Member File

I have been fine adding/removing printers up until this week. Now when I go to add a new remote printer I get "corrupted member file". I go to /etc/lp/member and the byte count on the new printer name is 0. I VI the file and put /dev/null in to make it the correct size and it all looks fine and... (2 Replies)
Discussion started by: astout
2 Replies

9. UNIX for Dummies Questions & Answers

inittab solaris

Hi! Is it possible to add more ttys in Solaris, like with inittab in Linux? I want to switch between the ttys with Alt F1+F2+F3 .... like Linux does. How can i do this? (1 Reply)
Discussion started by: donald1111
1 Replies
Login or Register to Ask a Question