sun solstice, admintool, smc

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers sun solstice, admintool, smc
# 1  
Old 09-24-2002
sun solstice, admintool, smc

hi, i tried these sun command on a sun0s 5.7 but get the "cant open display" message. please advise. i am using netterm to telnet.
# 2  
Old 09-24-2002
Bug I try to remember

the last time i did this was a year ago, so maybe you need the man pages to manage this.

But, the window system doesnot know where to open the terminal OR is not allowed to open a terminal

First thing you can try is;
>> xhosts + #on the console window as root

and try to restart the admintool

or sete the env. param. DISPLAY by (if on the csh)
>> setenv DISPLAY `hostname`

I hope this helps
# 3  
Old 09-24-2002

When you only have a telnet connection you can NOT use the grafical `admintool`
# 4  
Old 09-24-2002
To run the GUI interface, you have to have X running on the system you came from.

fyi- xhost is in /usr/openwin/bin/. You must run the command on your system (if it's a UNIX system) on a console window.

If sh or ksh, $ export DISPLAY=x.x.x.x:0 (where x is your IP address). Csh was explained already. This command is done on the system you connected to.

If you are on a NT or Window box, then you can still do it - just insure you have X running. Usually a 3rd party product. Search goggle to see if there are any you can get.
# 5  
Old 09-24-2002
netterm for sun interface

hi all!
i am using netterm. i think sun should have something like smitty from ibm to administer instead of going all the way to the console just to get the interface.

just my two penny worth of thoughts.... please advise if it is possible if i used netterm for sun solstice, admintool, smc

# 6  
Old 09-25-2002
You can see a comparison list of commands (IBM to Solaris) on this web page at ibm.

i think sun should have something like smitty from ibm to administer instead of going all the way to the console just to get the interface
1. Smit (in GUI form) interface is like admintool and you need either X to run it. Has nothing to do with being on the console. If YOU are logging into system B (UNIX) from system A (UNIX) to run a X GUI, then you need to open system A to accept X traffic. That can only be done from the console window of system A. There are two different terminal window in most UNIX flavors - a console terminal window, and a terminal window.

2. You actually would like admintool to work like smit. Smit can be either a GUI or text based. Please forward your wishes to Sun. I wouldn't mind seeing it either.

FYI - different ways to admin a AIX system.
Web-based System Manager, an object-oriented GUI that provides assistance for less experienced administrators and remote administration of one or more machines from any client platform.
The System Management Interface Tool, or SMIT, a task-oriented, menu-based interface that supports all common administration tasks. There are two versions of SMIT: an X Window version that provides GUI features such as point-and-click operations, and an ASCII text version that can be run on any character-mode terminal.
AIX command strings, which can be invoked directly by the user from the command line or through scripts. Both Web-based System Manager and SMIT execute these same commands from within their interfaces.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

HP Printer without SMC, Admintool, or Jetadmin

Jetadmin fails saying that it is not a network printer despite the fact that it is and can be pinged from UNIX. I am administering this remotely (long remote, I can't go there soon) and can't run smc or admintool. Any help configuring this spooler would be appreciated. (1 Reply)
Discussion started by: TT Fan
1 Replies

2. Solaris

Looking for Solstice DiskSuite 4.2

Hi all, Do you know where I can download Soltice Disksuite 4.2 for Solaris 2.6 ? I haven't the CD labeled “Solaris Server Intranet Extensions 1.0” . Thanks in advance for your precious help. Bests Regards Hosni (2 Replies)
Discussion started by: hosni
2 Replies

3. Solaris


How can I solve this admintool Error: Can't open display: (4 Replies)
Discussion started by: iwbasts
4 Replies

4. Solaris

what happened to admintool?

what happened to admintool in Solaris10? (2 Replies)
Discussion started by: mndavies
2 Replies

5. Solaris

Solstice DiskSuite

Has anybody every used Solstice DiskSuite? I am having trouble setting it up. I installed it without a problem, but do I really have to blow away the drives on the D1000 just to create a metastate database? (8 Replies)
Discussion started by: hshapiro
8 Replies

6. UNIX for Advanced & Expert Users

Printer Error with Admintool

Hi I have a unix box [ Solaris 2.5.1 , sparc staion 5_10 ) I could successfully configure a LOCAL printer using lpadmin -p XX -v /dev/term/a But when I tried to do local printer configuration with admintool, ( as root user ) it throws up error. " add printer failed ". Also when I... (4 Replies)
Discussion started by: shibz
4 Replies

7. UNIX for Dummies Questions & Answers


I am new to unix....How do I enable XWindows... Or for that matter, use Admintool. .....Pls. help. Thanks. PS. I am running Solaris 8. (3 Replies)
Discussion started by: d4jtwvb
3 Replies

8. UNIX for Dummies Questions & Answers

admintool : error display..

hi, i did the following 1) which admintool /bin/admintool 2) admintool Error: Can't open display: how to set the display then? i am using netterm to telnet to my sun server. (6 Replies)
Discussion started by: yls177
6 Replies

9. UNIX for Dummies Questions & Answers

problem with admintool

hi, after i execute admintool, i got the below "Error, cant open display" what is wrong? thanks (5 Replies)
Discussion started by: yls177
5 Replies

10. UNIX for Dummies Questions & Answers


Hi, Does anyone here know where I can find out what commands admintool runs while adding a new user and setting up the account? Reason being is the script I am writting, I can add the user create the path. But it wont set the path for the user. The password well it wont add without... (1 Reply)
Discussion started by: merlin
1 Replies
Login or Register to Ask a Question

Featured Tech Videos