GCC causing problems it seems.


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers GCC causing problems it seems.
# 1  
Old 09-10-2008
GCC causing problems it seems.

Hi, I seem to be getting errors in relation to GCC it seems as I cant upgrade alot of pkgs until I can upgrade or use a later version of GCC.
The error I get is along the lines of ( cc1: error: unrecognized command line option "-Wno-pointer-sign"
*** Error code 1 )
Anyway I was wondering if anyone could tell me how I can get My FreeBSD to use a newer version of GCC. I was thinking of upgrading to GCC 4.4.0
I also have GCC2.8.1_3 installed & I also have GCC4.2.5 which I think I upgraded to along time ago but it either isnt recognised or isnt high enough as I still get these errors.
So I was wondering how to go about fixing this error so I can begin to upgrade my software again,
Like do I have to force a deletion of the old GCC first or is there a way to cause a later version to be recognised after upgrading GCC ,as I am not sure if its OK to have multiple versions installed etc...

jasons-braain# uname -a
FreeBSD jasons-braain 6.3-RC2 FreeBSD 6.3-RC2 #30: Sun Jan 6 01:30:27 UTC 2008 root@tinderbox.3c-consulting.lokal:/usr/obj/usr/src/sys/GENERIC i386

Thanks anyOne.

Last edited by Browser; 09-10-2008 at 06:38 AM..
# 2  
Old 09-12-2008
Solved....
# 3  
Old 09-12-2008
Solved how?
 
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. AIX

Problems to install gcc 7.2 on AIX 7.2

We need gcc 7.2 on AIX 7.2 and so I tried to install the rpm package from IBM (<https://www-03.ibm.com/systems/power/software/aix/linux/toolbox/alpha.html>) The steps were as follows (I downloaded all packages from the given IBM toolbox page): # :-)rpm -ihv gcc-7.2.0-1.aix7.2.ppc.rpm error:... (2 Replies)
Discussion started by: BuSchu
2 Replies

2. Shell Programming and Scripting

Percentage sign causing awk problems

looks like awk gets confused when there's a % next to a number. command im running: awk -F" " '/phxnaz001b/ && /vol/ && NF { if (($NF >= 80) && ($NF < 83)) { print ; print ; w++ } else if ($NF >= 83) { print ; c++ } } END { printf("%d:OK %d:WARNING %d:CRITICAL\n", o, w, c) }' /tmp/test.log ... (3 Replies)
Discussion started by: SkySmart
3 Replies

3. Linux

Problems with gcc

Hello I'm not able to install gcc. My platform is # uname -a Linux localhost 2.6.18-194.el5 #1 SMP Fri Apr 2 14:58:14 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux #yum install gcc I got the following error ---> Package libgfortran44.x86_64 0:4.4.4-13.el5 set to be updated ---> Package... (2 Replies)
Discussion started by: My Style
2 Replies

4. Shell Programming and Scripting

Nohup causing issues

Hi folks... I really need some help soon with this issue I am having when I run my script using 'nohup'. Below is a function 'checkReturn' that my script uses to check whether other functions or tasks errored out with a non-zero exit code. function checkReturn { if ; then ... (2 Replies)
Discussion started by: ChicagoBlues
2 Replies

5. AIX

problems with gcc on AIX 4.33

I just installed gcc on AIX 4.33, and I am having some problems with compiling a simple hello world program. See output below for the issue. The "standards.h" file is not on my system and I don't know where to get it. Thanks in advance for your help! # gcc -v Reading specs from... (2 Replies)
Discussion started by: jhall
2 Replies

6. Solaris

Installing gcc - recieve error message gcc : cannot execute

AIM- Install Oracle 11g on Solaris using VMWare Steps 1.Logged on as root 2.Created subfolders /usr/local/bin & /usr/local/bin/gcc 3.Downloaded gcc & libiconv & unzipped them on my harddrive & burnt them on CD 4.Copied files from CD to /usr/local/bin/gcc 5.Terminal (root) pkgadd -d... (8 Replies)
Discussion started by: Ackers
8 Replies

7. SCO

Problems with gcc compiler

Hy everone! I have an old SCO 5.x machine on which I want to install openssh. Since there was no GCC compiler installed I had to install that too. I'm not a programmer and not so familiar with SCO, so I have a couple of questions. I did everything "by the book" as it says here: Where can I... (1 Reply)
Discussion started by: veccinho
1 Replies

8. Solaris

gcc problems

I downloaded and installed the gcc binaries recently. I am now trying to compile openssh, but I get bad compiler issues when I try this. in the openssh directory, I run: ./configure (mind you, I have usr/local/bin/gcc in my PATH) but the output says checking for gcc... no Why... (7 Replies)
Discussion started by: AJA
7 Replies

9. Post Here to Contact Site Administrators and Moderators

HTML is causing problems

I have to suggest that we turn HTML back off. The problem is that angle brackets are used in code and this is causing stuff to get dropped from posts. I know that we can use the constructs that PxT mentions in this thread. But look how hard it is to educate folks about code tags and the search... (4 Replies)
Discussion started by: Perderabo
4 Replies
Login or Register to Ask a Question

Featured Tech Videos