Visit Our UNIX and Linux User Community


SVR4 UNIX questions


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers SVR4 UNIX questions
# 1  
Old 09-05-2008
SVR4 UNIX questions - Edited with updated info

Hi

My main problem is trying to reset the password on an ancient (but still live) server. I have booted from floppy into maintenance mode, but it won't allow me to mount /. I'm using mount -F vxfs /dev/dsk/c0t0d0s1 /mnt and I get an error message along the lines of "operation not applicable to file type vxfs". I've tried using ufs and xfs and also leaving out the -F bit, but then get a message about the FS type being incorrect.

Any idea why it won't allow me to mount /?

I've resurrected a 'test' server to allow me to have a bit of a play, but I have no install media to boot from. Is there any way I can create a bootable floppy for this server?

Any help gratefully received.

ETA: It seems that the install floppy we have doesn't include the veritas FS support needed to mount the vxfs filesystem. We do have a later boot floppy, but this no longer works.

Is there any way that I can create a boot floppy disk that I can boot the server from to allow me to edit /etc/passwd??

Last edited by sweetleaf; 09-05-2008 at 12:33 PM..
# 2  
Old 09-05-2008
If you have a jumpstart server on the network, try:
ok: boot net -s
mount -F vxfs /dev/dsk/c0t0d0s1 /mnt
You'll need to manually mangle /mnt/etc/shadow, as any passwd commands would be related to the "current" os instance, rather than the mounted instance.

Disclaimer: I've not tried to do this with a vxfs volume


Edit: You'll have to follow normal configuration rules for adding a host to the jumpstart environment - updating bootparams
and of course, this only works for SUN gear... Smilie
# 3  
Old 09-08-2008
It's not Sun kit (nor is there another server one site as far as I know). But thanks for the info Smilie

Just trying to source a ready made boot disk now.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #578
Difficulty: Medium
Lists are ordered collections that are essentially static arrays.
True or False?

8 More Discussions You Might Find Interesting

1. Hardware

Upgrading antique Unisys U6000 / UNIX SVR4 1.2?

I have an old Unisys U6000/65 server I obtained as surplus about 12 years ago. For its day (1993) this server line was capable of insane ability, up to 4 gig of memory using dozens of 30-pin SIMMs and up to six processors, including mixed processor speeds and types (486/Pentium) in the same... (2 Replies)
Discussion started by: DMahalko
2 Replies

2. Shell Programming and Scripting

unix questions

Hello, Hello, Can any one tell me the answer of these questions attached in the document. The competition was over and I wanted to know correct answers. (6 Replies)
Discussion started by: bits1904
6 Replies

3. UNIX for Advanced & Expert Users

need help adding network printer on SVR4

We have a very old and unsupported box. It runs DC/OSx, SVR4. For the past 12 years all printers have been connected via terminal servers and working well. Now those terminal servers are dying and cannot be replaced or repaired. Of course the right solution is to upgrade, but that's not gonna... (10 Replies)
Discussion started by: jbcamel
10 Replies

4. Virtualization and Cloud Computing

SVR4 on virtual machine help

Hello to all UNIX experts! This is my problem: I have to emulate an old UNIX System 5 release 4 on a virtual machine. I've got 30 images (.IMA) of 1.4M floppy where there is the installation of SVR4. How I can install it with those files? I tried with Vmware 7 workstation but it says 'Operating... (6 Replies)
Discussion started by: mghis
6 Replies

5. UNIX for Dummies Questions & Answers

Copying large file problem on SVR4 Unix

We have 3 Unix servers all running SVR4 Unix 1.4. I have no problems copying files to and from 2 of the servers using either the rcp command or ftp but when i come to transfer large files to the third server the copy gives up part way through and crashes this server. Copying smaller files using RCP... (7 Replies)
Discussion started by: coatesd
7 Replies

6. UNIX for Dummies Questions & Answers

Some UNIX Questions!

1. Someone pings a server from another location and gets a different result than if you ping the same server onsite. What is going on? 2. You know the reason the server won't boot is because of ODS, but the root partition isn't on ODS. How do you go about fixing it? 3. How would you truncate... (1 Reply)
Discussion started by: JoeTheMan
1 Replies

7. UNIX for Dummies Questions & Answers

I have a few questions about Unix..

Hi I have just a few questions about the Unix aka NIX operating system. 1. Is it a free Operating System and if so where can I obtain it. 2. Where can I start out for a newbies guide to the OS. Thanks (1 Reply)
Discussion started by: SolidWing68
1 Replies

8. UNIX for Advanced & Expert Users

SVR4 or BSD?

Can we determine (reliably or guaranteed) at runtime if a system is SVR4 or BSD based, using two methods, shell and binary (C code)? (2 Replies)
Discussion started by: qanda
2 Replies

Featured Tech Videos