Having a run fsck manually problem...

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Having a run fsck manually problem...
# 1  
Old 09-05-2008
Question Having a run fsck manually problem...

so i am pretty dumb when it comes to unix. but i am in the navy and the system i work on is unix based. and we have come across this problem.

(in bcheckrc)#

Now all i have tried to enter is /etc/fsck -n but when i do that it says "/etc/fsck: not found" i am trying to avoid reloading software, so any help would be greatly appreciated.
# 2  
Old 09-05-2008
can you check the below command
#which fsck

# find / -type f -name "fsck"

-->then go for the file check

Last edited by Yogesh Sawant; 04-10-2011 at 11:49 AM.. Reason: added code tags
# 3  
Old 09-05-2008
I'd guess it would be in /sbin, not /etc. What operating system is this, exactly?
# 4  
Old 09-05-2008
which fsck and fsck -y
# 5  
Old 09-07-2008
#fsck -a
#reboot -n

Last edited by Yogesh Sawant; 04-10-2011 at 11:50 AM.. Reason: added code tags
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Disk corruption? Cant run fsck....

NOTICE: /: unexpected free inode 45262, run fsck(1M) fsck: cannot open vfstab Looks like /etc/vfstab (and a few other files has gone) Any ideas? Boot from cd, mount disk and recreate vfstab so that I can run fsck? (1 Reply)
Discussion started by: psychocandy
1 Replies

2. UNIX for Dummies Questions & Answers

Scripts can be run manually but couldn't run with cronjobs

I am from MQ/MB technology. My requirement is to display the queue manger and broker status on daily basis. If I manually run the script, it works fine and displays output. But when I have scheduled the same using cronjobs it shows only the queue manger status and not the broker status. Can... (3 Replies)
Discussion started by: Anusha M
3 Replies

3. Solaris

unable to repair the / filesystem. Run fsck manually (fsck -F ufs /dev/rdsk/c1t0d0s0)

What can I fix this issue? I have ran below commands but everything is same.:confused: WARNING: Last shutdown is later than time on time-of-day chip: check date. The / file system (/dev/rdsk/c1t0d0s0) is being checked WARNING - unable to repair the / filesystem. Run fsck manually (fsck -F... (4 Replies)
Discussion started by: getrue
4 Replies

4. Solaris

Not able to run fsck on root file system

I am trying to root disk mirroring on SunFire V210 Server. There are two disks on this server c1t0d0 and c1t1d0 . I completed all the steps and I updated the vfstab file too. After I have updated the vfstab file I run df -h command but could not see the changes i made in vfstab. Suddenly the server... (1 Reply)
Discussion started by: newbi8321
1 Replies

5. Solaris


Hi, I am getting this error while server booting up, not sure how to fix this. Unable to mount these file systems /dev/md/rdsk/d51: No such device or address Can't open /dev/md/rdsk/d51: No such device or address /dev/md/rdsk/d51: CAN'T CHECK FILE SYSTEM. /dev/md/rdsk/d51: UNEXPECTED... (1 Reply)
Discussion started by: bobby320
1 Replies

6. HP-UX

fsck doesn't work - not even run?

Hi, please consider, I'm pretty new to HP-UX, thanks. Our server (rp7420 with HP-UX 11.31) has crashed due to disk write error (not boot partition). So I replaced damaged device with the new one of the same size and performed dd copy 1:1 to restore data - vxfs partition "/dev/vg01/lvol1"... (4 Replies)
Discussion started by: Morhoo
4 Replies

7. Solaris

Run fsck from standard login

Hello. I have created a FS /u00/ and created a non-root login under this FS. Also, disabled direct root login. Now is it possible or worth moving this login over to the root partition or allowing mount/umount + fsck from a standard account. As I am not able to run fsck for this FS. How to... (5 Replies)
Discussion started by: panchpan
5 Replies

8. Solaris

fsck run

Hi, Can anybody tell me that is it the command "fsck" can be run by the root account only? Thanks. (2 Replies)
Discussion started by: efang
2 Replies

9. Shell Programming and Scripting

Can run script Manually, but not through Cron?

Hi all, I have a main script (called OracleCleanup) that runs some sql queries. that runs off a wrapper script which contains the sources for the login information and and JOB_HOME (the script is below). When I schedule this job in the cron the log says that it cannot open my list file, which... (4 Replies)
Discussion started by: MadHatter
4 Replies

10. UNIX for Dummies Questions & Answers

run fsck on swap slice?

Hi.. i am using sun solaris...and this is the filesystem information... you can see th slice(swap) c0t0d0s1 is giving some absord information......and during rebooting it is asking to run fsck mnually..when i run fsck manually it is giving error incorrect starting and end header...smthing like... (1 Reply)
Discussion started by: Prafulla
1 Replies
Login or Register to Ask a Question

Featured Tech Videos