error reading from tape

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers error reading from tape
# 1  
Old 08-29-2002
Error error reading from tape

Hi all,

I am attempting to read tar images from a DLT tape, and have recieved an error, which i don't know:

tar: blocksize = 8
tar: directory checksum error

I have been able to read from other tapes, using the same command (tar -tvf /devicename) but this time i have an error.

Can anyone firstly tell me what it means, and secondly, how to get round it?

Thanks in advance

# 2  
Old 08-29-2002
If your default blocking factor is smaller then the blocking factor used to create the tape, it will let you know what the blocking factor is and error out with a tape read error. It may be that is the case although the default blocking factor should be 10.

See the man page on tar and search for block or blocksize. It should have examples of this.

You can try your command with a blocking factor to see if that helps get around it:

# tar -tvbf 8 /devicename
# 3  
Old 08-30-2002
I have stipulated the blocksize using the b option, but am stlll getting this "tar: directory checksum error".

Any ideas of how to solve this part?

# 4  
Old 08-30-2002
Looking up the error on SunSolve shows this error if the file was created with gtar (GNU tar). If this is the case, there are times when SUN's tar will not extract files and give this error OR will extract some files and stop with this error. The 'fix' is to use gtar which can be downloaded from Sun Freeware

Did you create the tar file or is this part of a package you are installing?
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. SCO

Error: msgcnt 1 vxfs: mesg 016: vx_ilisterr - / file system error reading

Hello... i got an error in my SCO OpenServer 6. the error is: msgcnt 1 vxfs: mesg 016: vx_ilisterr - / file system error reading inode 373 Can anyone help me? (1 Reply)
Discussion started by: AndryMB
1 Replies

2. UNIX for Advanced & Expert Users

ssh error: Error reading response length from authentication socket

Hi - I am getting the error `Error reading response length from authentication socket' when I ssh from my cluster to another cluster, and then back to my cluster. It doesn't seem to affect anything, but it's just annoying that it always pops up and tends to confuse new users of the cluster. I... (1 Reply)
Discussion started by: cpp6f
1 Replies

3. Red Hat

reading an AIX cpio tape on RH8

Thanks for any insights you might have... I have a RH8 system setup with a DAT drive. I have a AIX tape that was made using cpio. Bottom line is I need to read the AIX tape into the RH box. I was able to do cpio -itv --no-absolute-filenames < /dev/st0 and read the table of contents. ... (0 Replies)
Discussion started by: mike114327
0 Replies

4. UNIX for Dummies Questions & Answers

Reading label from tape

Hi, I have a HP SURESTORE 40 tape drive. Several archives are stored on it using DUMP. I have several volumes stored on the tape... If I issue restore -rf /dev/st0 will it restore just the arhcive that the tape reader is currently on or will it restore all of them? Thanks, (3 Replies)
Discussion started by: mojoman
3 Replies

5. UNIX for Dummies Questions & Answers

Reading a tape from a StorEdge Autoloader L8.

Does anyone know how to read an LTO tape from this jukebox? (3 Replies)
Discussion started by: dr. phreeze
3 Replies

6. UNIX for Advanced & Expert Users

Reading from a corrupted tape

I've got a backuptape in cpio format that was accidentally overwritten with a very small batch file. As I assume that the cpio header has been overwritten, I cannot extract files from the backup in the conventional manner: ( cpio -itv </dev/rct0 cpio: this is not a cpio file, bad header) ... (0 Replies)
Discussion started by: mart4179
0 Replies

7. AIX

Problem reading a 4mm tape drive

I'm attempting to read a tape in a 4mm drive (AIX 4.3) using the following command... tar tvf /dev/rmt0 ...and I keep getting the following error message: tar: 0511-193 An error occurred while reading from the media. There is not enough memory available now. I've googled this error... (2 Replies)
Discussion started by: tdpearson
2 Replies

8. AIX

reading contents on a 4mm tape

I am experimenting with one of my TSM processes, and I am trying to write something to a 4mm tape. I tried to use the tctl command, but, I was unsuccessful. what AiX command can I run in order to see if my output is on the tape ? Thank You ! (0 Replies)
Discussion started by: DATDANGGADUDE
0 Replies

9. SCO

Tape error.

Hi, I am new to unix. We use Travan tapes to backup. The tape drive on two of our machines was working fine till this morning till we used the cleaning tape. We put the cleaning tape on the first machine, it got struck so we have to pull it out. Since then when we do the tar command we are getting... (1 Reply)
Discussion started by: krk123
1 Replies

10. UNIX for Dummies Questions & Answers

reading from tape error

I have been attempting to read a DLT tape, but encountered problems. I have applied patches from SUN that 'resolve' known problems with tape reading etc...but still the error! Techsupport reckon that the data/tape is corrupt. I would like to think they aren't. Are there any issues with... (10 Replies)
Discussion started by: colesy
10 Replies
Login or Register to Ask a Question

Featured Tech Videos