piping with javac command

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers piping with javac command
# 1  
Old 08-29-2002
piping with javac command

how to i use javac on a file after searching for it? example:
find . -name '*.java' -size -24 -links -2 -atime -4

what would happen if "find" found >1 .java files?

also, i'm a little confused on the -size property... mix up between -2 and +2... what's the difference?
# 2  
Old 08-29-2002
You're either looking for all files under two 512-byte blocks (-2) or over two 512-byte blocks (+2).

So find . -name '*.java' -size -24 -links -2 -atime -4 is looking for all files with an extension of java which are under 12kb, have less than 2 links, and were accessed less than 4 days ago.

As for using javac on a file after finding it, you should just be able to use a pipe:
find . -name '*.java' -size -24 -links -2 -atime -4 | javac

If there's more than one, javac can handle multiple files, so I would assume the above would still work, but I'm not near a Unix box right now..

If you don't need the options that "find" provides, you could just use:
javac *.java

Last edited by oombera; 08-29-2002 at 03:26 AM..
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Abnormality while piping tr command output to sed

i have a file seperated each line seperated by newline. For example alpha beta gamma i am trying to replace the newlines to "," but dont want , present at the end of the line so i am trying the below one liner . but not sure whats wrong but its not working cat myfile | tr -s '\n' ',' | sed... (9 Replies)
Discussion started by: chidori
9 Replies

2. Solaris

Java and Javac problems

Ok need some help getting Java working I have the JRE JDK as well as the Netbeands IDE installed. But still having issues getting java and javac working from command line. Running Solaris 11 64 box. root@solaris:/usr/jdk/instances/jdk1.7.0/bin# dir amd64 javadoc jsadebugd ... (11 Replies)
Discussion started by: Fingerz
11 Replies

3. Shell Programming and Scripting

Syntax error piping to bc on command line - works when assigned to var

I have a script which outputs some timing data a line at a time. There are approx. 10 lines echoed, each line looks something like this: 0.741 http://checkip.dyndns.org I needed to add all the values in the first column, I piped the output to grep, matching and printing the... (7 Replies)
Discussion started by: gencon
7 Replies

4. Programming

set javac classpath

I have several jar files in a specific folder, but I can't get javac to understand it. How do I set the classpath for javac. It is NOT the same classpath as the java command. And it's not enough with one jar file. I have several. (1 Reply)
Discussion started by: locoroco
1 Replies

5. Shell Programming and Scripting

piping to 'open' command!

Hello! One command generates a file path, which I then want to open in finder. The slow way is this with C&P: $bundle show jquery-validator /Users/peter/.rvm/gems/ruby-1.9.2-p136/gems/jquery-validator-0.3.0 $open /Users/peter/.rvm/gems/ruby-1.9.2-p136/gems/jquery-validator-0.3.0 I... (4 Replies)
Discussion started by: pehrlich
4 Replies

6. Shell Programming and Scripting

Piping output from a command into bash script

Hi all. I am using procmail to deliver an email to a script I am developing. Procmail delivers the email to the script on standard input. I imagine this is the same as piping input from a command into the script. Hence I've been testing my script by running echo 'test' | sms-autosend-backup.sh ... (2 Replies)
Discussion started by: akindo
2 Replies

7. Shell Programming and Scripting

KSH script: piping passes command-line arguments

Dear forum I have the following small script: #!/bin/ksh echo -e "abba-o" | awk -F '-' '{ print $2 }' | cut -b 1It needs to be ksh.. in bash I don't have this problem. If I run this on opensuse 10.2 I get this as output: e If I run this on suse enterprise 10 sp2 then I get this: o ... (1 Reply)
Discussion started by: gemtry
1 Replies

8. UNIX for Dummies Questions & Answers

echo command and piping

Hi, I have heard you can use the echo command and piping together and was wondering if you can help me out. I want to be able to use the echo command and pipe together to tell me how many files are in my current working directory, which have only my username read, write and execute... (4 Replies)
Discussion started by: rushhour
4 Replies

9. UNIX for Dummies Questions & Answers

use of xargs and prune piping with find command.

Can anyone interpret and tell me the way the below command works? find * -name "*${msgType}" -mtime +${archiveDays} -prune -type f -print 2>/dev/null | xargs rm -f 2> /dev/null Please tell me the usage of prune and xargs in the above command? Looking forward your reply. Thanks in... (1 Reply)
Discussion started by: venkatesht
1 Replies

10. UNIX for Dummies Questions & Answers

piping the output of find command to grep

Hi, I did not understand why the following did not work out as I expected: find . -name "pqp.txt" | grep -v "Permission" I thought I would be able to catch whichever paths containing my pqp.txt file without receiving the display of messages such as "find: cannot access... Permisson... (1 Reply)
Discussion started by: 435 Gavea
1 Replies
Login or Register to Ask a Question