Can't su to root

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Can't su to root
# 1  
Old 08-26-2002
Can't su to root

I keep getting
"su: Your own ID is unknown" whenever I try to su to root.

Why is this??? I cannot find anything anywhere with this message.
# 2  
Old 08-26-2002
Make sure you are a member of the same group root is.
I'm new to this Linux stuff but I know "wheel" is the group used w/FreeBDS.

Hope it helps
# 3  
Old 08-26-2002
might want to check /etc/passwd and make sure that you do have a GID and UID for that account. Other than that, try with a diff account, then tell us what happens.
# 4  
Old 08-26-2002
Also, what OS and version are you using (can find this with the command uname -a). Some Unix variants will only allow specific user IDs to use "su" - you should probably talk to your administrator about this.
# 5  
Old 09-05-2002
SCO_SV tshsco 3.2 5.0.6 i386.

How do I check the UID and GID of root??
# 6  
Old 09-05-2002
% grep root /etc/passwd

The third field is the uid, the fourth field is gid. Read the man pages on passwd (section 4). Note your entry will look different than this example posted.
# 7  
Old 09-10-2002
When I checked the UID and GID for root and a user I got this:

When I went to create a new user I received these messages
Unable to create home directory for user : scott You must create a home directory before theuser c

Unable to create home directory
General Failure occured in processing request
/tcb/lib/useshell:File control database inconsistv
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

2. UNIX for Advanced & Expert Users

Can't log in other than root - display garbles

I'm hoping someone here can bail me out of this one. I have a box running SCO Openserver 5.0.2. I can log in as root fine, but if I try to log into any other account, I get: Last succenful login for xxxx "bunch of symbols" Standard copyright stuff and returns to a login... (8 Replies)
Discussion started by: craig2k
8 Replies

3. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

4. UNIX for Dummies Questions & Answers

mistyped shell path, now i can't login as the only user that can su to root

i mistyped the location of bash and now i can't login as the only other user who belongs to wheel on my freebsd box. since i'm having many problems with samba, this has frozen my attempts to get things resolved with the former issue. i've been told that 'su -m' should do the trick, but it's... (3 Replies)
Discussion started by: xyyz
3 Replies

5. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

6. Filesystems, Disks and Memory

HELP! The '/var/adm/message' file increase every few seconds???

Hi, guys, I have a big problem. I've got a sun solaris 4.1.4 workstation, and the /var/adm/message file will add one row every few seconds. It soon becomes a large file. I wander if there are some mistakes configuring the workstation. the /var/adm/message is as follow: ... (1 Reply)
Discussion started by: cloudsmell
1 Replies

7. UNIX for Dummies Questions & Answers

HELP ME HELP!!!! I can't Log in as root

I am running a Linux Red Hat 7.2 system and I can't log into the root account. When I tried to su to root from another user by using the command su - root, I get this error message: su: basename.c:67: base_name:Assertion `all-slashes || !((*(p - 1)) == '/ ' ) failed also, when I tried to... (10 Replies)
Discussion started by: TRUEST
10 Replies

8. UNIX for Advanced & Expert Users

Terminal 'Local Echo' lost on Modem Dial-out

Can anybody help me? I am developing a utility for automating message paging to a BT alphanumeric pager. I am using a USR 56K Fax-modem connected to /dev/cuab on a Sun Ultra-10. I am using the UNIX 'tip' utility to connect to the modem and I have configured the modem as follows: Baud Rate:... (2 Replies)
Discussion started by: mybeat
2 Replies

9. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

10. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies
Login or Register to Ask a Question