Mailx command not working


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Mailx command not working
# 1  
Old 08-06-2008
Data Mailx command not working

HI,
I am sending a html attachment with the help of mailx and uuencode command ..but it is not working properly.. Smilie
Following are the commands i tried out.

parmdir=/opt/dwqa1/TEST/status_test
uuencode $parmdir/some.html $parmdir/some.html | mailx -s TEST ajoshi@yahoo.com

But in the mail it comming as corrupted file.. Smilie
FOllowing are the conmtains of the mail..

begin 664 /opt/dwqa1/TEST/status_test/some.html
.5"!M86EL"F5N:F]Y(0H`
`
end

Is there any problem in the server...or is there nay problem in the OS..we are using linux... Smilie

Thanks in Advance! Smilie
# 2  
Old 08-06-2008
Question Perhaps try to send a text file

Make a small text file, and try to do the same thing with it. Results good or bad, you will know a lot more about the issue.

uuencode sample.txt sample.txt | mailx -s "Subject Line" ajoshi@yahoo.com

Update us with your results. Also, with specifics on unix version, hardware, etc...
# 3  
Old 08-07-2008
Power

Thanks for your reply!

I checked in my system..."nail" command is working fine....

As you said i have tried with '.txt' file and it working fine.. Smilie

nail -s TEST -a $value/some.txt ajoshi@yahoo.com

Now the problem with this command is every time when we use "nail" command we have to press "cntrl +D" Smilie
I have to use this command in shell scripting....can anybody tell me..how to use the above command in scripting... Smilie ..(since in automated script we can not press contrl + D everytime)Smilie

Thanks in Advance!
# 4  
Old 08-07-2008
It's expecting input from the terminal; tell it to expect input from /dev/null instead.

Code:
nail -s TEST -a $value/some.txt ajoshi@yahoo.com </dev/null

uuencode is pretty ancient; perhaps you should use a proper MIME sending client instead, these days (maybe nail is such a beast? Never heard of it before). See the FAQ forum for more on this topic.
# 5  
Old 08-07-2008
Thanks for your immedatie reply!

While searching , i have found out "mutt' command...
"nail" is generally used in the Linux...While searching in the google i found out that in Linux " instead of using 'mailx' command,use 'nail'..and it is working fine..only the problem is that we have to press 'control +D ' after the 'nail' command...

I tried using '/dev/null' ..no need to use 'control +D'..but i am not getting th mail.. Smilie
# 6  
Old 08-07-2008
Thanks All for helping me out....
Finally it working fine!Smilie
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Mailx stopped working

after a new patch set on the 14th. I noticed that mailx stopped working, as far a I can tell that is the only thing that changed. solaris 10 OS it seems everything is the same, sendmail seems to be running root@server # ps -ef | grep -i sendmail smmsp 687 1 0 10:42:25 ? ... (0 Replies)
Discussion started by: goya
0 Replies

2. Shell Programming and Scripting

Mailx not working on Linux

Hi, telnet localhost 25 Trying ::1... Connected to localhost. Escape character is '^]'. 220 TechBun ESMTP Postfix This command echo "hi" | mail -v me@mycomp.com does not send mail to my inbox and i get the below output. Upon investigation i saw this log file tail -f... (3 Replies)
Discussion started by: mohtashims
3 Replies

3. Shell Programming and Scripting

Mailx command not working in the script

when i am using Mailx command from AIX box, i am getting the following errors : uuencode: not found. mailx: not found. but when i executed the mailx command as shown below it worked cat /etc/hosts | mailx -v -s "test email" user@server.com It works fine in the production server. ... (2 Replies)
Discussion started by: pyaranoid
2 Replies

4. Shell Programming and Scripting

mailx is not working

i have a file.i want to get that file to my mail.mail services are running.but still i didn't receive the mail. i have used this command. mailx -s file1 muraliinfy04@gmail.com < file2.txt.can anybody help me.it's urgent.I am new to unix. actually file1 i have directed to a file2.txt (8 Replies)
Discussion started by: muraliinfy04
8 Replies

5. Shell Programming and Scripting

mailx -s is not working

Hello, I have two unix boxes.. One of the unix box version is Linux iduxlys 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:15 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux I have shell script which has the below script. cat xyz.log|mailx -s "export is Successful" \ xyz.xyz@xyz The above... (3 Replies)
Discussion started by: govindts
3 Replies

6. Shell Programming and Scripting

Mailx: How to send a attachment using mailx command

Hi All, Can anyone please provide the command for sending an mail with attachment using mailx command. Thanks in Advance :) Regards, Siram. (3 Replies)
Discussion started by: Sriram.Vedula53
3 Replies

7. Solaris

mailx not working

i am supporting a server running Solaris 5.6.I don't know if the mail is configured on this server. i ran the following commands and got the corresponding output. #which mailx /usr/bin/mailx #ps -ef | grep sendmail root 601 1 0 Jan 10 ? 0:01 /usr/lib/sendmail... (1 Reply)
Discussion started by: asalman.qazi
1 Replies

8. Shell Programming and Scripting

mailx not working

Hi All, I am strugging with mailx. I have a shell script which triggers mail when executed. I have mailx utility installed in system under /usr/bin/mailx but still when that script executes i am not getting mails..any idea why strange behaviour..? Tha:(nks in advance Usha (2 Replies)
Discussion started by: usha rao
2 Replies

9. Solaris

mailx is not working.......

Hi All, I am working with solaris 5.9 servers.After some patch installation my mailx is not working in the server.I am using IBM Lotus Notes. Please help me to solve this issue (4 Replies)
Discussion started by: Renjesh
4 Replies

10. UNIX for Dummies Questions & Answers

mailx -s not working right

I have set up in Solaris to email me and I received emails on the OS level. However, I don't get the mail in my MS Outlook. Please advise. Thanks in advance. (3 Replies)
Discussion started by: simt
3 Replies
Login or Register to Ask a Question

Featured Tech Videos