Problem with crontab

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problem with crontab
# 1  
Old 08-16-2002
Problem with crontab

I am trying to schedule a job to run through cron that checks for high CPU usage. The 'top' command is run and the output is logged to a file. A calculation is done in the file to check if CPU runs above 80%. If this happens an email is sent out.

The problem I am having is that when I run this manually from the command prompt is runs fine. When I run it through cron it doesn't output teh results of the 'top' commnad to the file. Does anybody know why this would happen? The script uses awk commands as well. Any help will be appreciated.

# 2  
Old 08-16-2002
post how you are running top and a bit of the script.
should be something simple.
# 3  
Old 08-16-2002

Jobs from cron do not have the same envrionment as it runs in a command shell, this causes mostly the problem you describe.

A way to fix, load your personel .profile in the cronjob script

~x/.profile # Where x=username


exit # End of script
# 4  
Old 08-16-2002
Problem with crontab

Here is part of the script. I tried to execute the .profile within the script but its not working. I think my command may be wrong. I'm using KornShell, do you know what the correct command for executing the .profile with a KornShell script is?

Name=`uname -n`
TEXT=`echo 'Running TOP command on' $Name '\r'`
echo $Name
echo $TEXT
date > toplst.out
top >> toplst.out
REP_FILE=`grep '%' toplst.out | awk '{print $1,$10,$11,"\r"}'`
OUTPUT=`grep "%" toplst.out | awk 'BEGIN{ print }
sum += substr($10,1,4)
if (sum > 80)
# 5  
Old 08-21-2002
try these options

I would try running top with these options.

top -h -s 1 -d 1 > filename.out

This will give you the top output with no CPU data (-h) if you have 8/16 or more like I do with HP. Also, this will give you a 1 second (-s 1) snapshot and quit after 1 iteration the top (-d 1).

I had the same problem running a cronjob with glance on HPUX which prints to the console an active screen.

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

problem with crontab

hi all does any on has explanation for this result bash-3.00$ crontab -e "/var/tmp/Ex1kayUW" No space left on device The crontab file was not changed. bash-3.00$ (2 Replies)
Discussion started by: osmannix
2 Replies

2. UNIX for Advanced & Expert Users

crontab problem

hi.. i have a program (, and i want what it runs automatically with a "lapsus" of 2 hours. (1,3,5,7,9,11,13,15,17,19,21,23 hrs.) i know what i have to do it using crontab, but i donīt know how to do it. i have the next idea, but the problem is what it doesnīt run on my server... (11 Replies)
Discussion started by: DebianJ
11 Replies

3. AIX

Crontab problem

Hi to all. Guys, i have a truble with oracle user crontab. He work if i'm do 0-59 * * * * echo LOL> ~/test.txt But not work if me set realy norm date For example 14 17 28 12 * echo LOL> ~/test.txt In 17:14 28 December . In log file /var/adm/cron/log nothing.... Please... (3 Replies)
Discussion started by: jess_t03
3 Replies

4. Shell Programming and Scripting

Problem in crontab

Hi All, Am facing an issue while updating the crontab.Getting below error while updating the cron. cron/tmp.XXXX5fXBR6: No space left on device crontab: edits left in /tmp/crontab.XXXXEJX5gw Is there any file where i need to alter using root user so that i can update the cron. TIA... (9 Replies)
Discussion started by: Ashok_oct22
9 Replies

5. Shell Programming and Scripting

Crontab Problem

Dear All , I have .sh script wich has the following inside getFileName=Listportfolio.txt.`date +'%Y%m%d` ftp -n<<EOF user xxx xxx bin cd /home/gbs/FTP_Script get /home/gbs/FTP_Script/$getFileName bye EOF EOF when I run the... (3 Replies)
Discussion started by: habuzahra
3 Replies

6. UNIX for Advanced & Expert Users

crontab problem

hi all while using crontab -e im receiving 754 as output im unable to add a entry in crontab crontab -l is working fine OS: sun5.8 can some one please assist me (4 Replies)
Discussion started by: NIMISH AGARWAL
4 Replies

7. UNIX for Dummies Questions & Answers

problem with crontab

i added to my crontab file: * * * * * echo "hello" it works, i receive a message into my /var/mail/username and i receive: bob in addition to a large text add-on any help appreciated (1 Reply)
Discussion started by: cleansing_flame
1 Replies

8. UNIX for Dummies Questions & Answers

Problem with crontab

I'm trying to get crontab to run a script, but to test crontab I tried out a very simple command: `echo bob` here is my crontab file (I edited it by using `crontab -e`): ----------------- #!/bin/sh 23 10 * * * echo bob and at 10:23 every day I get a new message: in /var/mail/a... (3 Replies)
Discussion started by: cleansing_flame
3 Replies

9. Shell Programming and Scripting

crontab problem

HI, i am working on linux. i have crontab problem i wrote a small script and put it in a crontab . but the script is not running.. i have given following way in crontab -e 02 06 * * * /bin/csh /home/vr_test.csh but the above script is not running please rectify my... (26 Replies)
Discussion started by: rajan_ka1
26 Replies

10. UNIX for Dummies Questions & Answers

crontab problem

Hi, I trying to include a script in my crontab as user. I used "crontab -e" to include my script there but does not seem to work. If I understand correctly it is set to run at 11:20 every day, correct? Can anybody identify any error? <pre> #Sun Microsystems Inc. SunOS 5.7 Generic... (19 Replies)
Discussion started by: guest100
19 Replies
Login or Register to Ask a Question