Apache Server 1.3.20 Icons Missing and Other Problems...Please Help!!!!

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Apache Server 1.3.20 Icons Missing and Other Problems...Please Help!!!!
# 1  
Old 08-12-2002
Apache Server 1.3.20 Icons Missing and Other Problems...Please Help!!!!

Hi everyone. Okay here are a couple of my problems and hopefully you
guys can help me out.

Problem 1: i have 2 website that are being hosted on a webserver. The
webserver is running redhat 8x and running apache 1.3.20. To make it a
little clearer, lets say website A and website B. Both website A and B
are working from the outside like if I go home and type in both
websites it works and all. But at work or internal network, website B
works perfect (whenever I type in the website name, it pops up the
index.htm file) but website A, when I type it in, gives me a directory
listing instead. How do I solve this problem. Website A is the main
website and Website B is the secondary website.

Problem 2: when I type in website A when I'm at work, the directory
listing shows however the icons of the files are missing. But if I go
to a directoy and then hit the back key on the browser, the icons
appears. If i hit refresh it disappear. I right click on the icon and
see where the pictures are located. I checked the folder and the icons
are there. How do I fix this?

Problem 3: is there a way to view the files in a directory in a
different way. Like a prettier way so to speak. If there is, how do I
do it?

well thanks in advance for any help you guys can offer.
# 2  
Old 08-12-2002
it sounds like your apache configuration for website a is misconfigured, an easy, EASY way to do it, is webmin, haha its like cheating but it really is a BIG help and will increase your uptime because problems with your system WILL be fixed alot quicker, go to webmin.com , i hope my answer wasnt too much of a cop-out for you. in apache you can configure what the default displayed file is, in otherwords your index.html , you can set that to be whatever you like, it can be main.html or default.asp , anything, also you have to specify to apache that you want that file displayed, or you want apache to give a directory listing, if dont want to download webmin its ok, just look around the apache config files, you will find it your problem will be easy to solve. oh that issue with the icons, i think that might be a problem with your web browser, not the server, though i am not sure, someone more expierenced than myself can probably help you with that.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Web Development

Problems with Apache Virtual Host

I am attempting to add virtual hosts to an apache web server, which has this current configuration: <VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www <Directory /> Options FollowSymLinks AllowOverride None ... (27 Replies)
Discussion started by: Corona688
27 Replies

2. Debian

Help me with installing nagvis in nagios (Apache mod_php missing)

Hi Im new in this forum. I have setup a pc with debian, and installed nagios core, with basic functions like pings in all our departments. The plan is to install nagvis and make a map with "pins" on all our departmens, and then pin is green the department is up, and when its red its down. I have... (1 Reply)
Discussion started by: nielsen110
1 Replies

3. Solaris

Problems with 2 NICS and Apache

I have a Solaris 10 box that has 2 Ethernet connections. One is, this is on the main internal LAN. The other is this is the DMZ. I have Apache 2.0.59, I do not care which it Listens to but the main one for it is (DMZ) which I have been explicit (Listen... (1 Reply)
Discussion started by: crowman
1 Replies

4. Web Development

Problems starting Apache 2.0.54

Hi, I just installed Apache 2.0.54 and when I try and start httpd I get mohit@mohit-desktop:/sw/pkg/apache/bin$ ./httpd -k start httpd: Could not determine the server's fully qualified domain name, using for ServerName (13): make_sock: could not bind to address :80 no listening... (1 Reply)
Discussion started by: mojoman
1 Replies

5. Web Development

Apache Problems.

Hello guys I have been running a LAMP stack for awhile now but have never really explored the server side end of things. What I am trying to do is have a python script on a website run a bash command. This will accomplish a system so someone can create an account for proxy access via a webpage.... (45 Replies)
Discussion started by: darkphaux
45 Replies

6. Web Development

Apache upload problems.

When I upload a file 32M or larger to fails. I can see the file being uploaded into the /tmp directory but when it gets to ~32M it dissapears. This is from phpinfo: upload_max_filesize 100M 100MB post_max_size 100M 100MB enable_dl On On I dont get an error in the log saying im... (9 Replies)
Discussion started by: Ikon
9 Replies

7. Solaris

Problems starting apache 1.3 with mysql

I've been working on a project to replace one of the my group's primary NIS servers. It also runs mysql and apache, as it is the host for the our team's hardware tracking database and website. Its running apache 1.3, and for some odd reason, I can't get apache to start on system boot. The... (1 Reply)
Discussion started by: godspunk32
1 Replies

8. Solaris

problems with Apache

I have a Solaris 8 box and need to install Apache 2.0.55 on it. First thing I tried was compiling from source code. During the make phase, I got the following errors: Then I tried downloading the binaries. I tried the one available from Apache's site and the one from sunfreeware.com, with... (3 Replies)
Discussion started by: GKnight
3 Replies

9. UNIX for Dummies Questions & Answers

Problems with Apache setup

I posted a problem with the forum on 11/18/02. Unfortunately, I have been out of town. Today is the first chance I've had to try the suggestions that were made. Here is the output from the ls -l configure* command: -rw-r--r-- 1root sys 58230 May 21 2002 configure When I type " sh... (2 Replies)
Discussion started by: cstovall
2 Replies

10. UNIX for Dummies Questions & Answers

Problems with Apache setup

I downloaded Apache 1.3.27.tar.gz into my SCO u/install directory. However, to begin with, I couldn't untar the file using the " tar xvf apache-1.3.27.tar.gz" command, so I used winzip from a windows computer on our network. Winzip untarred the file and I transferred the files to the SCO... (2 Replies)
Discussion started by: cstovall
2 Replies
Login or Register to Ask a Question