Visit Our UNIX and Linux User Community


su permission


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers su permission
# 1  
Old 06-05-2002
su permission

Hi Forums,

It seems to me that I can't use "su" command. When I type "su", I get the following message:
/sbin/su - Permission denied

Am I missing any thing?

By the way I am using IRIX6.5 on a SGI computer. Many thanks in advance for your help.

Cheers, Siavoush

Last edited by siavoush; 06-05-2002 at 09:40 PM..
# 2  
Old 06-06-2002
Check the permissions on the file -
ls -l /sbin/su

If you can not do that, check the permissions on the directory
ls -ld /sbin

Check for read - execute on both for world or group (group would be fine as long as you belong to the group). If the file/directory do not have r-x for group or world, then you cannot excute the program.
# 3  
Old 06-06-2002
Most System Admins will revoke users permissions to su to another user. If you are root you should never receive this error message.

If you are logged in as yourself and you type: su username

and still get the error message see your administrator.
# 4  
Old 06-07-2002
hi,

how made the admin this??? i want that an error occurs wenn the user type in su!!! ist there a config file??

greetz
adme
# 5  
Old 06-08-2002
Configuring su for a user depends on the operating system. If you are using AIX these rights can be removed using smit. If you are using another system search the companies website for user properties or security settings. Most companies will give you some information, if not all, on how to control there system via the internet.
# 6  
Old 06-10-2002
Dear adme,

There are several Security software packages that will monitor unauthorized access to root user which will give email to root.

Also, I don't know what OS version you are using, but in HPUX, there is a config file that allows/restricts su rights, called scfmgr.

However, it is proprietary to HPUX only. Many versions of UNIX don't regulate the su command other than changing the permissions.

Just turing off su to all except root is sometimes impossible to do because some applications, ie Oracle, NetBackup, need su ability to get to root to execute some commands as root.


You will just have to protect the root password closely.
Smilie
# 7  
Old 06-12-2002
su Running with insufficient privilege.

Dear Forum,

I have changed the permission for su and now it looks like this:

-rwxr-xr-x 1 root sys 44368 Jan 25 2001 /sbin/su*

I am also a member of system and have been granted all privileges. However, when I am logged in as myself, I get the following message:

Running with insufficient privilege.

Any help much appreciated.

Cheers,
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #374
Difficulty: Easy
In 2004, a new edition of the POSIX:2002 standard was released called POSIX:2004 (formally: IEEE Std 1003.1-2004).
True or False?

10 More Discussions You Might Find Interesting

1. Ubuntu

Permission denied

Trying to get date into the txt file. It says Permission denied. echo $(date +%I:%M:%S_%D) >> /tmp/systemd_suspend_test_err.txt exec 2>> /tmp/systemd_suspend_test_err.txt if ; then # Do the thing you want before suspend here echo "we are suspending $(date +%I:%M:%S_%D)." elif ;... (5 Replies)
Discussion started by: drew77
5 Replies

2. Linux

Permission denied

I am using korn shell When I type in Telnet on cmd line, I get message "cannot execute" How can I get permission to execute command ? In which dir is telnet located ? I looked in /usr/bin dir. but its not there Thanks (1 Reply)
Discussion started by: paramshamnani
1 Replies

3. UNIX for Dummies Questions & Answers

really need help with permission changes

I dont understand why permission changes are being such a pain in the bum even after I manually changed them through properties....Anyone know what to do here because even thoguh in properties the permissions make me local admin over in the Cygwin its not working.. ... (5 Replies)
Discussion started by: okhawaja
5 Replies

4. UNIX for Dummies Questions & Answers

Permission

Hello Whenever we want to oen any type of file by name, we must have execute perm. in each dir. mentioned in the name. I changed the dir permission using chmod to test the validity of this statement. but i still can open the file ------- any guides would be appreciable (2 Replies)
Discussion started by: dr_mabuse
2 Replies

5. Ubuntu

Permission (I Think)

Pictures by worthamtx - Photobucket The URL is graphic view my present concern. Old partition working great sdb1 both appear on nautilus, both deliver icons to desk top. Based on the label handling of gparted results I tried following with success sudo mkdir /media/disk/data sudo chown... (1 Reply)
Discussion started by: 77yrold
1 Replies

6. UNIX for Dummies Questions & Answers

User permission

Hi all, I created testuser. by following command. /usr/sbin/adduser -n test -d /disk05/collections/GET/testdata/ and then set its password by following command. passwd testuser When I login to system by testuser, it enters everything is ok. The problem is how to set permission to this... (3 Replies)
Discussion started by: mr_bold
3 Replies

7. UNIX for Dummies Questions & Answers

File Permission

Hi, When I listed one directory in Sun, it showed that : -rwsr-xr-x 1 root bsmbin 78004 Oct 21 2004 bsmprsm I don't know meaning of the character "s" in "rws" above. I have searched in Sun admin documents but no result. Would you please explain it ? :) Thank you so much. (1 Reply)
Discussion started by: msg098
1 Replies

8. UNIX for Dummies Questions & Answers

Permission?

What does the following permission indicate? -rwSr----- 1 oracle dba 1536 Nov 7 17:05 orapwRTMDB Thanks, Rahul. (1 Reply)
Discussion started by: rahulrathod
1 Replies

9. UNIX for Dummies Questions & Answers

permission

Is it possible to set owner to a group? I need to have a group own a process, because there will be 3 diffrent persons that will start and stop this process. They can not use the same users cause och back logging. we need to know who end when a certian user start/stops processes. (1 Reply)
Discussion started by: dozy
1 Replies

10. UNIX for Dummies Questions & Answers

permission help

Ok heres the situation I've been studying Solaris 8 for about 6 months now and some things click in my head but others don't. One of the things that don't click are file permissions. For example I login at work and I use the ls -l command to get a long listing of the files w/ the permissions.... (2 Replies)
Discussion started by: eloquent99
2 Replies

Featured Tech Videos