SCSI Tape Error


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers SCSI Tape Error
# 1  
Old 05-23-2002
Question SCSI Tape Error

When I am trying to read any tape I getthe following message on my screen:
"stp: Error on SCSI tape=0 (ha=0 id=6 lun=0)"

Does anybody know how to solve this problem and what the message means.

I already have rebooted the server and cleaned the heads of the tape unit.

HELP!!!!
# 2  
Old 05-23-2002
You need to change the device name for the 'tape unload' command. Lets say that you backup using '/dev/rStp0'... then the unload command should call '/dev/nrStp0'. Why??? The rewind device (rStp0) is trying to do a rewind after eject and 'nrStp0' will *not* attempt to rewind. After done do a test like below:

# tape unload /dev/rStp0
# tape unload /dev/nrStp0

Here's the major/minor numbers:
crw-rw-rw- 4 root other 46, 12 Mar 21 1997 nrStp0
crw-rw-rw- 7 root other 46, 4 Aug 09 15:00 rStp0

There is a shell script available to help determine the correct device for you to use:
ftp.cactus.com/cowboy/backitup/test_tape_cmd

Also if you use LONE-TAR to eject the tape then make sure you go into the 'ENV.menu' and change #23 to reflect the new device name.
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Adding Legacy SCSI tape to Ent Rel 6 64

I have Ent Rel 6 64 bit running in a virtualized environment. I wish to add a Ultium 3 U320 Scsi tape drive. I add an LSI LSI20320IE SCSI controller to the virtual server. The controller shows under the machine settings, but the OS doesn't see a tape drive. /proc/scsi/scsi shows only Virtual CDRom... (0 Replies)
Discussion started by: adone36
0 Replies

2. Hardware

Help with scsi tape drive problem

I've had a scsi hard drive, scsi tape drive, and cd rom working off an adaptec 29160 controller. Everything worked great until a few days ago. I begin getting tar format errors (running sco 5.0.6) on the tape drive and occasionally the entire system would hang up while trying to access data on... (0 Replies)
Discussion started by: powwm
0 Replies

3. UNIX for Dummies Questions & Answers

Problems with SCSI card and tape drive

Currenty running SCO Openserver 6 at a Dell PowerEdge T300. I recently installed a driver for an Adaptec SCSI card (adpu320). When I connect a tape drive to it and re-start the system,it freezes and displays the following message: "WARNING: adpu320: Command timed out (ha= 4)" and the system... (2 Replies)
Discussion started by: RicardoM
2 Replies

4. Solaris

Restoring dump from tape to SCSI disk

Hi Gurus, I need help. Mine is an Ultra 10 machine running on solaris 7. Problem with solaris 7 is, it can no longer recognize IDE disks greater that 10GB. My workaround is ro use an external SCSI disk since it is recognizable with solaris 7. I backup my filesystems (residing on the IDE... (2 Replies)
Discussion started by: domesat
2 Replies

5. SCO

SCSI tape on Openserver 5.0.6

Running into an interesting problem here: I can add the tape with "mkdev tape" the system appears to see it wwith "hwconfig -hc" however a 'tape status /dev/rStp0' says 'no device found', checked the configuration files in 'etc' all appear to be correct. Any suggestion appreciated Jim (3 Replies)
Discussion started by: jimj1369
3 Replies

6. SCO

Installing SCSI Tape drive

Hello, I'm having some issues with installing SCSI tape drive on SCO 5.0.6 hardware config shows the following adapters %adapter 0xE800-0xE8FF 10 - type=alad ha=0 bus=0 id=7 fts=sto %adapter 0x0170-0x0177 15 - type=IDE ctlr=secondary dvr=wd %adapter - 3 - ... (3 Replies)
Discussion started by: ananth_ak
3 Replies

7. HP-UX

Modules Required For SCSI Tape?

I've got an HP9000 server and I'm trying to hook up a tape drive to it. When I go into "SAM-->Peripheral Devices-->Tape Drives", the tape isn't listed. I then choose to "ADD" a drive, and I get the following error. I know I need to install the "stape" module, but for some reason even that... (2 Replies)
Discussion started by: quantumdude
2 Replies

8. Solaris

mounting an external scsi tape drive

hi- I just installed a quad gigaswift ethernet scsi card to my sunblade 150. I checked with the docs, and got all of the required drivers on the box. Now, I'm trying to mount an external scsi tape drive with no luck. I set the scsi address on the external drive to 0. Here's what I'm coming... (9 Replies)
Discussion started by: ECBROWN
9 Replies

9. UNIX for Dummies Questions & Answers

Scsi tape drive.

I'm running SCO OS 505 on a Compaq proliant 1600, and my tape drive will just not work. It was working properly and whent to Sh?ts when I tried to get the cd rom working. I have uninstalled any configured tape drive and rebooted and then configured a tape drive and rebooted still nothing. I'm... (4 Replies)
Discussion started by: kikkin
4 Replies

10. UNIX for Dummies Questions & Answers

Scsi Tape Message?????

I do daily backups running a shell script. I use 6 different tapes for each day (monday through saturday). First of all I insert the tape then run the script and when it finished I eject the tape. Until today I was doing this with no problem, but now I'm getting this message constantly (even... (4 Replies)
Discussion started by: rrivas
4 Replies
Login or Register to Ask a Question

Featured Tech Videos