boot sector for Solaris 8

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers boot sector for Solaris 8
# 1  
Old 04-16-2002
Question boot sector for Solaris 8

Hi all,

I was wondering if anyone knows how to make a boot sector for Solaris 8. I'm trying to install solaris 8 via the network and I'm get error "files just loaded does not seem to be executable" at the ok propmt. Has anyone encouter this problem before? THANKS advance
# 2  
Old 04-16-2002
If you have a Solaris 8 4/01 or newer, and you want to install
the Solaris 8 via the network is recommendable to use jumpstart:

An undocumented tip is to add in the /etc/system the
following two lines:
set rlim_fd_max=8096
set hsfs:nhsnode=8096
and then reboot.

a- Create a big Filesystem /jumpstart (2Gb or more)

b- Insert the Solaris 8 CD 1
cd /cdrom/sol_8_401_sparc/s0/Solaris_8/Tools
./setup_install_server /jumpstart/OS/Solaris_8_2001-04

c- when you was received the message "Install Server setup complete"
eject cdrom

d- Insert The Solaris 8 Cd 2
cd /cdrom/sol_8_401_sparc_2/Solaris_8/Tools
./add_to_install_server /jumpstart/OS/Solaris_8_2001-04

e- when you was received the message "Processing completed successfully"
eject cdrom

f- share -F nfs -o ro,anon=0 -d "Jumpstart" /jumpstart
(remember /etc/init.d/nfs.server start if not yet started)

g- shareall

h- Make the entry of the client in the /etc/hosts

i- make the entry of the client in the /etc/ethers

j- create a /jumpstart/sysidcfg file
network_interface=hme0 {netmask=
(you need to replace with the apropiate values see: man

k- create a generic rule file
any - - generic_profile -

k.1 or create a specific rule (you need to create the apropiate
model SUNW,UltraSPARC-IIi && memsize 256-512 && disksize c0t0d0 8192-194560 - Profiles/FE/normal_FE.profile Finish/

model SUNW,UltraSPARC-IIi-cEngine && memsize 256-512 && disksize c0t0d0 8192-194
560 - Profiles/FE/normal_FE.profile Finish/

model SUNW,UltraSPARC-IIi-cEngine && memsize 1024 && disksize c0t0d0 8192-194560
- Profiles/FE/robust_FE.profile Finish/

model SUNW,Ultra-80 && memsize 2048-6144 && disksize c0t0d0 8192-194560 - Profil
es/BE/robust_BE.profile Finish/

model SUNW,Ultra-80 && memsize 512-1024 && disksize c0t0d0 8192-194560 - Profile
s/BE/normal_BE.profile Finish/
# any - - Profiles/basic.profile -

l- create the generic_profile file
install_type initial_install
system_type server
root_device c0t0d0s0
partitioning explicit
filesys rootdisk.s0 3072 /
filesys rootdisk.s1 1024 swap
filesys rootdisk.s3 9216 /opt
filesys rootdisk.s5 3072 /var
filesys rootdisk.s6 720 /var/spool
filesys rootdisk.s7 128 /export/home
geo N_America
geo S_America
locale en_US
cluster SUNWCall
package SUNWpmux delete
package SUNWpmu delete
package SUNWpmr delete
package SUNWpmowr delete
package SUNWpmowu delete
package SUNWpmowm delete
(customize with your preferences)

m- Check your rules file
cd /jumpstart
cp /jumpstart/OS/Solaris_8_2001-04/Solaris_8/Misc/jumpstart_sample/check .
(this step create a rules.ok file needed for the installation)

n- run the add_install_client
cd /jumpstart/OS/Solaris_8_2001-04/Solaris/Tools
./add_install_client -e <MAC_client> -i <IP_client> -c <your_ip_jumpstart_server>:/jumpstart <client_machine_name> <platform>

o- if the jumpstart configuration is ok
in the client side at the boot prompt
ok> boot net - install

See the apropiates man pages and good luck, and excuse my poor english (I speek spanish)

Last edited by hugo_perez; 01-07-2003 at 10:13 AM..
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Solaris

Solaris stuck during boot after reconfigure boot

Hello, I have a problem with my machine that won't boot properly. The story is that I installed a software called apcupsd, which is a control application for my APC battery UPS. I have used version 3.14.10 earlier, but as part of restoring my previously crashed os harddrive I wanted to... (18 Replies)
Discussion started by: Zorken
18 Replies

2. AIX

AIX unreadable sector Logical or Physical

Hello Folks, I have got this message: When I contacted support, they said this is logical filesystem error and it has to do with the filesystem. How can I find out ? (1 Reply)
Discussion started by: filosophizer
1 Replies

3. Linux

Sector,cylinder,track information

Hi all, I am trying to get below information from linux machine, could you please assist me to get this information using a command(s) or small script: SectorsPerTrack TotalCylinders TotalHeads TotalTracks TracksPerCylinder i am aware of fdisk -l command but the information provided by... (1 Reply)
Discussion started by: omkar.jadhav
1 Replies

4. Solaris

dual boot solaris/solaris zfs file system

Hi, I am running into a some problems creating a dual boot system of 2 solaris instances using ZFS file system and I was wondering if someone can help me out. First some back ground. I have been asked to change the file system of our server from UFS to ZFS. Currently we are using Solaris... (3 Replies)
Discussion started by: estammis
3 Replies

5. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

6. AIX

Repair boot sector after stupidly importing disk into vg?

Hey guys, I've bought a second-hand RS/6000 hardware with freshly installed AIX 5.3 on disk2 and freshly installed AIX 6 on disk1. I'm in possession of the original 5.3 install cds but the AIX 6 installation is just on the disk, I've no install media. So first after getting the system, I... (3 Replies)
Discussion started by: selzeda
3 Replies

7. Solaris

solaris boot problem boot error loading interpreter(misc/krtld)

When I installed the SOLARIS 10 OS first time, the desktop would not start up, this was because of network setup. Reinstalled worked. After a week due to some problem I had to reinstall OS, installation went fine and but when i reboot I get this error. cannot find mis/krtld boot error loading... (0 Replies)
Discussion started by: johncy_j
0 Replies

8. Programming

Accessing info from Boot Sector of Diskette

I am writing a Floppy Disk Driver and need to find out what the "Sectors per track", "Tracks per cylinder", and the "number of cylinders" on a disk. I have a book that tells me that this info is held in the boot sector of the disk in locations such as: 0x18 0x19 Sectors per track But... (0 Replies)
Discussion started by: compdaugh
0 Replies

9. Filesystems, Disks and Memory

boot sector bad? or is is something else?

SuSE 8 Both LILO and GRUB are complaining about not being able to write to the boot sector. Is this definitely a problem with the drive or is there another possible problem? I've checked the BIOS and I don't think the problem is's probably the drive. Just another Linux user (1 Reply)
Discussion started by: HumanBeanDip
1 Replies
Login or Register to Ask a Question