usb - deleting (irq)

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers usb - deleting (irq)
# 1  
Old 04-16-2002
usb - deleting (irq)

FreeBSD 4.5
i installed my sound drivers (which are onboard) with the following lines in my kernel
device pcm
options PNPBIOS

then cd /dev
sh MAKEDEV snd0

output from cat /dev/sndstat show the devicedriver (correct one)

ok this works nice
untill i enter my kde and want to play a song. There i see in the terminal ***WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Device busy (i have my acces (xwr)to /dev/dsp and its links)
now, i thought it could be it's using the same irq as an other device and i did #dmesg pcm and say it is using the same irq (11) as USB A. That pissed me off Smilie i don't need USB but it's all onboard unfortunately so i tried to rebuild my kernel without the USB declaration in it but yet every time i reboot with new kernels, the USB is still present!. How can i really get those USB lines out of my kernel or perhaps even better; how can i chance irq for the devices?

i hope someone might know the answer because we've been looking on the problem with 3 people.

ow yeah, also tried it without the PNPBIOS option
# 2  
Old 04-18-2002
thougth somebody would like to know how i'm doing with my sound?
wel, still nothing but i learned again some important things
like you cannot change you're irq's in freebsd so i changed them in BIOS, deleted usb irq, changed sound irq, switched sound irq with screen, ... nothing helped.

still getting the same error msg which basicly says "request interrupt timeout, channel is dead"
and after that, the output of /dev/dsp is
"Device busy"

i tried almost everything in my kernel from option PNPBIOS (on/off),
device pcm
device pcm0

strange thing is, he finds the correct device when is cat /dev/sndstat

is there anybody who has any idea on how this could be solved?
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Hardware

IRQ and Number of Devices

Hello everyone. I feel that I'm about to answer my own question, but I just want to be sure that I'm right. I know computers all use, at a very low level, the IRQ system of interrupting the CPU when it needs something. My questions are as follows: 1. Does the device in question, say.. a mouse,... (1 Reply)
Discussion started by: Lost in Cyberia
1 Replies

2. Programming

What is unbalanced IRQ?

------------------------ WARNING: at kernel/irq/manage.c:225 __enable_irq+0x3b/0x57() Unbalanced enable for IRQ 4 Modules linked in: svsknfdrvr Pid: 634, comm: ash Tainted: G W 2.6.28 #1 Call Trace: warn_slowpath+0x76/0x8d profile_tick+0x2d/0x57 irq_exit+0x32/0x34 ... (3 Replies)
Discussion started by: dragonpoint
3 Replies

3. UNIX for Dummies Questions & Answers

USB-USB cable between linux and windows computers

Is there an easy way to setup a cross-over cable (USB-USB) between a linux box and a windows PC? My 2 machines are next to each other but I really do not want to keep transfering my files using my USB drive. Thanks! (4 Replies)
Discussion started by: Xterra
4 Replies

4. UNIX for Dummies Questions & Answers

Doubt with irq handler.......

Hello, I have develop a driver for my hardware and now, I need to handle a IRQ but I does not work. As I can understand, to handle a irq, it is necessary to make a request_irq(). If the return value is zero, ok, no problem to handle irq. Here is a easy example of my driver: #include... (8 Replies)
Discussion started by: webquinty
8 Replies

5. Linux

A question with respect to IRQ distribution

Hi all, I am a Linux newbie in kernel development. In class I was asked a question about IRQ distribution as followed. IRQs can be distributed among the available CPUs (in a multiple-CPU system) in two ways: (1) Static distribution The IRQ signal is delivered to the local APICs listed... (2 Replies)
Discussion started by: sunnyhay
2 Replies

6. SCO

IRQ conflict between USB and NIC SCO 5.0.7

I have a SCO 5.0.7 server.As there is no parellel port ,printing is done via USB port. After loading the Network Card driver ,during booting the server gets hanged and the NIC driver is not loaded.If the USB ports are disabled the NIC driver gets loaded. As both USB and NIC driver are essential... (0 Replies)
Discussion started by: vikramviky
0 Replies

7. UNIX for Advanced & Expert Users

IRQ priority in FC9

Hi, I want to increase IRQ4 priority to maximum in Fedora core 9 (kernel version anybody knows plz help me.... I will be very thankful .. regards, Raj (0 Replies)
Discussion started by: rajuprade
0 Replies

8. UNIX for Dummies Questions & Answers

irq complication

hi, i looked around already and had no luck finding anything. Im trying ot install a wpc11v3 linksys wireless card, and i have been for about a week now. :mad: Im near certain i have figured out my problem. When i plug in my card while knoppix is running, it crashes. When i plug it into... (0 Replies)
Discussion started by: jestra
0 Replies

9. UNIX for Dummies Questions & Answers


where can i find the i/o and irq's in mandrake 8 help lost :D (2 Replies)
Discussion started by: RYRY46D9
2 Replies
Login or Register to Ask a Question